aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash-devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-09 12:34:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-09 12:34:13 +0000
commitbaca239922cb074d13953a81ec730c739f846ae8 (patch)
treeac6921cb6f9f64f771365a79d4703e278a4d2210 /graphics/gnash-devel
parent7c3b8a611aebedf72d9041b8fee6d12854d6285a (diff)
downloadports-baca239922cb074d13953a81ec730c739f846ae8.tar.gz
ports-baca239922cb074d13953a81ec730c739f846ae8.zip
Notes
Diffstat (limited to 'graphics/gnash-devel')
-rw-r--r--graphics/gnash-devel/Makefile29
-rw-r--r--graphics/gnash-devel/distinfo6
-rw-r--r--graphics/gnash-devel/pkg-plist3
3 files changed, 25 insertions, 13 deletions
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
index 9d7f73ba0cf9..8137d5b4de7f 100644
--- a/graphics/gnash-devel/Makefile
+++ b/graphics/gnash-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 20081030
-PORTREVISION= 2
+PORTVERSION= 20081208
CATEGORIES= graphics
# gnashdev.org is slower
MASTER_SITES= http://www.amdmi3.ru/distfiles/ \
@@ -26,7 +25,7 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
CONFLICTS= gnash-[0-9]*
-REVISION= 10051
+REVISION= 10395
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -64,7 +63,8 @@ OPTIONS= PLUGIN "Enable browser plugin" on \
OPENGL "Renderer: OpenGL (broken)" off \
CAIRO "Renderer: Cairo (experimental)" off \
FFMPEG "Media handler: ffmpeg (+SDL sound output)" on \
- GSTREAMER "Media handler: GStreamer" off
+ GSTREAMER "Media handler: GStreamer" off \
+ SPEEX "Speex codec support" on
.include <bsd.port.pre.mk>
@@ -160,7 +160,8 @@ IGNORE= can't be built with multiple or without renderers enabled. Please reru
#
.if defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+= --enable-media=ffmpeg
+CONFIGURE_ARGS+= --enable-media=ffmpeg \
+ --with-ffmpeg-incl=${LOCALBASE}/include/ffmpeg
USE_SDL+= sdl
.elif !defined(WITH_FFMPEG) && defined(WITH_GSTREAMER)
USE_GSTREAMER= yes
@@ -172,6 +173,16 @@ CONFIGURE_ARGS+= --enable-media=none
IGNORE= can't be built with multiple media handlers enabled. Please rerun 'make config' and leave one or none of them (ffmpeg|gstreamer)
.endif
+#
+# Other options
+#
+.if !defined(WITHOUT_SPEEX)
+LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+CONFIGURE_ARGS+= --enable-speex
+.else
+CONFIGURE_ARGS+= --disable-speex
+.endif
+
pre-everything::
.if defined(WITH_OPENGL)
@${ECHO_CMD} "OpenGL support is currently broken (Gnash hangs using 100% CPU). Use at your own risk"
@@ -182,13 +193,11 @@ post-patch:
@${REINPLACE_CMD} -e '/^PTHREAD_[LC][IF]*=/ d; s|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
- s|/lib64|/lib|g; \
- s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure \
- ${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
+ s|/lib64|/lib|g; s|/usr/X11R6|${LOCALBASE}|g' \
+ ${WRKSRC}/configure ${WRKSRC}/macros/libslist \
+ ${WRKSRC}/macros/incllist
@${REINPLACE_CMD} -e '/sysconfDATA_INSTALL/ s|/$$$$f|&.dist|' \
${WRKSRC}/libbase/Makefile.in
- @${REINPLACE_CMD} -e '/^gprocessor_LDFLAGS =/ s|$$| $$(AM_LDFLAGS)|' \
- ${WRKSRC}/utilities/Makefile.in
post-install:
if [ ! -f ${PREFIX}/etc/gnashrc ]; then \
diff --git a/graphics/gnash-devel/distinfo b/graphics/gnash-devel/distinfo
index cf0fd77bb934..98241ea85c89 100644
--- a/graphics/gnash-devel/distinfo
+++ b/graphics/gnash-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-trunk-10051.tar.tgz) = 531d51ca0d3af28aaadd0b8ee7160c4d
-SHA256 (gnash-trunk-10051.tar.tgz) = bd7055c50edfcd8939b67fff046457aa47a1398bafdc6cbf2feebddcc845b2ec
-SIZE (gnash-trunk-10051.tar.tgz) = 3935699
+MD5 (gnash-trunk-10395.tar.tgz) = ee500762aaf809b53c08a3cbcfb3c0e7
+SHA256 (gnash-trunk-10395.tar.tgz) = 6b230424956beb86802e009cf6e9be28afea0116ccf1060df0380240da59f7bc
+SIZE (gnash-trunk-10395.tar.tgz) = 4167955
diff --git a/graphics/gnash-devel/pkg-plist b/graphics/gnash-devel/pkg-plist
index d67932f9985a..8b8cdc664a16 100644
--- a/graphics/gnash-devel/pkg-plist
+++ b/graphics/gnash-devel/pkg-plist
@@ -33,6 +33,9 @@ lib/gnash/libgnashmedia.so
lib/gnash/libgnashnet.la
lib/gnash/libgnashnet.so
lib/gnash/libgnashnet.so.0
+lib/gnash/libgnashsound-%%GNASHVER%%.so
+lib/gnash/libgnashsound.la
+lib/gnash/libgnashsound.so
%%GTK%%lib/gnash/libmozsdk.la
%%GTK%%lib/gnash/libmozsdk.so
%%GTK%%lib/gnash/libmozsdk.so.0