aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash-devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-02 20:44:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-02 20:44:35 +0000
commit9d9a42d35df4b05160b683bb71edfd83d37cd519 (patch)
treea887dcf860c7aa568cbdcf2ca3a6ca5ab3621efa /graphics/gnash-devel
parent85cae389450bc0df94be8efb3c7af5ab4b7a349e (diff)
downloadports-9d9a42d35df4b05160b683bb71edfd83d37cd519.tar.gz
ports-9d9a42d35df4b05160b683bb71edfd83d37cd519.zip
Notes
Diffstat (limited to 'graphics/gnash-devel')
-rw-r--r--graphics/gnash-devel/Makefile43
-rw-r--r--graphics/gnash-devel/distinfo6
-rw-r--r--graphics/gnash-devel/files/patch-backend-render_handler_ogl.h178
-rw-r--r--graphics/gnash-devel/files/patch-server-asobj-flash-geom-Point_as.cpp14
-rw-r--r--graphics/gnash-devel/files/patch-server-asobj-flash-geom-Rectangle_as.cpp15
-rw-r--r--graphics/gnash-devel/pkg-plist28
6 files changed, 44 insertions, 240 deletions
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
index da4ba1bfe09d..620cb3062a75 100644
--- a/graphics/gnash-devel/Makefile
+++ b/graphics/gnash-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-DISTVERSION= 20080515
-PORTREVISION= 1
+DISTVERSION= 20080927
CATEGORIES= graphics
# gnashdev.org is slower
MASTER_SITES= http://www.amdmi3.ru/distfiles/ \
@@ -19,7 +18,8 @@ COMMENT= GNU Flash movie player
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- curl.4:${PORTSDIR}/ftp/curl
+ curl.4:${PORTSDIR}/ftp/curl \
+ ungif.5:${PORTSDIR}/graphics/libungif
CONFLICTS= gnash-[0-9]*
@@ -28,11 +28,11 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
WANT_SDL= yes
WANT_GNOME= yes
-USE_GCC= 4.2+
+USE_GCC= 4.2+ # triggers compiler error on gcc 3.4
WANT_GSTREAMER= yes
USE_GNOME= pkgconfig libxml2
USE_XORG= x11 xau xdmcp xext xi xinerama ice sm
-USE_AUTOTOOLS= libltdl:15 automake:19:env autoheader:262:env autoconf:262:env aclocal:19:env libtool:15:env
+USE_AUTOTOOLS= libltdl:15 libtool:15:env
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -43,7 +43,10 @@ CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-npapi-plugindir="${PREFIX}/lib/browser_plugins" \
--with-kde-pluginprefix="${PREFIX}"
-WRKSRC= ${WRKDIR}/${PORTNAME}-0.8.3
+GNASHVER= trunk
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GNASHVER}
+PLIST_SUB+= GNASHVER="${GNASHVER}"
USE_LDCONFIG= ${PREFIX}/lib/gnash
@@ -62,7 +65,7 @@ OPTIONS= PLUGIN "Enable browser plugin" on \
.include <bsd.port.pre.mk>
# Plugin option processing
-.if defined(WITH_GTK) && !defined(WITHOUT_PLUGIN)
+.if !defined(WITHOUT_GTK) && !defined(WITHOUT_PLUGIN)
PLIST_SUB+= FFPLUGIN=""
.else
PLIST_SUB+= FFPLUGIN="@comment "
@@ -100,7 +103,7 @@ PLIST_SUB+= NLS="@comment "
#
GNASH_GUIS=
-.if defined(WITH_GTK)
+.if !defined(WITHOUT_GTK)
USE_GNOME= gtk20
GNASH_GUIS+= gtk
PLIST_SUB+= GTK=""
@@ -134,7 +137,7 @@ LIB_DEPENDS+= agg.2:${PORTSDIR}/graphics/agg
CONFIGURE_ARGS+= --enable-renderer=agg
.elif !defined(WITH_AGG) && defined(WITH_OPENGL) && !defined(WITH_CAIRO)
USE_GL= yes
-. if defined(WITH_GTK)
+. if !defined(WITHOUT_GTK)
LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
. endif
CONFIGURE_ARGS+= --enable-renderer=ogl
@@ -170,19 +173,27 @@ pre-everything::
@sleep 3
.endif
-pre-configure:
- @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./autogen.sh)
- @${REINPLACE_CMD} -e 's|^LIBS = |&$${INTLLIBS} |' \
- ${WRKSRC}/utilities/Makefile.in ${WRKSRC}/cygnal/Makefile.in
+post-patch:
@${REINPLACE_CMD} -e '/^PTHREAD_[LC][IF]*=/ d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
s|/lib64|/lib|g; \
s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure \
- ${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
+ ${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
+ @${REINPLACE_CMD} -e '/sysconfDATA_INSTALL/ s|/$$$$f|&.dist|' \
+ ${WRKSRC}/libbase/Makefile.in
-.if !defined(WITHOUT_PLUGIN)
post-install:
-.if defined(WITH_GTK)
+ if [ ! -f ${PREFIX}/etc/gnashrc ]; then \
+ ${INSTALL_DATA} ${PREFIX}/etc/gnashrc.dist \
+ ${PREFIX}/etc/gnashrc; \
+ fi
+ if [ ! -f ${PREFIX}/etc/gnashpluginrc ]; then \
+ ${INSTALL_DATA} ${PREFIX}/etc/gnashpluginrc.dist \
+ ${PREFIX}/etc/gnashpluginrc; \
+ fi
+
+.if !defined(WITHOUT_PLUGIN)
+.if !defined(WITHOUT_GTK)
@cd ${INSTALL_WRKSRC}/plugin && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install-plugin
.endif
diff --git a/graphics/gnash-devel/distinfo b/graphics/gnash-devel/distinfo
index db552c423a47..b0898ab77f80 100644
--- a/graphics/gnash-devel/distinfo
+++ b/graphics/gnash-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-20080515.tar.tgz) = dfa5293481120dda51473d5974cb6bee
-SHA256 (gnash-20080515.tar.tgz) = b1e9a6bdf45e154e095c6c98ab822e9014d1c822d0841166ec39681d77b7c6eb
-SIZE (gnash-20080515.tar.tgz) = 3666406
+MD5 (gnash-20080927.tar.tgz) = 9a3ce0f655ce72809f4d9dc56ae84e33
+SHA256 (gnash-20080927.tar.tgz) = fdebe69ccb8b5111df8a85673e303cee31c843f47163ee84f8da9f06bd3b60e2
+SIZE (gnash-20080927.tar.tgz) = 4023101
diff --git a/graphics/gnash-devel/files/patch-backend-render_handler_ogl.h b/graphics/gnash-devel/files/patch-backend-render_handler_ogl.h
deleted file mode 100644
index b4f4382b3e44..000000000000
--- a/graphics/gnash-devel/files/patch-backend-render_handler_ogl.h
+++ /dev/null
@@ -1,178 +0,0 @@
-diff -ruN backend/render_handler_ogl.h.orig backend/render_handler_ogl.h
---- backend/render_handler_ogl.h.orig 1970-01-01 03:00:00.000000000 +0300
-+++ backend/render_handler_ogl.h 2008-05-15 06:18:41.725653935 +0400
-@@ -0,0 +1,174 @@
-+//
-+// Copyright (C) 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
-+//
-+// This program is free software; you can redistribute it and/or modify
-+// it under the terms of the GNU General Public License as published by
-+// the Free Software Foundation; either version 3 of the License, or
-+// (at your option) any later version.
-+//
-+// This program is distributed in the hope that it will be useful,
-+// but WITHOUT ANY WARRANTY; without even the implied warranty of
-+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+// GNU General Public License for more details.
-+//
-+// You should have received a copy of the GNU General Public License
-+// along with this program; if not, write to the Free Software
-+// Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-+
-+#ifndef __RENDER_HANDLER_OGL_H__
-+#define __RENDER_HANDLER_OGL_H__
-+
-+
-+#if defined(NOT_SGI_GL) || defined(__APPLE_CC__)
-+#include <AGL/agl.h>
-+#include <OpenGL/gl.h>
-+#include <OpenGL/glu.h>
-+#include <OpenGL/glext.h>
-+#define GLUCALLBACKTYPE GLvoid (*)(...)
-+#else
-+# define GLUCALLBACKTYPE void (*)()
-+# include <GL/gl.h>
-+# ifdef WIN32
-+# define GL_CLAMP_TO_EDGE 0x812F
-+# else
-+# include <GL/glx.h>
-+# ifdef OSMESA_TESTING
-+# include <GL/osmesa.h>
-+# endif // OSMESA_TESTING
-+# endif
-+# include <GL/glu.h>
-+# ifndef APIENTRY
-+# define APIENTRY
-+# endif
-+#endif
-+
-+
-+
-+
-+namespace gnash {
-+
-+
-+
-+
-+typedef std::vector<const path*> PathRefs;
-+
-+
-+
-+struct oglVertex {
-+ oglVertex(double x, double y, double z = 0.0)
-+ : _x(x), _y(y), _z(z)
-+ {
-+ }
-+
-+ oglVertex(const point& p)
-+ : _x(p.x), _y(p.y), _z(0.0)
-+ {
-+ }
-+
-+ GLdouble _x;
-+ GLdouble _y;
-+ GLdouble _z;
-+};
-+
-+typedef std::map< const path*, std::vector<oglVertex> > PathPointMap;
-+
-+class Tesselator
-+{
-+public:
-+ Tesselator();
-+ ~Tesselator();
-+
-+ void beginPolygon();
-+
-+ void feed(std::vector<oglVertex>& vertices);
-+
-+ void tesselate();
-+
-+ void beginContour();
-+ void endContour();
-+
-+ void rememberVertex(GLdouble* v);
-+
-+ static void
-+ error(GLenum error);
-+
-+ static void combine(GLdouble coords [3], void *vertex_data[4],
-+ GLfloat weight[4], void **outData, void* userdata);
-+
-+
-+
-+private:
-+ std::vector<GLdouble*> _vertices;
-+ GLUtesselator* _tessobj;
-+};
-+
-+class WholeShape
-+{
-+public:
-+ void newPath(const path& new_path)
-+ {
-+ PathRefs refs;
-+ refs.push_back(&new_path);
-+
-+ shape.push_back(refs);
-+ }
-+
-+ void addPath(const path& add_path)
-+ {
-+ PathRefs& refs = shape.back();
-+ refs.push_back(&add_path);
-+ }
-+
-+ void addPathRefs(const PathRefs& pathrefs)
-+ {
-+
-+ PathRefs new_refs(pathrefs.begin(), pathrefs.end());
-+
-+ shape.push_back(new_refs);
-+ }
-+
-+
-+ const std::vector<PathRefs>& get() const
-+ {
-+ return shape;
-+ }
-+
-+private:
-+ std::vector<PathRefs> shape;
-+
-+};
-+
-+
-+class bitmap_info_ogl : public bitmap_info
-+{
-+ public:
-+ bitmap_info_ogl(image::image_base* image, GLenum pixelformat,
-+ bool ogl_accessible);
-+ ~bitmap_info_ogl();
-+
-+ void apply(const gnash::matrix& bitmap_matrix,
-+ render_handler::bitmap_wrap_mode wrap_mode);
-+ private:
-+ inline bool ogl_accessible() const;
-+ void setup();
-+ void upload(boost::uint8_t* data, size_t width, size_t height);
-+
-+ std::auto_ptr<image::image_base> _img;
-+ GLenum _pixel_format;
-+ GLenum _ogl_img_type;
-+ bool _ogl_accessible;
-+ GLuint _texture_id;
-+ size_t _orig_width;
-+ size_t _orig_height;
-+};
-+
-+
-+
-+
-+
-+
-+} // namespace gnash
-+
-+
-+#endif // __RENDER_HANDLER_OGL_H__
-+
diff --git a/graphics/gnash-devel/files/patch-server-asobj-flash-geom-Point_as.cpp b/graphics/gnash-devel/files/patch-server-asobj-flash-geom-Point_as.cpp
deleted file mode 100644
index 4a9a3628b7f8..000000000000
--- a/graphics/gnash-devel/files/patch-server-asobj-flash-geom-Point_as.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- server/asobj/flash/geom/Point_as.cpp.orig 2008-05-14 14:38:44.000000000 +0400
-+++ server/asobj/flash/geom/Point_as.cpp 2008-05-17 02:22:11.737384190 +0400
-@@ -193,9 +193,9 @@
- ptr->get_member(NSV::PROP_X, &xval);
- ptr->get_member(NSV::PROP_Y, &yval);
- double x = xval.to_number();
-- if ( ! isfinite(x) ) return as_value(NAN);
-+ if ( ! std::isfinite(x) ) return as_value(NAN);
- double y = yval.to_number();
-- if ( ! isfinite(y) ) return as_value(NAN);
-+ if ( ! std::isfinite(y) ) return as_value(NAN);
-
- double l = sqrt(x*x+y*y);
- return as_value(l);
diff --git a/graphics/gnash-devel/files/patch-server-asobj-flash-geom-Rectangle_as.cpp b/graphics/gnash-devel/files/patch-server-asobj-flash-geom-Rectangle_as.cpp
deleted file mode 100644
index 0d490fdb7a8c..000000000000
--- a/graphics/gnash-devel/files/patch-server-asobj-flash-geom-Rectangle_as.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- server/asobj/flash/geom/Rectangle_as.cpp.orig 2008-05-14 14:38:44.000000000 +0400
-+++ server/asobj/flash/geom/Rectangle_as.cpp 2008-05-17 02:22:29.328831706 +0400
-@@ -241,10 +241,10 @@
- if ( h.is_undefined() || h.is_null() ) return as_value(true);
-
- double wn = w.to_number();
-- if ( ! isfinite(wn) || wn == 0 ) return as_value(true);
-+ if ( ! std::isfinite(wn) || wn == 0 ) return as_value(true);
-
- double hn = h.to_number();
-- if ( ! isfinite(hn) || hn == 0 ) return as_value(true);
-+ if ( ! std::isfinite(hn) || hn == 0 ) return as_value(true);
-
- log_debug("Width: %g, Height: %g", wn, hn);
-
diff --git a/graphics/gnash-devel/pkg-plist b/graphics/gnash-devel/pkg-plist
index 8bc032c84217..8b9cd417dc5a 100644
--- a/graphics/gnash-devel/pkg-plist
+++ b/graphics/gnash-devel/pkg-plist
@@ -1,4 +1,5 @@
bin/dumpshm
+bin/flvdumper
bin/gnash
bin/gprocessor
bin/soldumper
@@ -12,29 +13,27 @@ bin/soldumper
%%KONQPLUGIN%%lib/kde3/libklashpart.a
%%KONQPLUGIN%%lib/kde3/libklashpart.so
%%KONQPLUGIN%%lib/kde3/libklashpart.la
-etc/gnashpluginrc
-etc/gnashrc
-lib/gnash/libgnashamf-0.8.3.so
-lib/gnash/libgnashamf.a
+@unexec if cmp -s %D/etc/gnashpluginrc.dist %D/etc/gnashpluginrc; then rm -f %D/etc/gnashpluginrc; fi
+etc/gnashpluginrc.dist
+@exec if [ ! -f %B/gnashpluginrc ]; then cp -p %D/%F %B/gnashpluginrc; fi
+@unexec if cmp -s %D/etc/gnashrc.dist %D/etc/gnashrc; then rm -f %D/etc/gnashrc; fi
+etc/gnashrc.dist
+@exec if [ ! -f %B/gnashrc ]; then cp -p %D/%F %B/gnashrc; fi
+lib/gnash/libgnashamf-%%GNASHVER%%.so
lib/gnash/libgnashamf.la
lib/gnash/libgnashamf.so
-lib/gnash/libgnashbase-0.8.3.so
-lib/gnash/libgnashbase.a
+lib/gnash/libgnashbase-%%GNASHVER%%.so
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashmedia-0.8.3.so
-lib/gnash/libgnashmedia.a
+lib/gnash/libgnashcore-%%GNASHVER%%.so
+lib/gnash/libgnashcore.la
+lib/gnash/libgnashcore.so
+lib/gnash/libgnashmedia-%%GNASHVER%%.so
lib/gnash/libgnashmedia.la
lib/gnash/libgnashmedia.so
-lib/gnash/libgnashnet.a
lib/gnash/libgnashnet.la
lib/gnash/libgnashnet.so
lib/gnash/libgnashnet.so.0
-lib/gnash/libgnashserver-0.8.3.so
-lib/gnash/libgnashserver.a
-lib/gnash/libgnashserver.la
-lib/gnash/libgnashserver.so
-%%FFPLUGIN%%lib/gnash/libmozsdk.a
%%FFPLUGIN%%lib/gnash/libmozsdk.la
%%FFPLUGIN%%lib/gnash/libmozsdk.so
%%FFPLUGIN%%lib/gnash/libmozsdk.so.0
@@ -50,6 +49,7 @@ share/locale/es/LC_MESSAGES/gnash.mo
share/locale/fi/LC_MESSAGES/gnash.mo
share/locale/fr/LC_MESSAGES/gnash.mo
share/locale/it/LC_MESSAGES/gnash.mo
+share/locale/ja/LC_MESSAGES/gnash.mo
share/locale/sv/LC_MESSAGES/gnash.mo
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%/images