aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-06 15:31:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-06 15:31:55 +0000
commit8842406b9d2263ae0d10b8bc7c4da3469f6befe1 (patch)
tree6304fd1fdc3d9a0542e50c7c15d65984e849ca9f /graphics/gnash
parentfd281e030705a0ecccc606bd5729de49b0cc239a (diff)
downloadports-8842406b9d2263ae0d10b8bc7c4da3469f6befe1.tar.gz
ports-8842406b9d2263ae0d10b8bc7c4da3469f6befe1.zip
Notes
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile15
-rw-r--r--graphics/gnash/distinfo4
-rw-r--r--graphics/gnash/files/patch-configure18
-rw-r--r--graphics/gnash/files/patch-libbase-tu_file.h10
-rw-r--r--graphics/gnash/files/patch-plugin-klash-klash_part.cpp6
-rw-r--r--graphics/gnash/files/patch-plugin-klash4-klash_part.cpp6
-rw-r--r--graphics/gnash/files/patch-plugin-npapi-Makefile.in12
-rw-r--r--graphics/gnash/pkg-plist99
8 files changed, 87 insertions, 83 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 7c4bf1f7ec19..0293d7a53080 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 0.8.8
-PORTREVISION= 2
+PORTVERSION= 0.8.9
CATEGORIES= graphics
MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/ \
http://mirror.amdmi3.ru/distfiles/
@@ -34,13 +33,14 @@ USE_GNOME= pkgconfig libxml2
USE_XORG= x11 xau xdmcp xext xi xinerama ice sm xv
USE_AUTOTOOLS= libltdl
MAKE_JOBS_SAFE= yes
+INSTALLS_ICONS= yes
# jemalloc leads to infinite recursion on FreeBSD
# --enable-avm2 doesn't build (but consider for future)
CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-boost-lib="${LOCALBASE}/lib" \
--disable-testsuite --disable-avm2 \
- --with-plugins-install=system \
+ --with-plugins-install=prefix \
--sysconfdir="${WRKDIR}/etc" \
--disable-jemalloc \
--disable-silent-rules
@@ -54,7 +54,7 @@ PLIST_SUB+= GNASHVER="${GNASHVER}"
USE_LDCONFIG= ${PREFIX}/lib/gnash
MAN1= cygnal.1 findmicrophones.1 findwebcams.1 \
- flvdumper.1 gnash.1 gprocessor.1 gtk-gnash.1 kde4-gnash.1 \
+ flvdumper.1 gnash.1 gprocessor.1 \
rtmpget.1 soldumper.1
OPTIONS= PLUGIN "Enable browser plugin" on \
@@ -65,7 +65,7 @@ OPTIONS= PLUGIN "Enable browser plugin" on \
AGG "Renderer: AGG" on \
OPENGL "Renderer: OpenGL (broken)" off \
CAIRO "Renderer: Cairo (experimental)" off \
- VAAPI "Enable VAAPI support (requres FFMPEG)" off \
+ VAAPI "Enable VAAPI support (requires FFMPEG)" off \
FFMPEG "Media handler: ffmpeg (+SDL sound output)" on \
GSTREAMER "Media handler: GStreamer" off
@@ -99,6 +99,8 @@ WEBPLUGINS_FILES= libgnashplugin.so
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
PLIST_SUB+= NPAPI=""
CONFIGURE_ARGS+=--with-npapi-plugindir="${WEBPLUGINS_DIR}"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libxul/xpidl:${PORTSDIR}/www/libxul
+RUN_DEPENDS+= ${LOCALBASE}/lib/libxul/xpidl:${PORTSDIR}/www/libxul
.else
PLIST_SUB+= NPAPI="@comment "
CONFIGURE_ARGS+= --disable-npapi
@@ -115,6 +117,7 @@ CONFIGURE_ARGS+= --disable-kparts3
.if defined(WITH_KDE4) && !defined(WITHOUT_PLUGIN)
PLIST_SUB+= KPARTS4=""
USE_LDCONFIG+= ${KDE4_PREFIX}/lib/kde4
+CONFIGURE_ARGS+= --with-kde4_prefix=${PREFIX}/kde4
.else
PLIST_SUB+= KPARTS4="@comment "
CONFIGURE_ARGS+= --disable-kparts4
@@ -129,6 +132,7 @@ GNASH_GUIS=
USE_GNOME= gtk20
GNASH_GUIS+= gtk
PLIST_SUB+= GTK=""
+MAN1+= gnash-gtk-launcher.1 gtk-gnash.1
.else
PLIST_SUB+= GTK="@comment "
.endif
@@ -152,6 +156,7 @@ CONFIGURE_ENV+= KDE4_CONFIG="${KDE4_PREFIX}/bin/kde4-config"
. if exists(${LOCALBASE}/lib/libkdeui.so)
IGNORE= KDE4 GUI can't be built when KDE3 is installed. Please rerun 'make config' and disable KDE4 GUI or deinstall kdelibs-3
. endif
+MAN1+= gnash-qt-launcher.1 kde4-gnash.1
.else
PLIST_SUB+= KDE4="@comment "
.endif
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
index 447d02896214..14580621eb67 100644
--- a/graphics/gnash/distinfo
+++ b/graphics/gnash/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnash-0.8.8.tar.bz2) = dcac4b81f81ecd6cc7c5422d7c731fc5c2a7be7fb18b5570a7e6f8fb5fc6e220
-SIZE (gnash-0.8.8.tar.bz2) = 3850383
+SHA256 (gnash-0.8.9.tar.bz2) = f90dbdc6f03d787b239b9edacbea077b46d69ae9d85f08af23f256af389c48bd
+SIZE (gnash-0.8.9.tar.bz2) = 3777140
diff --git a/graphics/gnash/files/patch-configure b/graphics/gnash/files/patch-configure
index 6c829e306f84..e9283fec0511 100644
--- a/graphics/gnash/files/patch-configure
+++ b/graphics/gnash/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2011-06-24 09:37:48.372797223 +0200
-+++ configure 2011-06-24 09:49:48.244082692 +0200
-@@ -20791,9 +20791,9 @@
+--- configure.orig 2011-03-18 09:50:30.000000000 -0400
++++ configure 2011-07-23 14:50:23.436294372 -0400
+@@ -9373,9 +9373,9 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking ffmpeg version" >&5
$as_echo_n "checking ffmpeg version... " >&6; }
@@ -13,3 +13,15 @@
if test x"${ffmpeg_major_version}" != x ; then
+@@ -27778,6 +27778,11 @@
+ esac
+ fi
+
++# KDE4_PREFIX override
++ if test x"${with_kde4_prefix}" != x; then
++ KDE4_PREFIX="${with_kde4_prefix}"
++ fi
++
+ if test x"${with_kde4_plugindir}" != x ; then
+ KDE4_PLUGINDIR="${with_kde4_plugindir}"
+ else
diff --git a/graphics/gnash/files/patch-libbase-tu_file.h b/graphics/gnash/files/patch-libbase-tu_file.h
deleted file mode 100644
index 28c2762b65c6..000000000000
--- a/graphics/gnash/files/patch-libbase-tu_file.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- libbase/tu_file.h.orig 2010-08-07 19:50:00.000000000 +0400
-+++ libbase/tu_file.h 2010-10-01 20:49:40.000000000 +0400
-@@ -12,6 +12,7 @@
- #include "dsodefs.h" // DSOEXPORT
- #include "utility.h"
- #include "IOChannel.h" // for inheritance
-+#include <cstdio>
-
-
- namespace gnash {
diff --git a/graphics/gnash/files/patch-plugin-klash-klash_part.cpp b/graphics/gnash/files/patch-plugin-klash-klash_part.cpp
index edd622becdee..704948946b40 100644
--- a/graphics/gnash/files/patch-plugin-klash-klash_part.cpp
+++ b/graphics/gnash/files/patch-plugin-klash-klash_part.cpp
@@ -1,6 +1,6 @@
---- plugin/klash/klash_part.cpp.orig 2009-03-02 18:29:45.000000000 +0300
-+++ plugin/klash/klash_part.cpp 2009-03-06 05:27:45.000000000 +0300
-@@ -160,7 +160,7 @@
+--- plugin/klash/klash_part.cpp.orig 2011-06-16 18:54:16.833252653 -0400
++++ plugin/klash/klash_part.cpp 2011-06-16 18:54:56.913835639 -0400
+@@ -161,7 +161,7 @@
QString procname;
char *gnash_env = getenv("KLASH_PLAYER");
if (!gnash_env) {
diff --git a/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp b/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp
index 31cd5c7a6f28..d896220545eb 100644
--- a/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp
+++ b/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp
@@ -1,6 +1,6 @@
---- plugin/klash4/klash_part.cpp.orig 2009-03-02 18:29:50.000000000 +0300
-+++ plugin/klash4/klash_part.cpp 2009-03-06 05:44:08.000000000 +0300
-@@ -147,7 +147,7 @@
+--- plugin/klash4/klash_part.cpp.orig 2011-06-16 18:56:30.869545798 -0400
++++ plugin/klash4/klash_part.cpp 2011-06-16 18:57:04.979892841 -0400
+@@ -148,7 +148,7 @@
}
}
KParts::Part::setWidget (new KlashView (wparent));
diff --git a/graphics/gnash/files/patch-plugin-npapi-Makefile.in b/graphics/gnash/files/patch-plugin-npapi-Makefile.in
index 475b813923a2..4de5d901c5b8 100644
--- a/graphics/gnash/files/patch-plugin-npapi-Makefile.in
+++ b/graphics/gnash/files/patch-plugin-npapi-Makefile.in
@@ -1,11 +1,11 @@
---- plugin/npapi/Makefile.in.orig 2010-08-21 22:04:45.000000000 +0400
-+++ plugin/npapi/Makefile.in 2010-08-25 05:43:40.000000000 +0400
-@@ -637,7 +637,7 @@
+--- plugin/npapi/Makefile.in.orig 2011-06-16 18:47:41.180628330 -0400
++++ plugin/npapi/Makefile.in 2011-06-16 18:48:21.950238296 -0400
+@@ -633,7 +633,7 @@
-I$(top_srcdir)/libcore/parser -I$(top_srcdir)/libbase \
-I$(top_srcdir)/librender -I$(srcdir)/mozilla-sdk \
- -I$(srcdir)/mozilla-sdk/include $(GLIB_CFLAGS) $(NULL) \
-- $(am__append_1) $(am__append_2)
-+ $(am__append_1) $(am__append_2) $(BOOST_CFLAGS)
+ $(NPAPI_CFLAGS) $(X11_CFLAGS) $(GLIB_CFLAGS) $(NULL) \
+- $(am__append_1) $(am__append_2) $(am__append_3)
++ $(am__append_1) $(am__append_2) $(am__append_3) $(BOOST_CFLAGS)
# AM_CXXFLAGS = $(AM_CPPFLAGS)
noinst_HEADERS = plugin.h mozilla-sdk/pluginbase.h \
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index a2cf59a9122a..a3e7c6fb21e7 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -1,26 +1,29 @@
bin/gnash
+%%GTK%%bin/gnash-gtk-launcher
%%GTK%%bin/gtk-gnash
%%KDE%%bin/kde3-gnash
+%%KDE4%%bin/gnash-qt-launcher
%%KDE4%%bin/kde4-gnash
bin/gprocessor
bin/rtmpget
%%GSTREAMER%%bin/findmicrophones
%%GSTREAMER%%bin/findwebcams
%%CYGNAL%%bin/cygnal
-@comment %%CYGNAL%%bin/dumpshm
%%CYGNAL%%bin/flvdumper
%%CYGNAL%%bin/soldumper
%%NPAPI%%%%WEBPLUGINS_DIR%%/libgnashplugin.so
-@comment Should be //KPARTS//, but it is installed regardless of whether plugin is enabled
-%%KPARTS%%share/apps/klash/pluginsinfo
-%%KPARTS%%share/apps/klash/klashpartui.rc
-@comment Should be //KPARTS//, but it is installed regardless of whether plugin is enabled
-%%KPARTS%%share/services/klash_part.desktop
+%%CYGNAL%%@unexec if cmp -s %D/etc/cygnalrc.dist %D/etc/cygnalrc; then rm -f %D/etc/cygnalrc; fi
+%%CYGNAL%%etc/cygnalrc.dist
+%%CYGNAL%%@exec if [ ! -f %B/cygnalrc ]; then cp -p %D/%F %B/cygnalrc; fi
+@unexec if cmp -s %D/etc/gnashpluginrc.dist %D/etc/gnashpluginrc; then rm -f %D/etc/gnashpluginrc; fi
+etc/gnashpluginrc.dist
+@exec if [ ! -f %B/gnashpluginrc ]; then cp -p %D/%F %B/gnashpluginrc; fi
+@unexec if cmp -s %D/etc/gnashrc.dist %D/etc/gnashrc; then rm -f %D/etc/gnashrc; fi
+etc/gnashrc.dist
+@exec if [ ! -f %B/gnashrc ]; then cp -p %D/%F %B/gnashrc; fi
include/gnash/AMF.h
include/gnash/BevelFilter_as.h
include/gnash/BitmapData_as.h
-include/gnash/BitmapFilterQuality_as.h
-include/gnash/BitmapFilterType_as.h
include/gnash/BitmapFilter_as.h
include/gnash/BitsReader.h
include/gnash/BlurFilter_as.h
@@ -29,14 +32,13 @@ include/gnash/ClockTime.h
include/gnash/ColorMatrixFilter_as.h
include/gnash/ColorTransform_as.h
include/gnash/ConvolutionFilter_as.h
-include/gnash/DisplacementMapFilterMode_as.h
include/gnash/DisplacementMapFilter_as.h
include/gnash/DropShadowFilter_as.h
include/gnash/ExternalInterface_as.h
-include/gnash/FileTypes.h
include/gnash/GC.h
include/gnash/GlowFilter_as.h
include/gnash/GnashAlgorithm.h
+include/gnash/GnashEnums.h
include/gnash/GnashException.h
include/gnash/GnashFactory.h
include/gnash/GnashFileUtilities.h
@@ -50,6 +52,7 @@ include/gnash/GnashSystemNetHeaders.h
include/gnash/GradientBevelFilter_as.h
include/gnash/GradientGlowFilter_as.h
include/gnash/IOChannel.h
+include/gnash/ImageIterators.h
include/gnash/Matrix_as.h
include/gnash/NamingPolicy.h
include/gnash/NetworkAdapter.h
@@ -58,15 +61,22 @@ include/gnash/Point_as.h
include/gnash/RTMP.h
include/gnash/Range2d.h
include/gnash/Rectangle_as.h
+include/gnash/Renderer.h
+include/gnash/SWFCtype.h
include/gnash/SharedMem.h
include/gnash/SimpleBuffer.h
include/gnash/Socket.h
+include/gnash/Stats.h
+include/gnash/StreamProvider.h
include/gnash/StringPredicates.h
include/gnash/Transform_as.h
include/gnash/URL.h
+include/gnash/URLAccessManager.h
include/gnash/WallClockTimer.h
+include/gnash/accumulator.h
include/gnash/arg_parser.h
include/gnash/asobj/AMFConverter.h
+include/gnash/asobj/ASConversions.h
include/gnash/asobj/Accessibility_as.h
include/gnash/asobj/Array_as.h
include/gnash/asobj/AsBroadcaster.h
@@ -77,18 +87,18 @@ include/gnash/asobj/Color_as.h
include/gnash/asobj/ContextMenuItem_as.h
include/gnash/asobj/ContextMenu_as.h
include/gnash/asobj/ControlTag.h
-include/gnash/asobj/CustomActions.h
include/gnash/asobj/Date_as.h
include/gnash/asobj/DefinitionTag.h
include/gnash/asobj/DisplayList.h
include/gnash/asobj/DisplayObject.h
include/gnash/asobj/DisplayObjectContainer.h
+include/gnash/asobj/DragState.h
include/gnash/asobj/DynamicShape.h
include/gnash/asobj/Error_as.h
include/gnash/asobj/FillStyle.h
+include/gnash/asobj/Function_as.h
include/gnash/asobj/Geometry.h
include/gnash/asobj/Global_as.h
-include/gnash/asobj/Globals.h
include/gnash/asobj/GnashKey.h
include/gnash/asobj/InteractiveObject.h
include/gnash/asobj/Key_as.h
@@ -119,6 +129,7 @@ include/gnash/asobj/RGBA.h
include/gnash/asobj/Relay.h
include/gnash/asobj/RunResources.h
include/gnash/asobj/SWF.h
+include/gnash/asobj/SWFCxForm.h
include/gnash/asobj/SWFMatrix.h
include/gnash/asobj/SWFRect.h
include/gnash/asobj/Selection_as.h
@@ -126,7 +137,6 @@ include/gnash/asobj/ShapeRecord.h
include/gnash/asobj/SharedObject_as.h
include/gnash/asobj/Sound_as.h
include/gnash/asobj/Stage_as.h
-include/gnash/asobj/StreamProvider.h
include/gnash/asobj/String_as.h
include/gnash/asobj/System_as.h
include/gnash/asobj/TagLoadersTable.h
@@ -143,10 +153,7 @@ include/gnash/asobj/as_function.h
include/gnash/asobj/as_object.h
include/gnash/asobj/as_value.h
include/gnash/asobj/builtin_function.h
-include/gnash/asobj/cxform.h
-include/gnash/asobj/drag_state.h
include/gnash/asobj/event_id.h
-include/gnash/asobj/gnash.h
include/gnash/asobj/movie_root.h
include/gnash/asobj/namedStrings.h
include/gnash/display_pkg.h
@@ -162,7 +169,6 @@ include/gnash/jemtree.h
include/gnash/log.h
include/gnash/net_pkg.h
include/gnash/noseek_fd_adapter.h
-include/gnash/ogl.h
include/gnash/parser/movie_definition.h
include/gnash/rc.h
include/gnash/ref_counted.h
@@ -173,70 +179,55 @@ include/gnash/string_table.h
include/gnash/text_pkg.h
include/gnash/tree.hh
include/gnash/tu_file.h
-include/gnash/tu_opengl_includes.h
include/gnash/utf8.h
include/gnash/utility.h
include/gnash/vm/ASHandlers.h
include/gnash/vm/ActionExec.h
include/gnash/vm/CallStack.h
include/gnash/vm/ExecutableCode.h
-include/gnash/vm/Machine.h
include/gnash/vm/SafeStack.h
include/gnash/vm/VM.h
include/gnash/vm/fn_call.h
include/gnash/zlib_adapter.h
-%%KPARTS%%lib/kde3/libklashpart.so
+%%KPARTS%%share/apps/klash/pluginsinfo
+%%KPARTS%%share/apps/klash/klashpartui.rc
+%%KPARTS%%share/services/klash_part.desktop
%%KPARTS%%lib/kde3/libklashpart.la
+%%KPARTS%%lib/kde3/libklashpart.so
%%KPARTS4%%kde4/share/apps/klash/pluginsinfo
%%KPARTS4%%kde4/share/apps/klash/klashpartui.rc
%%KPARTS4%%kde4/share/kde4/services/klash_part.desktop
%%KPARTS4%%kde4/lib/kde4/libklashpart.so
-%%KPARTS4%%kde4/lib/kde4/libklashpart.la
-%%CYGNAL%%@unexec if cmp -s %D/etc/cygnalrc.dist %D/etc/cygnalrc; then rm -f %D/etc/cygnalrc; fi
-%%CYGNAL%%etc/cygnalrc.dist
-%%CYGNAL%%@exec if [ ! -f %B/cygnalrc ]; then cp -p %D/%F %B/cygnalrc; fi
-@unexec if cmp -s %D/etc/gnashpluginrc.dist %D/etc/gnashpluginrc; then rm -f %D/etc/gnashpluginrc; fi
-etc/gnashpluginrc.dist
-@exec if [ ! -f %B/gnashpluginrc ]; then cp -p %D/%F %B/gnashpluginrc; fi
-@unexec if cmp -s %D/etc/gnashrc.dist %D/etc/gnashrc; then rm -f %D/etc/gnashrc; fi
-etc/gnashrc.dist
-@exec if [ ! -f %B/gnashrc ]; then cp -p %D/%F %B/gnashrc; fi
%%CYGNAL%%lib/cygnal/plugins/echo.so
%%CYGNAL%%lib/cygnal/plugins/oflaDemo.so
%%CYGNAL%%lib/gnash/libgnashamf-%%GNASHVER%%.so
-%%CYGNAL%%lib/gnash/libgnashamf.la
%%CYGNAL%%lib/gnash/libgnashamf.so
lib/gnash/libgnashbase-%%GNASHVER%%.so
-lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
lib/gnash/libgnashcore-%%GNASHVER%%.so
-lib/gnash/libgnashcore.la
lib/gnash/libgnashcore.so
lib/gnash/libgnashmedia-%%GNASHVER%%.so
-lib/gnash/libgnashmedia.la
lib/gnash/libgnashmedia.so
-%%CYGNAL%%lib/gnash/libgnashnet.la
+%%CYGNAL%%lib/gnash/libgnashnet-%%GNASHVER%%.so
%%CYGNAL%%lib/gnash/libgnashnet.so
-%%CYGNAL%%lib/gnash/libgnashnet.so.0
-lib/gnash/libgnashrender.la
+lib/gnash/libgnashrender-%%GNASHVER%%.so
lib/gnash/libgnashrender.so
-lib/gnash/libgnashrender.so.0
lib/gnash/libgnashsound-%%GNASHVER%%.so
-lib/gnash/libgnashsound.la
lib/gnash/libgnashsound.so
%%VAAPI%%lib/gnash/libgnashvaapi-%%GNASHVER%%.so
%%VAAPI%%lib/gnash/libgnashvaapi.la
%%VAAPI%%lib/gnash/libgnashvaapi.so
-@comment %%NPAPI%%lib/gnash/libmozsdk.la
-@comment %%NPAPI%%lib/gnash/libmozsdk.so
-@comment %%NPAPI%%lib/gnash/libmozsdk.so.0
libdata/pkgconfig/gnash.pc
-%%DOCSDIR%%/gnashuser.html
-%%DOCSDIR%%/images/car_crash.png
-%%DOCSDIR%%/images/rtmp.png
-%%DOCSDIR%%/gnashref.html
+%%GTK%%share/applications/gnash.desktop
+%%KDE4%%share/applications/klash.desktop
+%%DATADIR%%/doc/gnash/C/gnashref.html
+%%DATADIR%%/doc/gnash/C/gnashuser.html
+%%DATADIR%%/doc/gnash/C/images/rtmp.png
%%DATADIR%%/GnashG.png
+%%DATADIR%%/gnash-splash.swf
%%DATADIR%%/gnash_128_96.ico
+%%GTK%%share/icons/hicolor/32x32/apps/gnash.xpm
+%%KDE4%%share/icons/hicolor/32x32/apps/klash.xpm
share/locale/cs/LC_MESSAGES/gnash.mo
share/locale/de/LC_MESSAGES/gnash.mo
share/locale/es/LC_MESSAGES/gnash.mo
@@ -244,17 +235,23 @@ share/locale/fi/LC_MESSAGES/gnash.mo
share/locale/fr/LC_MESSAGES/gnash.mo
share/locale/it/LC_MESSAGES/gnash.mo
share/locale/ja/LC_MESSAGES/gnash.mo
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrm %%DATADIR%%/doc/gnash/C/images
+@dirrm %%DATADIR%%/doc/gnash/C
+@dirrm %%DATADIR%%/doc/gnash
+@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%/images
-@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
@dirrm lib/gnash
-%%CYGNAL%%@dirrm lib/cygnal/plugins
-%%CYGNAL%%@dirrm lib/cygnal
+%%CYGNAL%%@dirrmtry lib/cygnal/plugins
+%%CYGNAL%%@dirrmtry lib/cygnal
@dirrm include/gnash/vm
@dirrm include/gnash/parser
@dirrm include/gnash/asobj
@dirrm include/gnash
-@comment Should be //KPARTS//, but it is installed regardless of whether plugin is enabled
%%KPARTS%%@dirrm share/apps/klash
%%KPARTS4%%@dirrm kde4/share/apps/klash
%%NPAPI%%@dirrmtry %%WEBPLUGINS_DIR%%