aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-19 11:24:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-19 11:24:50 +0000
commit5ac9a97323d98c90a542606f7cd2f12723252461 (patch)
treee21a1d98559c1e866d361635266ff07e1286eebb /graphics/gnash
parent2139272bdebbe902c3d6bd6e45222923824c1985 (diff)
downloadports-5ac9a97323d98c90a542606f7cd2f12723252461.tar.gz
ports-5ac9a97323d98c90a542606f7cd2f12723252461.zip
Notes
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile41
-rw-r--r--graphics/gnash/files/patch-utilities-Makefile.in11
-rw-r--r--graphics/gnash/pkg-plist7
3 files changed, 42 insertions, 17 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index f71fc2ccbed7..57c0150065db 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -43,22 +44,18 @@ USE_LDCONFIG= ${PREFIX}/lib/gnash
MAN1= gnash.1
-# WITH_KDE option is untested - please uncomment related .if's below
-# build gnash -DWITH_KDE -DWITH_PLUGIN. Check whether the plugin works
-# and then contact the maintainer: plist and depends should be corrected
OPTIONS= PLUGIN "Enable browser plugin" on \
CYGNAL "Enable Cygnal media server" off \
GTK "GUI: GTK (required for FF plugin)" on \
- AGG "Renderer: AGG" off \
- OPENGL "Renderer: OpenGL" on \
+ KDE "GUI: KDE (required for Konqueror plugin)" off \
+ AGG "Renderer: AGG" on \
+ OPENGL "Renderer: OpenGL" off \
CAIRO "Renderer: Cairo (experimental)" off \
FFMPEG "Media handler: ffmpeg (+SDL sound output)" on \
GSTREAMER "Media handler: GStreamer" off \
MAD "Media handler: MAD (+SDL sound output)" off \
DEBUGLOG "Leave logfile in current directory on every run" off
-# KDE "GUI: KDE (required for Konqueror plugin)" off \
-
.include <bsd.port.pre.mk>
# Plugin option processing
@@ -69,12 +66,12 @@ PLIST_SUB+= FFPLUGIN="@comment "
CONFIGURE_ARGS+= --disable-nsapi
.endif
-#.if defined(WITH_KDE) && !defined(WITHOUT_PLUGIN)
-#PLIST_SUB+= KONQPLUGIN=""
-#.else
-#PLIST_SUB+= KONQPLUGIN="@comment "
+.if defined(WITH_KDE) && !defined(WITHOUT_PLUGIN)
+PLIST_SUB+= KONQPLUGIN=""
+.else
+PLIST_SUB+= KONQPLUGIN="@comment "
CONFIGURE_ARGS+= --disable-kparts
-#.endif
+.endif
# Cygnal option processing
.if defined(WITH_CYGNAL)
@@ -107,12 +104,19 @@ PLIST_SUB+= GTK=""
PLIST_SUB+= GTK="@comment "
.endif
-#.if defined(WITH_KDE)
-#GNASH_GUIS+= kde
-#PLIST_SUB+= KDE=""
-#.else
+.if defined(WITH_KDE)
+GNASH_GUIS+= kde
+PLIST_SUB+= KDE=""
+# We have to use this lame way to depend on kdelibs, as USE_KDELIBS_VER won't
+# work after bsd.port.pre.mk, and bsd.port.options.mk is unavailable until
+# 5.5/6.2 EOL. We could also include bsd.kde.mk here, but that's much more
+# likely to bring more trouble
+LIB_DEPENDS+= kimproxy:${PORTSDIR}/x11/kdelibs3
+CONFIGURE_ARGS+=--with-qt-incl="${LOCALBASE}/include" \
+ --with-qt-lib="${LOCALBASE}/lib"
+.else
PLIST_SUB+= KDE="@comment "
-#.endif
+.endif
CONFIGURE_ARGS+= --enable-gui=`${ECHO} ${GNASH_GUIS} | ${TR} ' ' ,`
@@ -129,6 +133,9 @@ LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
. endif
CONFIGURE_ARGS+= --enable-renderer=ogl
.elif !defined(WITH_AGG) && !defined(WITH_OPENGL) && defined(WITH_CAIRO)
+. if defined(WITH_KDE)
+IGNORE= doesn't support Cairo renderer with KDE gui. Please rerun 'make config' and select different renderer or disable KDE GUI
+. endif
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
CONFIGURE_ARGS+= --enable-renderer=cairo
.else
diff --git a/graphics/gnash/files/patch-utilities-Makefile.in b/graphics/gnash/files/patch-utilities-Makefile.in
new file mode 100644
index 000000000000..c12a8846d50d
--- /dev/null
+++ b/graphics/gnash/files/patch-utilities-Makefile.in
@@ -0,0 +1,11 @@
+--- utilities/Makefile.in.orig 2007-08-29 15:03:59.000000000 +0000
++++ utilities/Makefile.in 2007-11-07 20:37:02.000000000 +0000
+@@ -365,7 +365,7 @@
+ $(top_builddir)/libbase/libgnashbase.la \
+ $(top_builddir)/backend/libgnashbackend.la \
+ $(top_builddir)/libamf/libgnashamf.la $(am__append_2) \
+- $(am__append_4) $(GLIB_LIBS) $(GSTREAMER_LIBS)
++ $(am__append_4) $(GLIB_LIBS) $(GSTREAMER_LIBS) $(INTLLIBS)
+ AM_LDFLAGS = \
+ $(LIBADD_DL) \
+ $(LIBLTDL) \
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index e24747551d4d..600cdc9f62d7 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -2,8 +2,12 @@ bin/gnash
bin/gparser
bin/gprocessor
%%GTK%%bin/gtk-gnash
+%%KDE%%bin/kde-gnash
%%CYGNAL%%bin/cygnal
%%FFPLUGIN%%lib/browser_plugins/libgnashplugin.so
+%%KONQPLUGIN%%lib/kde3/libklashpart.so
+%%KONQPLUGIN%%lib/kde3/libklashpart.a
+%%KONQPLUGIN%%lib/kde3/libklashpart.la
lib/gnash/libgnashamf-0.8.1.so
lib/gnash/libgnashamf.a
lib/gnash/libgnashamf.la
@@ -26,6 +30,9 @@ lib/gnash/libgnashserver.la
lib/gnash/libgnashserver.so
%%DATADIR%%/GnashG.png
%%DATADIR%%/gnash_128_96.ico
+%%KONQPLUGIN%%share/apps/klash/pluginsinfo
+%%KONQPLUGIN%%share/apps/klash/klashpartui.rc
+%%KONQPLUGIN%%share/services/klash_part.desktop
share/locale/cs/gnash.mo
share/locale/de/gnash.mo
share/locale/es/gnash.mo