aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnome-color-manager/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /graphics/gnome-color-manager/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'graphics/gnome-color-manager/Makefile')
-rw-r--r--graphics/gnome-color-manager/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/graphics/gnome-color-manager/Makefile b/graphics/gnome-color-manager/Makefile
new file mode 100644
index 000000000000..f0ecf607270c
--- /dev/null
+++ b/graphics/gnome-color-manager/Makefile
@@ -0,0 +1,56 @@
+# Created by: FreeBSD GNOME Team <gnome@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/graphics/gnome-color-manager/Makefile 19998 2014-10-19 21:36:22Z gusi $
+
+PORTNAME= gnome-color-manager
+PORTVERSION= 3.14.1
+CATEGORIES= graphics gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Session framework for the GNOME desktop to manage color profiles
+
+BUILD_DEPENDS= docbook2man:${PORTSDIR}/textproc/docbook-utils \
+ itstool:${PORTSDIR}/textproc/itstool \
+ ${LOCALBASE}/share/sgml/docbook/4.1:${PORTSDIR}/textproc/docbook-sgml
+LIB_DEPENDS= liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libcolord.so:${PORTSDIR}/graphics/colord \
+ libcolord-gtk.so:${PORTSDIR}/graphics/colord-gtk \
+ libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
+ libexif.so:${PORTSDIR}/graphics/libexif
+
+USE_XORG= xrandr
+USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack vte3
+USES= desktop-file-utils gettext gmake pathfix \
+ pkgconfig tar:xz
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-clutter=no
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS_DEFINE= RAW
+OPTIONS_DEFAULT=RAW
+
+RAW_DESC= Enable RAW EXIF support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MRAW}
+LIB_DEPENDS+= libexiv2.so:${PORTSDIR}/graphics/exiv2
+CONFIGURE_ARGS+=--enable-exiv=yes
+PLIST_SUB+= RAW=""
+.else
+CONFIGURE_ARGS+=--enable-exiv=no
+PLIST_SUB+= RAW="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Wclobbered||g ; s|-Wempty-body||g ; \
+ s|-Wignored-qualifiers||g ; s|-Wtype-limits||g ; \
+ s|-Wmissing-parameter-type||g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>