aboutsummaryrefslogtreecommitdiff
path: root/graphics/gocr/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-11 18:23:21 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-11 18:23:21 +0000
commite404df93747922570700e9c2347974656051a059 (patch)
tree2403af9442f3474de19fa03133e38410b9586896 /graphics/gocr/Makefile
parent3848e3a8b6f82a42e1e1ea6aa484b6a7779a7fad (diff)
downloadports-e404df93747922570700e9c2347974656051a059.tar.gz
ports-e404df93747922570700e9c2347974656051a059.zip
Notes
Diffstat (limited to 'graphics/gocr/Makefile')
-rw-r--r--graphics/gocr/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/graphics/gocr/Makefile b/graphics/gocr/Makefile
index c5f160283de2..cfd63039463c 100644
--- a/graphics/gocr/Makefile
+++ b/graphics/gocr/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gocr
-PORTVERSION= 0.39
+PORTVERSION= 0.40
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= jocr
@@ -15,20 +15,34 @@ MAINTAINER= kay_lehmann@web.de
COMMENT= GOCR/JOCR is an OCR (Optical Character Recognition) program
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
+LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS+= --with-netpbm=${LOCALBASE}
+
+.if !defined(WITHOUT_X11)
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+PLIST_FILES+= bin/gocr.tcl
+.endif
MAN1= gocr.1
PORTDOCS= examples.txt gocr.html unicode.txt
+PLIST_FILES+= bin/gocr include/gocr.h lib/libPgm2asc.a
+
+post-patch:
+.if defined(WITHOUT_X11)
+ @${REINPLACE_CMD} -e '/gocr.tcl/d' ${WRKSRC}/src/Makefile.in
+.else
+ @${REINPLACE_CMD} -e 's/exec wish/exec wish8.4/' ${WRKSRC}/bin/gocr.tcl
+.endif
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
-.endfor
+ @(cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
.include <bsd.port.mk>