aboutsummaryrefslogtreecommitdiff
path: root/graphics/goom/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-06-22 12:37:03 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-06-22 12:37:03 +0000
commitc014d8190586d19380d29672bfcd29fd121695ef (patch)
tree3a9e661f8ab6c7ad37dacb960f5ead3b74961d00 /graphics/goom/Makefile
parentf3cd77a5257ef8c90839389226af103df94a195f (diff)
Add goom. Goom is a visual effects library with optional xmms plugin.
Notes
Notes: svn path=/head/; revision=137861
Diffstat (limited to 'graphics/goom/Makefile')
-rw-r--r--graphics/goom/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
new file mode 100644
index 000000000000..02ca854cf5b9
--- /dev/null
+++ b/graphics/goom/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: goom
+# Date created: 12 February 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= goom
+PORTVERSION= 2k4.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|-|}-src
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Visual effects library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S|.|-|}
+USE_GNOME= gnomehack gnometarget
+GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-sdltest
+INSTALLS_SHLIB= yes
+
+.if exists(${X11R6}/bin/xmms) || defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+PLIST_SUB+= XMMS=""
+.else
+PLIST_SUB+= XMMS="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITH_XMMS)
+ @${ECHO} ""
+ @${ECHO} "Define WITH_XMMS to build goom xmms visualization plugin"
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.mk>