aboutsummaryrefslogtreecommitdiff
path: root/graphics/goom
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-11-28 17:14:06 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-11-28 17:14:06 +0000
commit8c2c7ef1b0db9be7219a63c37bb61d5861df03d3 (patch)
treec63c0cc8b24817379e3161b72716885ccf20f0d8 /graphics/goom
parent65990f38b17311c075d1d741a0a474c9df831f8a (diff)
downloadports-8c2c7ef1b0db9be7219a63c37bb61d5861df03d3.tar.gz
ports-8c2c7ef1b0db9be7219a63c37bb61d5861df03d3.zip
- Fix build with clang on i386.
- Remove USE_GCC. - No PORTREVISION bump as there should be no functional change. Submitted by: dim Obtained from: multimedia/gstreamer-plugins-good/files/patch-gst_goom_mmx.h
Notes
Notes: svn path=/head/; revision=335108
Diffstat (limited to 'graphics/goom')
-rw-r--r--graphics/goom/Makefile4
-rw-r--r--graphics/goom/files/patch-src-mmx.h18
2 files changed, 18 insertions, 4 deletions
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
index dc382a80e61c..322c85c14082 100644
--- a/graphics/goom/Makefile
+++ b/graphics/goom/Makefile
@@ -40,8 +40,4 @@ pre-everything::
BROKEN= Does not compile on powerpc
.endif
-.if ${ARCH} == "i386"
-USE_GCC= any
-.endif
-
.include <bsd.port.post.mk>
diff --git a/graphics/goom/files/patch-src-mmx.h b/graphics/goom/files/patch-src-mmx.h
new file mode 100644
index 000000000000..3c174c604f24
--- /dev/null
+++ b/graphics/goom/files/patch-src-mmx.h
@@ -0,0 +1,18 @@
+--- src/mmx.h.orig
++++ src/mmx.h
+@@ -715,13 +715,13 @@ void zoom_filter_xmmx (int prevX, int pr
+ { \
+ printf("emms()\n"); \
+ __asm__ __volatile__ ("emms" \
+- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
++ "st","st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
+ }
+
+ #else
+
+ #define emms() __asm__ __volatile__ ("emms"::: \
+- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
++ "st","st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
+
+ #endif
+