aboutsummaryrefslogtreecommitdiff
path: root/graphics/gource
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2009-11-25 12:14:46 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2009-11-25 12:14:46 +0000
commit702c9aa3724e4634c42abc7f4009a058519c5f25 (patch)
tree8550795b9e59f2eb0ba77ea714a64c60f7a97eb9 /graphics/gource
parent739673f42c70449a158642457af5634e632a400f (diff)
downloadports-702c9aa3724e4634c42abc7f4009a058519c5f25.tar.gz
ports-702c9aa3724e4634c42abc7f4009a058519c5f25.zip
Notes
Diffstat (limited to 'graphics/gource')
-rw-r--r--graphics/gource/Makefile27
-rw-r--r--graphics/gource/distinfo3
-rw-r--r--graphics/gource/files/patch-Makefile.in11
-rw-r--r--graphics/gource/pkg-descr8
-rw-r--r--graphics/gource/pkg-plist8
5 files changed, 57 insertions, 0 deletions
diff --git a/graphics/gource/Makefile b/graphics/gource/Makefile
new file mode 100644
index 000000000000..78c5b991713a
--- /dev/null
+++ b/graphics/gource/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gource
+# Date created: Nov 25 2009
+# Whom: demon@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gource
+PORTVERSION= 0.17
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= OpenGL-based 3D visualisation tool for source control repositories
+
+LIB_DEPENDS= SDL_image:${PORTSDIR}/graphics/sdl_image \
+ ftgl:${PORTSDIR}/graphics/ftgl \
+ pcre:${PORTSDIR}/devel/pcre
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MANCOMPRESSED= yes
+
+MAN1= gource.1
+
+.include <bsd.port.mk>
diff --git a/graphics/gource/distinfo b/graphics/gource/distinfo
new file mode 100644
index 000000000000..4d765ff3e2ae
--- /dev/null
+++ b/graphics/gource/distinfo
@@ -0,0 +1,3 @@
+MD5 (gource-0.17.tar.gz) = f0bc16ae1faa18f3dbc5020b318798ab
+SHA256 (gource-0.17.tar.gz) = 9596ac7801c42588098bfaae465bb86abe9b98b6dc67fe632c641178472558c9
+SIZE (gource-0.17.tar.gz) = 516355
diff --git a/graphics/gource/files/patch-Makefile.in b/graphics/gource/files/patch-Makefile.in
new file mode 100644
index 000000000000..c3d27c09baea
--- /dev/null
+++ b/graphics/gource/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2009-11-25 05:29:14.000000000 +0300
++++ Makefile.in 2009-11-25 15:03:36.000000000 +0300
+@@ -2,7 +2,7 @@
+ exec_prefix = ${prefix}
+ bindir = ${exec_prefix}/bin
+ datarootdir = @datarootdir@
+-mandir = ${datarootdir}/man
++mandir = ${prefix}/man
+ gourcedatadir = $(datarootdir)/gource
+ gourcefontdir = @gourcefontdir@
+
diff --git a/graphics/gource/pkg-descr b/graphics/gource/pkg-descr
new file mode 100644
index 000000000000..9c91d6d3aeb1
--- /dev/null
+++ b/graphics/gource/pkg-descr
@@ -0,0 +1,8 @@
+OpenGL-based 3D visualisation tool for source control repositories.
+
+The repository is displayed as a tree where the root of the
+repository is the centre, directories are branches and files
+are leaves. Contributors to the source code appear and disappear
+ias they contribute to specific files and directories.
+
+WWW: http://code.google.com/p/gource/
diff --git a/graphics/gource/pkg-plist b/graphics/gource/pkg-plist
new file mode 100644
index 000000000000..fc3767620d43
--- /dev/null
+++ b/graphics/gource/pkg-plist
@@ -0,0 +1,8 @@
+bin/gource
+%%DATADIR%%/no_photo.png
+%%DATADIR%%/file.png
+%%DATADIR%%/beam.png
+%%DATADIR%%/fonts/FreeSans.ttf
+%%DATADIR%%/fonts/README
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%