aboutsummaryrefslogtreecommitdiff
path: root/graphics/gpdf
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 07:04:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 07:04:25 +0000
commit81da8e3d90e5c9388790b014cfb2e0ba2a79bce3 (patch)
tree6edb0e875c7268955725dab0f88baed49618d66d /graphics/gpdf
parentfcaa194286273f670025d897ebbb64bc4a51ff56 (diff)
downloadports-81da8e3d90e5c9388790b014cfb2e0ba2a79bce3.tar.gz
ports-81da8e3d90e5c9388790b014cfb2e0ba2a79bce3.zip
Notes
Diffstat (limited to 'graphics/gpdf')
-rw-r--r--graphics/gpdf/Makefile27
-rw-r--r--graphics/gpdf/distinfo1
-rw-r--r--graphics/gpdf/files/patch-configure10
-rw-r--r--graphics/gpdf/files/patch-xpdf_gpdf-link-canvas-item.cc11
-rw-r--r--graphics/gpdf/files/patch-xpdf_gpdf-links-canvas-layer.cc11
-rw-r--r--graphics/gpdf/pkg-descr6
-rw-r--r--graphics/gpdf/pkg-plist63
7 files changed, 129 insertions, 0 deletions
diff --git a/graphics/gpdf/Makefile b/graphics/gpdf/Makefile
new file mode 100644
index 000000000000..82744d448cd3
--- /dev/null
+++ b/graphics/gpdf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gpdf
+# Date created: 12 April 2002
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpdf
+PORTVERSION= 0.110
+CATEGORIES= graphics print gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME version of xpdf
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/gpdf/distinfo b/graphics/gpdf/distinfo
new file mode 100644
index 000000000000..f009f0bb9862
--- /dev/null
+++ b/graphics/gpdf/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gpdf-0.110.tar.bz2) = ae3682bcd13f5ab2095fa5409462fb6f
diff --git a/graphics/gpdf/files/patch-configure b/graphics/gpdf/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/graphics/gpdf/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/graphics/gpdf/files/patch-xpdf_gpdf-link-canvas-item.cc b/graphics/gpdf/files/patch-xpdf_gpdf-link-canvas-item.cc
new file mode 100644
index 000000000000..18497bb5e5ad
--- /dev/null
+++ b/graphics/gpdf/files/patch-xpdf_gpdf-link-canvas-item.cc
@@ -0,0 +1,11 @@
+--- xpdf/gpdf-link-canvas-item.cc.orig Fri May 23 23:04:01 2003
++++ xpdf/gpdf-link-canvas-item.cc Sat May 24 00:15:18 2003
+@@ -33,6 +33,8 @@
+
+ BEGIN_EXTERN_C
+
++#define G_STRLOC __FILE__ ":" G_STRINGIFY (__LINE__)
++
+ struct _GPdfLinkCanvasItemPrivate {
+ Link *link;
+ };
diff --git a/graphics/gpdf/files/patch-xpdf_gpdf-links-canvas-layer.cc b/graphics/gpdf/files/patch-xpdf_gpdf-links-canvas-layer.cc
new file mode 100644
index 000000000000..aea0001c779b
--- /dev/null
+++ b/graphics/gpdf/files/patch-xpdf_gpdf-links-canvas-layer.cc
@@ -0,0 +1,11 @@
+--- xpdf/gpdf-links-canvas-layer.cc.orig Sat May 24 00:17:29 2003
++++ xpdf/gpdf-links-canvas-layer.cc Sat May 24 00:17:46 2003
+@@ -42,6 +42,8 @@
+
+ BEGIN_EXTERN_C
+
++#define G_STRLOC __FILE__ ":" G_STRINGIFY (__LINE__)
++
+ struct _GPdfLinksCanvasLayerPrivate {
+ Links *links;
+ };
diff --git a/graphics/gpdf/pkg-descr b/graphics/gpdf/pkg-descr
new file mode 100644
index 000000000000..4d967a66f364
--- /dev/null
+++ b/graphics/gpdf/pkg-descr
@@ -0,0 +1,6 @@
+The GNOME PDF Viewer is an open source viewer for Portable Document
+Format (PDF) files. (These are also sometimes called "Acrobat" files,
+from the name of Adobe's PDF software.) The GNOME PDF viewer is based
+upon xpdf (ports/graphics/xpdf).
+
+WWW: http://www.gnome.org
diff --git a/graphics/gpdf/pkg-plist b/graphics/gpdf/pkg-plist
new file mode 100644
index 000000000000..c5fb067f0f67
--- /dev/null
+++ b/graphics/gpdf/pkg-plist
@@ -0,0 +1,63 @@
+bin/gpdf
+libdata/bonobo/servers/GNOME_PDF.server
+libexec/gnome-pdf-viewer
+share/gnome/gpdf/glade/gpdf-properties-dialog.glade
+share/gnome/pixmaps/gpdf/fitwidth.png
+share/gnome/pixmaps/gnome-pdf.png
+share/gnome/gnome-2.0/ui/gpdf-control-ui.xml
+share/gnome/gnome-2.0/ui/gpdf-window-ui.xml
+share/gnome/applications/gpdf.desktop
+share/gnome/mime-info/gpdf.keys
+share/gnome/application-registry/gpdf.applications
+share/locale/am/LC_MESSAGES/gpdf.mo
+share/locale/az/LC_MESSAGES/gpdf.mo
+share/locale/be/LC_MESSAGES/gpdf.mo
+share/locale/ca/LC_MESSAGES/gpdf.mo
+share/locale/cs/LC_MESSAGES/gpdf.mo
+share/locale/cy/LC_MESSAGES/gpdf.mo
+share/locale/da/LC_MESSAGES/gpdf.mo
+share/locale/de/LC_MESSAGES/gpdf.mo
+share/locale/el/LC_MESSAGES/gpdf.mo
+share/locale/eo/LC_MESSAGES/gpdf.mo
+share/locale/es/LC_MESSAGES/gpdf.mo
+share/locale/fi/LC_MESSAGES/gpdf.mo
+share/locale/fr/LC_MESSAGES/gpdf.mo
+share/locale/ga/LC_MESSAGES/gpdf.mo
+share/locale/gl/LC_MESSAGES/gpdf.mo
+share/locale/he/LC_MESSAGES/gpdf.mo
+share/locale/hi/LC_MESSAGES/gpdf.mo
+share/locale/hu/LC_MESSAGES/gpdf.mo
+share/locale/is/LC_MESSAGES/gpdf.mo
+share/locale/it/LC_MESSAGES/gpdf.mo
+share/locale/ja/LC_MESSAGES/gpdf.mo
+share/locale/kn/LC_MESSAGES/gpdf.mo
+share/locale/ko/LC_MESSAGES/gpdf.mo
+share/locale/lt/LC_MESSAGES/gpdf.mo
+share/locale/lv/LC_MESSAGES/gpdf.mo
+share/locale/mk/LC_MESSAGES/gpdf.mo
+share/locale/ml/LC_MESSAGES/gpdf.mo
+share/locale/ms/LC_MESSAGES/gpdf.mo
+share/locale/nl/LC_MESSAGES/gpdf.mo
+share/locale/nn/LC_MESSAGES/gpdf.mo
+share/locale/no/LC_MESSAGES/gpdf.mo
+share/locale/pl/LC_MESSAGES/gpdf.mo
+share/locale/pt/LC_MESSAGES/gpdf.mo
+share/locale/pt_BR/LC_MESSAGES/gpdf.mo
+share/locale/ro/LC_MESSAGES/gpdf.mo
+share/locale/ru/LC_MESSAGES/gpdf.mo
+share/locale/sk/LC_MESSAGES/gpdf.mo
+share/locale/sq/LC_MESSAGES/gpdf.mo
+share/locale/sr/LC_MESSAGES/gpdf.mo
+share/locale/sr@Latn/LC_MESSAGES/gpdf.mo
+share/locale/sv/LC_MESSAGES/gpdf.mo
+share/locale/ta/LC_MESSAGES/gpdf.mo
+share/locale/th/LC_MESSAGES/gpdf.mo
+share/locale/tr/LC_MESSAGES/gpdf.mo
+share/locale/uk/LC_MESSAGES/gpdf.mo
+share/locale/vi/LC_MESSAGES/gpdf.mo
+share/locale/wa/LC_MESSAGES/gpdf.mo
+share/locale/zh_CN/LC_MESSAGES/gpdf.mo
+share/locale/zh_TW/LC_MESSAGES/gpdf.mo
+@dirrm share/gnome/pixmaps/gpdf
+@dirrm share/gnome/gpdf/glade
+@dirrm share/gnome/gpdf