aboutsummaryrefslogtreecommitdiff
path: root/graphics/gphoto2
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-20 08:47:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-20 08:47:41 +0000
commitbab4175717a25f4234cfd2fe72842843f71468df (patch)
tree1717ebca1dd60a561a37e7251b2cc7f113226401 /graphics/gphoto2
parent713870636ffa96c10f29020d593069bdee0284ac (diff)
downloadports-bab4175717a25f4234cfd2fe72842843f71468df.tar.gz
ports-bab4175717a25f4234cfd2fe72842843f71468df.zip
Notes
Diffstat (limited to 'graphics/gphoto2')
-rw-r--r--graphics/gphoto2/Makefile18
-rw-r--r--graphics/gphoto2/distinfo4
-rw-r--r--graphics/gphoto2/files/patch-gphoto2::actions.c17
-rw-r--r--graphics/gphoto2/pkg-plist38
4 files changed, 37 insertions, 40 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 53fc5a898408..832aee44ce37 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gphoto2
-PORTVERSION= 2.1.4
-PORTREVISION= 1
+PORTVERSION= 2.1.5
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gphoto
@@ -20,17 +19,26 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
jpeg.9:${PORTSDIR}/graphics/jpeg \
gphoto2.2:${PORTSDIR}/graphics/libgphoto2
-USE_BZIP2= yes
USE_GNOME= gnometarget
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --without-cdk
MAN1= gphoto2.1
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREADS_LIBS:S/"//g}|g ; \
s|-g -Wall||g' ${WRKSRC}/configure
diff --git a/graphics/gphoto2/distinfo b/graphics/gphoto2/distinfo
index 7c3bb5c75884..e22e8a3fe8bf 100644
--- a/graphics/gphoto2/distinfo
+++ b/graphics/gphoto2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gphoto2-2.1.4.tar.bz2) = 5bbee55d4e59b063d3cff0fbc9121006
-SIZE (gphoto2-2.1.4.tar.bz2) = 350858
+MD5 (gphoto2-2.1.5.tar.gz) = 9bd1a033389f9e4e6425dda4f6e603c9
+SIZE (gphoto2-2.1.5.tar.gz) = 535490
diff --git a/graphics/gphoto2/files/patch-gphoto2::actions.c b/graphics/gphoto2/files/patch-gphoto2::actions.c
deleted file mode 100644
index 0942d9aa9285..000000000000
--- a/graphics/gphoto2/files/patch-gphoto2::actions.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- gphoto2/actions.c.orig Thu Sep 30 13:04:05 2004
-+++ gphoto2/actions.c Thu Sep 30 13:14:06 2004
-@@ -346,12 +346,13 @@
- {
- ExifEntry *e;
- unsigned int i;
-+ char value[1024];
-
- for (i = 0; i < content->count; i++) {
- e = content->entries[i];
- printf ("%-20.20s", exif_tag_get_name (e->tag));
- printf ("|");
-- printf ("%-59.59s", exif_entry_get_value (e));
-+ printf ("%-59.59s", exif_entry_get_value (e, value, sizeof(value)));
- printf ("\n");
- }
- }
diff --git a/graphics/gphoto2/pkg-plist b/graphics/gphoto2/pkg-plist
index 5da61e6b0e9e..6d8666e65ee8 100644
--- a/graphics/gphoto2/pkg-plist
+++ b/graphics/gphoto2/pkg-plist
@@ -2,20 +2,26 @@ bin/gphoto2
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
-share/locale/cs/LC_MESSAGES/gphoto2.mo
-share/locale/da/LC_MESSAGES/gphoto2.mo
-share/locale/de/LC_MESSAGES/gphoto2.mo
-share/locale/es/LC_MESSAGES/gphoto2.mo
-share/locale/fr/LC_MESSAGES/gphoto2.mo
-share/locale/it/LC_MESSAGES/gphoto2.mo
-share/locale/ja/LC_MESSAGES/gphoto2.mo
-share/locale/no/LC_MESSAGES/gphoto2.mo
-share/locale/pt_BR/LC_MESSAGES/gphoto2.mo
-share/locale/ro/LC_MESSAGES/gphoto2.mo
-share/locale/ru/LC_MESSAGES/gphoto2.mo
-share/locale/sk/LC_MESSAGES/gphoto2.mo
-share/locale/sl/LC_MESSAGES/gphoto2.mo
-share/locale/sv/LC_MESSAGES/gphoto2.mo
-share/locale/uk/LC_MESSAGES/gphoto2.mo
-share/locale/zh_CN/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/az/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/no/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/gphoto2.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gphoto2.mo
%%PORTDOCS%%@dirrm %%DOCSDIR%%