aboutsummaryrefslogtreecommitdiff
path: root/graphics/gpsmanshp
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-05-08 00:34:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-05-08 00:34:49 +0000
commitcabb68b96dedc817c423e52e81afe9a9912e5411 (patch)
treeb45791e4b286123f0ed2db217e08ddba69466303 /graphics/gpsmanshp
parentd83f8f9b98a3ac143f4b0e6932a4a14fa6e7dc94 (diff)
downloadports-cabb68b96dedc817c423e52e81afe9a9912e5411.tar.gz
ports-cabb68b96dedc817c423e52e81afe9a9912e5411.zip
graphics/gpsmanshp: update to 1.2.3
- Chase new home - Define LICENSE - Convert to USES=tcl - Convert to USES=tar - Convert to COPYTREE_SHARE Changes: http://gpsmanshp.sourceforge.net/GPSManSHP_3.html PR: 199235 Submitted by: tkato432@yahoo.com
Notes
Notes: svn path=/head/; revision=385718
Diffstat (limited to 'graphics/gpsmanshp')
-rw-r--r--graphics/gpsmanshp/Makefile21
-rw-r--r--graphics/gpsmanshp/distinfo4
-rw-r--r--graphics/gpsmanshp/files/patch-Makefile27
-rw-r--r--graphics/gpsmanshp/files/patch-gpsmanshp.c11
-rw-r--r--graphics/gpsmanshp/pkg-descr2
-rw-r--r--graphics/gpsmanshp/pkg-plist14
6 files changed, 25 insertions, 54 deletions
diff --git a/graphics/gpsmanshp/Makefile b/graphics/gpsmanshp/Makefile
index 739e6053d138..4b6aba6ab8a0 100644
--- a/graphics/gpsmanshp/Makefile
+++ b/graphics/gpsmanshp/Makefile
@@ -2,29 +2,28 @@
# $FreeBSD$
PORTNAME= gpsmanshp
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.2.3
CATEGORIES= graphics tcl geography
-MASTER_SITES= http://www.ncc.up.pt/gpsmanshp/
+MASTER_SITES= SF/${PORTNAME}/distr
DISTNAME= ${PORTNAME}_${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Shapelib support for gpsman
-BROKEN= No public distfiles
+LICENSE= GPLv3 # (or later)
+LIB_DEPENDS= libshp.so:${PORTSDIR}/devel/shapelib
RUN_DEPENDS= gpsman:${PORTSDIR}/astro/gpsman
-LIB_DEPENDS= libshp.so:${PORTSDIR}/devel/shapelib \
- libtcl${TCLVERSION:S/.//}.so:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
-TCLVERSION?= 8.4
-PLIST_SUB= TCLVERSION=${TCLVERSION} PORTVERSION=${PORTVERSION}
+USES= tar:tgz tcl
+MAKE_ENV= TCLVERSION="${TCL_VER}"
+PLIST_SUB= TCLVERSION="${TCL_VER}" PORTVERSION="${PORTVERSION}"
OPTIONS_DEFINE= DOCS
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \
+ . ${STAGEDIR}${DOCSDIR} \
+ "! -name gpl-3_0.txt")
.include <bsd.port.mk>
diff --git a/graphics/gpsmanshp/distinfo b/graphics/gpsmanshp/distinfo
index 21e079a1119f..aa31c3dda69a 100644
--- a/graphics/gpsmanshp/distinfo
+++ b/graphics/gpsmanshp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gpsmanshp_1.2.tgz) = f216332c8d42f7c6d6f3a3111835e55793e5fc562036299dd8c4ace406f30cd3
-SIZE (gpsmanshp_1.2.tgz) = 104092
+SHA256 (gpsmanshp_1.2.3.tgz) = 2803524aa8f87db6ff1eaec93cef9619c944c9aa00149e554be11f6e2f1cafd2
+SIZE (gpsmanshp_1.2.3.tgz) = 150070
diff --git a/graphics/gpsmanshp/files/patch-Makefile b/graphics/gpsmanshp/files/patch-Makefile
index 6c3884a79bb2..b2df5d6e5782 100644
--- a/graphics/gpsmanshp/files/patch-Makefile
+++ b/graphics/gpsmanshp/files/patch-Makefile
@@ -1,30 +1,27 @@
---- Makefile.orig Fri Jul 9 11:05:39 2004
-+++ Makefile Fri Jul 9 11:18:01 2004
-@@ -25,11 +25,15 @@
- VERSION = 1.2
+--- Makefile.orig 2013-10-06 18:44:14 UTC
++++ Makefile
+@@ -24,12 +24,16 @@
- TCLVERSION = 8.4
-+TCLLVERSION = 84
+ VERSION = 1.2.3
+
+-TCLVERSION = 8.4
++TCLVERSION ?= 8.4
++TCLLVERSION = $(TCLVERSION:S/.//)
-INSTALLDIR = /usr/lib/tcl$(TCLVERSION)
+INSTALLDIR = ${DESTDIR}${PREFIX}/lib/tcl$(TCLVERSION)/gpsmanshp-$(VERSION)
-CFLAGS = -Wall -fPIC -c -I/usr/include/tcl$(TCLVERSION)
-LINKOPT = -lshp -ltcl$(TCLVERSION)
-+CFLAGS += -Wall -fPIC -c -I${PREFIX}/include/tcl$(TCLVERSION)
-+CFLAGS += -I${PREFIX}/include
-+LINKOPT = -L${PREFIX}/lib -lshp -ltcl$(TCLLVERSION)
++CFLAGS += -Wall -fPIC -c -I${LOCALBASE}/include/tcl$(TCLVERSION)
++CFLAGS += -I${LOCALBASE}/include
++LINKOPT = -L${LOCALBASE}/lib -lshp -ltcl$(TCLLVERSION)
+
+all: pkgIndex.tcl
gpsmanshp.so: gpsmanshp.o
$(CC) -shared -o gpsmanshp.so $(LINKOPT) gpsmanshp.o
-@@ -38,12 +42,13 @@
- $(CC) $(CFLAGS) gpsmanshp.c
-
- pkgIndex.tcl: gpsmanshp.so
-- echo "source package-8.3.tcl ; pkg_mkIndex -lazy -verbose . gpsmanshp.so" | tclsh$(TCLVERSION)
-+ echo "pkg_mkIndex -lazy -verbose . gpsmanshp.so" | tclsh$(TCLVERSION)
+@@ -42,8 +46,9 @@ pkgIndex.tcl: gpsmanshp.so
chmod 644 gpsmanshp.so pkgIndex.tcl
install: pkgIndex.tcl
diff --git a/graphics/gpsmanshp/files/patch-gpsmanshp.c b/graphics/gpsmanshp/files/patch-gpsmanshp.c
deleted file mode 100644
index 015c6347181a..000000000000
--- a/graphics/gpsmanshp/files/patch-gpsmanshp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gpsmanshp.c.org Mon Jan 26 14:10:32 2004
-+++ gpsmanshp.c Wed Jul 7 20:53:40 2004
-@@ -65,7 +65,7 @@
-
- #include <stdlib.h>
- #include <string.h>
--#include <libshp/shapefil.h>
-+#include <shapefil.h>
- #include <tcl.h>
-
- #define VERSION "1.1"
diff --git a/graphics/gpsmanshp/pkg-descr b/graphics/gpsmanshp/pkg-descr
index f30410203787..bb1549ff3457 100644
--- a/graphics/gpsmanshp/pkg-descr
+++ b/graphics/gpsmanshp/pkg-descr
@@ -3,4 +3,4 @@ A Tcl Package to Read and Write Shapefiles
Gpsmanshp was developed for use in GPSMan, a manager of GPS receiver
data. It is written in C and is based on shapelib.
-WWW: http://www.ncc.up.pt/gpsmanshp/
+WWW: http://gpsmanshp.sourceforge.net/
diff --git a/graphics/gpsmanshp/pkg-plist b/graphics/gpsmanshp/pkg-plist
index 7a72be00f6b5..afe8184a1981 100644
--- a/graphics/gpsmanshp/pkg-plist
+++ b/graphics/gpsmanshp/pkg-plist
@@ -1,17 +1,3 @@
lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/gpsmanshp.so
lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/pkgIndex.tcl
-%%PORTDOCS%%%%DOCSDIR%%/GPL.txt
-%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP.html
%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP.pdf
-%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_1.html
-%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_2.html
-%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_3.html
-%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_4.html
-%%PORTDOCS%%%%DOCSDIR%%/backgr.gif
-%%PORTDOCS%%%%DOCSDIR%%/blank.gif
-%%PORTDOCS%%%%DOCSDIR%%/gpsman-logo-small.gif
-%%PORTDOCS%%%%DOCSDIR%%/newarr.gif
-%%PORTDOCS%%%%DOCSDIR%%/newearr.gif
-%%PORTDOCS%%%%DOCSDIR%%/next.gif
-%%PORTDOCS%%%%DOCSDIR%%/previous.gif
-%%PORTDOCS%%%%DOCSDIR%%/up.gif