aboutsummaryrefslogtreecommitdiff
path: root/graphics/gpsmanshp
diff options
context:
space:
mode:
authorJohn Hay <jhay@FreeBSD.org>2004-07-18 19:16:03 +0000
committerJohn Hay <jhay@FreeBSD.org>2004-07-18 19:16:03 +0000
commit991af4c17f250652c7097741132e30cc839d8910 (patch)
tree6cc9f3c20d594c8405f97f8150e410bdabcbd947 /graphics/gpsmanshp
parent99849b1ff9efbb1f7bff7f2d6972080afb96da39 (diff)
downloadports-991af4c17f250652c7097741132e30cc839d8910.tar.gz
ports-991af4c17f250652c7097741132e30cc839d8910.zip
Notes
Diffstat (limited to 'graphics/gpsmanshp')
-rw-r--r--graphics/gpsmanshp/Makefile29
-rw-r--r--graphics/gpsmanshp/distinfo2
-rw-r--r--graphics/gpsmanshp/files/patch-Makefile37
-rw-r--r--graphics/gpsmanshp/files/patch-gpsmanshp.c11
-rw-r--r--graphics/gpsmanshp/pkg-descr6
-rw-r--r--graphics/gpsmanshp/pkg-plist19
6 files changed, 104 insertions, 0 deletions
diff --git a/graphics/gpsmanshp/Makefile b/graphics/gpsmanshp/Makefile
new file mode 100644
index 000000000000..4fd8266ba652
--- /dev/null
+++ b/graphics/gpsmanshp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gpsmanshp
+# Date created: 7 July 2004
+# Whom: John Hay
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpsmanshp
+PORTVERSION= 1.2
+CATEGORIES= graphics tcl84
+MASTER_SITES= http://www.ncc.up.pt/gpsmanshp/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jhay@FreeBSD.org
+COMMENT= Shapelib support for gpsman
+
+RUN_DEPENDS= gpsman:${PORTSDIR}/astro/gpsman
+LIB_DEPENDS= shp.1:${PORTSDIR}/devel/shapelib
+
+PLIST_SUB= TCLVERSION=8.4 PORTVERSION=${PORTVERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gpsmanshp/distinfo b/graphics/gpsmanshp/distinfo
new file mode 100644
index 000000000000..494cca974bab
--- /dev/null
+++ b/graphics/gpsmanshp/distinfo
@@ -0,0 +1,2 @@
+MD5 (gpsmanshp_1.2.tgz) = b32e16afe3e306cf991ea38713fd0c9e
+SIZE (gpsmanshp_1.2.tgz) = 104092
diff --git a/graphics/gpsmanshp/files/patch-Makefile b/graphics/gpsmanshp/files/patch-Makefile
new file mode 100644
index 000000000000..7143f30b372f
--- /dev/null
+++ b/graphics/gpsmanshp/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig Fri Jul 9 11:05:39 2004
++++ Makefile Fri Jul 9 11:18:01 2004
+@@ -25,11 +25,15 @@
+ VERSION = 1.2
+
+ TCLVERSION = 8.4
++TCLLVERSION = 84
+
+-INSTALLDIR = /usr/lib/tcl$(TCLVERSION)
++INSTALLDIR = ${PREFIX}/lib/tcl$(TCLVERSION)/gpsmanshp-$(VERSION)
+
+-CFLAGS = -Wall -fPIC -c -I/usr/include/tcl$(TCLVERSION)
+-LINKOPT = -lshp -ltcl$(TCLVERSION)
++CFLAGS += -Wall -fPIC -c -I${PREFIX}/include/tcl$(TCLVERSION)
++CFLAGS += -I${PREFIX}/include
++LINKOPT = -L${PREFIX}/lib -lshp -ltcl$(TCLLVERSION)
++
++all: pkgIndex.tcl
+
+ gpsmanshp.so: gpsmanshp.o
+ $(CC) -shared -o gpsmanshp.so $(LINKOPT) gpsmanshp.o
+@@ -38,12 +42,13 @@
+ $(CC) $(CFLAGS) gpsmanshp.c
+
+ pkgIndex.tcl: gpsmanshp.so
+- echo "source package-8.3.tcl ; pkg_mkIndex -lazy -verbose . gpsmanshp.so" | tclsh$(TCLVERSION)
++ echo "pkg_mkIndex -lazy -verbose . gpsmanshp.so" | tclsh$(TCLVERSION)
+ chmod 644 gpsmanshp.so pkgIndex.tcl
+
+ install: pkgIndex.tcl
+ -mkdir $(INSTALLDIR)
+- cp gpsmanshp.so pkgIndex.tcl $(INSTALLDIR)
++ install -c -s -m 555 -o root -g wheel gpsmanshp.so $(INSTALLDIR)/
++ install -c -m 555 -o root -g wheel pkgIndex.tcl $(INSTALLDIR)/
+
+ clean:
+ rm -f gpsmanshp.o gpsmanshp.so pkgIndex.tcl G*.aux G*.log
diff --git a/graphics/gpsmanshp/files/patch-gpsmanshp.c b/graphics/gpsmanshp/files/patch-gpsmanshp.c
new file mode 100644
index 000000000000..015c6347181a
--- /dev/null
+++ b/graphics/gpsmanshp/files/patch-gpsmanshp.c
@@ -0,0 +1,11 @@
+--- gpsmanshp.c.org Mon Jan 26 14:10:32 2004
++++ gpsmanshp.c Wed Jul 7 20:53:40 2004
+@@ -65,7 +65,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
+-#include <libshp/shapefil.h>
++#include <shapefil.h>
+ #include <tcl.h>
+
+ #define VERSION "1.1"
diff --git a/graphics/gpsmanshp/pkg-descr b/graphics/gpsmanshp/pkg-descr
new file mode 100644
index 000000000000..f30410203787
--- /dev/null
+++ b/graphics/gpsmanshp/pkg-descr
@@ -0,0 +1,6 @@
+A Tcl Package to Read and Write Shapefiles
+
+Gpsmanshp was developed for use in GPSMan, a manager of GPS receiver
+data. It is written in C and is based on shapelib.
+
+WWW: http://www.ncc.up.pt/gpsmanshp/
diff --git a/graphics/gpsmanshp/pkg-plist b/graphics/gpsmanshp/pkg-plist
new file mode 100644
index 000000000000..b9c8ddd007d6
--- /dev/null
+++ b/graphics/gpsmanshp/pkg-plist
@@ -0,0 +1,19 @@
+lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/gpsmanshp.so
+lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/pkgIndex.tcl
+@dirrm lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%
+%%PORTDOCS%%%%DOCSDIR%%/GPL.txt
+%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP.html
+%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP.pdf
+%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_1.html
+%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_2.html
+%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_3.html
+%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_4.html
+%%PORTDOCS%%%%DOCSDIR%%/backgr.gif
+%%PORTDOCS%%%%DOCSDIR%%/blank.gif
+%%PORTDOCS%%%%DOCSDIR%%/gpsman-logo-small.gif
+%%PORTDOCS%%%%DOCSDIR%%/newarr.gif
+%%PORTDOCS%%%%DOCSDIR%%/newearr.gif
+%%PORTDOCS%%%%DOCSDIR%%/next.gif
+%%PORTDOCS%%%%DOCSDIR%%/previous.gif
+%%PORTDOCS%%%%DOCSDIR%%/up.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%