aboutsummaryrefslogtreecommitdiff
path: root/graphics/gqview-devel
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-06-17 14:27:17 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-06-17 14:27:17 +0000
commit71c44ad7d89b87d3fd369db2aaacb58d3edce668 (patch)
tree01f85df71c210dae0e22dc2dd283baf939e26b68 /graphics/gqview-devel
parent1995afb5cfd5cf6037316f5563927f0bff2ca3c4 (diff)
downloadports-71c44ad7d89b87d3fd369db2aaacb58d3edce668.tar.gz
ports-71c44ad7d89b87d3fd369db2aaacb58d3edce668.zip
Notes
Diffstat (limited to 'graphics/gqview-devel')
-rw-r--r--graphics/gqview-devel/Makefile37
-rw-r--r--graphics/gqview-devel/distinfo1
-rw-r--r--graphics/gqview-devel/files/patch-aa12
-rw-r--r--graphics/gqview-devel/pkg-descr6
-rw-r--r--graphics/gqview-devel/pkg-plist26
5 files changed, 82 insertions, 0 deletions
diff --git a/graphics/gqview-devel/Makefile b/graphics/gqview-devel/Makefile
new file mode 100644
index 000000000000..2c35c70ba4d8
--- /dev/null
+++ b/graphics/gqview-devel/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gqview-devel
+# Date Created: 5 March 2003
+# Whom: Andrew Dolgov <cthulhu@cthulhu.ru>
+# based on graphics/gqview port
+#
+# $FreeBSD$
+#
+
+PORTNAME= gqview
+PORTVERSION= 1.3.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= cthulhu@cthulhu.ru
+COMMENT= Another gtk2-based graphic file viewer
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+MAN1= gqview.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/gqview
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gqview
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/gqview-devel/distinfo b/graphics/gqview-devel/distinfo
new file mode 100644
index 000000000000..7668588a8399
--- /dev/null
+++ b/graphics/gqview-devel/distinfo
@@ -0,0 +1 @@
+MD5 (gqview-1.3.1.tar.gz) = 339e64d5454c8e831887f05983e184e6
diff --git a/graphics/gqview-devel/files/patch-aa b/graphics/gqview-devel/files/patch-aa
new file mode 100644
index 000000000000..7b187ca37c35
--- /dev/null
+++ b/graphics/gqview-devel/files/patch-aa
@@ -0,0 +1,12 @@
+*** src/exif.c.orig Wed Mar 5 20:01:10 2003
+--- src/exif.c Wed Mar 5 20:01:27 2003
+***************
+*** 23,29 ****
+ */
+
+ #include <stdio.h>
+- #include <stdint.h>
+ #include <string.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+--- 23,28 ----
diff --git a/graphics/gqview-devel/pkg-descr b/graphics/gqview-devel/pkg-descr
new file mode 100644
index 000000000000..50961072f562
--- /dev/null
+++ b/graphics/gqview-devel/pkg-descr
@@ -0,0 +1,6 @@
+Another gtk2-based graphic file viewer.
+
+WWW: http://gqview.sourceforge.net/
+
+-Vanilla
+vanilla@FreeBSD.ORG
diff --git a/graphics/gqview-devel/pkg-plist b/graphics/gqview-devel/pkg-plist
new file mode 100644
index 000000000000..e16e9e0dea7d
--- /dev/null
+++ b/graphics/gqview-devel/pkg-plist
@@ -0,0 +1,26 @@
+bin/gqview
+%%PORTDOCS%%share/doc/gqview/README
+share/gqview/README
+share/locale/cs/LC_MESSAGES/gqview.mo
+share/locale/da/LC_MESSAGES/gqview.mo
+share/locale/de/LC_MESSAGES/gqview.mo
+share/locale/es/LC_MESSAGES/gqview.mo
+share/locale/et/LC_MESSAGES/gqview.mo
+share/locale/fi/LC_MESSAGES/gqview.mo
+share/locale/fr/LC_MESSAGES/gqview.mo
+share/locale/hu/LC_MESSAGES/gqview.mo
+share/locale/it/LC_MESSAGES/gqview.mo
+share/locale/ja/LC_MESSAGES/gqview.mo
+share/locale/nl/LC_MESSAGES/gqview.mo
+share/locale/no/LC_MESSAGES/gqview.mo
+share/locale/pl/LC_MESSAGES/gqview.mo
+share/locale/pt_BR/LC_MESSAGES/gqview.mo
+share/locale/ru/LC_MESSAGES/gqview.mo
+share/locale/sk/LC_MESSAGES/gqview.mo
+share/locale/sl/LC_MESSAGES/gqview.mo
+share/locale/tr/LC_MESSAGES/gqview.mo
+share/locale/uk/LC_MESSAGES/gqview.mo
+share/locale/zh_CN.GB2312/LC_MESSAGES/gqview.mo
+share/locale/zh_TW/LC_MESSAGES/gqview.mo
+%%PORTDOCS%%@dirrm share/doc/gqview
+@dirrm share/gqview