aboutsummaryrefslogtreecommitdiff
path: root/graphics/gqview/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-22 14:05:56 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-22 14:05:56 +0000
commit92000630adc8f60a21dcd720b593881f91b53244 (patch)
tree6b20214b5c7c91fa067934fd7070c953896af2a8 /graphics/gqview/Makefile
parent2668410b930d8ccdb1cdc49e6abdfa619a4a85c5 (diff)
Notes
Diffstat (limited to 'graphics/gqview/Makefile')
-rw-r--r--graphics/gqview/Makefile31
1 files changed, 13 insertions, 18 deletions
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index 2fea0f7f33cb..ae28aefe4ed5 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -6,37 +6,32 @@
#
PORTNAME= gqview
-PORTVERSION= 1.2.2
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Another gtk-based graphic file viewer
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Another gtk2-based graphic file viewer
+
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
+ png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
-USE_GNOME= gdkpixbuf
-WANT_GNOME= yes
+USE_GNOME= gtk20
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-USE_AUTOCONF_VER= 213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-gnome
+ LIBS="-L${LOCALBASE}/lib"
CONFLICTS= gqview-devel-1.3.*
MAN1= gqview.1
-post-patch:
- @${REINPLACE_CMD} -e 's|INCLUDED_LIBINTL=yes|INCLUDED_LIBINTL=no|g' \
- ${WRKSRC}/aclocal.m4
-
+.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${PREFIX}/share/gnome/pixmaps
- ${MKDIR} ${PREFIX}/share/gnome/apps/Graphics
- ${INSTALL_DATA} ${WRKSRC}/gqview.png ${PREFIX}/share/gnome/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/gqview.desktop ${PREFIX}/share/gnome/apps/Graphics
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>