aboutsummaryrefslogtreecommitdiff
path: root/graphics/grads/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2009-01-21 04:54:57 +0000
committerGreg Lewis <glewis@FreeBSD.org>2009-01-21 04:54:57 +0000
commit8ec0dae891f1c2bc761c407f72c0c7411d8c984f (patch)
tree724f75c16f8174e05b962e06b24a594408ed0cb1 /graphics/grads/Makefile
parent653d4a328b4d9b6562acda35c7cd9ececee2b249 (diff)
downloadports-8ec0dae891f1c2bc761c407f72c0c7411d8c984f.tar.gz
ports-8ec0dae891f1c2bc761c407f72c0c7411d8c984f.zip
Notes
Diffstat (limited to 'graphics/grads/Makefile')
-rw-r--r--graphics/grads/Makefile25
1 files changed, 19 insertions, 6 deletions
diff --git a/graphics/grads/Makefile b/graphics/grads/Makefile
index 4768ef057317..439ce18b719f 100644
--- a/graphics/grads/Makefile
+++ b/graphics/grads/Makefile
@@ -36,6 +36,18 @@ CONFIGURE_ARGS+= --enable-dyn-supplibs \
OPTIONS= HDF "Build hdf-support (only hdf OR netcdf is supported)" on \
NETCDF "Build netcdf-support" off
+.if !defined(NOPORTDATA)
+PORTDATA= *
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+PORTEXAMPLES= *
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_HDF)
@@ -58,16 +70,17 @@ post-configure:
${REINPLACE_CMD} -e "s:%%DATADIR%%:${DATADIR}:" ${WRKSRC}/src/gx.h
post-install:
+.if !defined(NOPORTDATA)
${MKDIR} "${DATADIR}"
- cd ${WRKSRC}/data && ${FIND} . \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} "${DATADIR}"
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} . "${DATADIR}"
+.endif
+.if !defined(NOPORTEXAMPLES)
${MKDIR} "${EXAMPLESDIR}"
- cd ${WRKSRC}/examples && ${FIND} . \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} "${EXAMPLESDIR}"
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . "${EXAMPLESDIR}"
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} "${DOCSDIR}"
- cd ${WRKSRC}/doc && ${FIND} . \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} "${DOCSDIR}"
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . "${DOCSDIR}"
.endif
.include <bsd.port.post.mk>