aboutsummaryrefslogtreecommitdiff
path: root/graphics/grafx2/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-02-03 08:59:53 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-02-03 08:59:53 +0000
commit04fe4c926c6ceb38f039bea4d5762c6aa28cbf01 (patch)
tree5e33f2cd1c59f9f6d65b2112dbf269f7f4cfc7aa /graphics/grafx2/Makefile
parentdb7652420057be5848f5175826b75367cf22710e (diff)
downloadports-04fe4c926c6ceb38f039bea4d5762c6aa28cbf01.tar.gz
ports-04fe4c926c6ceb38f039bea4d5762c6aa28cbf01.zip
Notes
Diffstat (limited to 'graphics/grafx2/Makefile')
-rw-r--r--graphics/grafx2/Makefile30
1 files changed, 7 insertions, 23 deletions
diff --git a/graphics/grafx2/Makefile b/graphics/grafx2/Makefile
index fde4c4fdefae..f452d3733b47 100644
--- a/graphics/grafx2/Makefile
+++ b/graphics/grafx2/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= grafx2
-PORTVERSION= 2.6
-DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTVERSION= 2.7
+DISTVERSIONSUFFIX= .2945-src
CATEGORIES= graphics
-MASTER_SITES= SF/recoil/recoil/${RECOIL_VERSION}/:recoil
-DISTFILES= recoil-${RECOIL_VERSION}${EXTRACT_SUFX}:recoil
+MASTER_SITES= https://gitlab.com/GrafX2/grafX2/-/jobs/422881812/artifacts/raw/ \
+ LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Pixelart-oriented bitmap painting program
@@ -18,19 +17,15 @@ LIB_DEPENDS= libX11.so:x11/libX11 \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= desktop-file-utils gmake gnome iconv:wchar_t pkgconfig sdl
+USES= desktop-file-utils gmake gnome iconv:wchar_t pkgconfig sdl \
+ tar:tgz
USE_SDL= sdl2 image2
-USE_GITLAB= yes
-
-GL_ACCOUNT= GrafX2
-GL_PROJECT= grafX2
-GL_COMMIT= 5d8c61e41011a8106359343243e1050af4e7fd1f
INSTALLS_ICONS= yes
GRAFX2_API= sdl2
-RECOIL_VERSION= 4.3.1
+WRKSRC= ${WRKDIR}/grafx2
WRKSRC_SUBDIR= src
CFLAGS+= -DHAVE_SYS_PARAM_H -DHAVE_SYS_UCRED_H -DHAVE_SYS_MOUNT_H
MAKE_ENV+= API=${GRAFX2_API}
@@ -47,17 +42,6 @@ TTF_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
TTF_USE= SDL=ttf2
TTF_MAKE_ARGS_OFF= NOTTF=1
-post-extract:
- @${MV} ${WRKDIR}/recoil-${RECOIL_VERSION} ${WRKSRC}/../3rdparty/
-
-post-patch:
- @${REINPLACE_CMD} \
- -e 's|macosx|FreeBSD|g' \
- ${WRKSRC}/mountlist.c ${WRKSRC}/init.c
- @${REINPLACE_CMD} \
- -e 's|Extract_path(program_dir, argv0);|strcpy(program_dir,"${PREFIX}/bin/");|' \
- ${WRKSRC}/setup.c
-
post-install:
@${MV} ${STAGEDIR}${PREFIX}/bin/grafx2-${GRAFX2_API} \
${STAGEDIR}${PREFIX}/bin/grafx2