aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphite2
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-01-22 09:46:53 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-01-22 09:46:53 +0000
commit79ac946b88e6dd1791edb2e585388881a94a9270 (patch)
tree2ad0e9a348454301677620fb2bb1d15402562d5d /graphics/graphite2
parent8457e90924eed4da514d717e5ce2614204d38c41 (diff)
Notes
Diffstat (limited to 'graphics/graphite2')
-rw-r--r--graphics/graphite2/Makefile26
-rw-r--r--graphics/graphite2/distinfo2
-rw-r--r--graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp11
-rw-r--r--graphics/graphite2/pkg-descr12
-rw-r--r--graphics/graphite2/pkg-plist13
5 files changed, 64 insertions, 0 deletions
diff --git a/graphics/graphite2/Makefile b/graphics/graphite2/Makefile
new file mode 100644
index 000000000000..c20718a43df3
--- /dev/null
+++ b/graphics/graphite2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: graphite2
+# Date created: 2012-01-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graphite2
+PORTVERSION= 1.0.3
+CATEGORIES= graphics print
+MASTER_SITES= SF/silgraphite/${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Rendering capabilities for complex non-Roman writing systems
+
+USE_GNOME= gnomehack
+USE_CMAKE= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/pkgconfig,data/pkgconfig,g' ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/graphics/graphite2/distinfo b/graphics/graphite2/distinfo
new file mode 100644
index 000000000000..e59e75c1dc3f
--- /dev/null
+++ b/graphics/graphite2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (graphite2-1.0.3.tgz) = 643c5307a3fdc31754a18c8c1398d4036a107e4bdc03d9a265fcadfc85d4a07a
+SIZE (graphite2-1.0.3.tgz) = 4352127
diff --git a/graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp b/graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp
new file mode 100644
index 000000000000..249407c65e25
--- /dev/null
+++ b/graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp
@@ -0,0 +1,11 @@
+--- ./gr2fonttest/gr2FontTest.cpp.orig 2011-09-22 17:30:02.000000000 +0200
++++ ./gr2fonttest/gr2FontTest.cpp 2012-01-22 10:24:33.468384204 +0100
+@@ -176,7 +176,7 @@
+ #ifdef WIN32
+ const char * pText = reinterpret_cast<char*>(pIn);
+ #else
+- char * pText = reinterpret_cast<char*>(pIn);
++ const char * pText = reinterpret_cast<char*>(pIn);
+ #endif
+ // It seems to be necessary to include the trailing null to prevent
+ // stray characters appearing with utf16
diff --git a/graphics/graphite2/pkg-descr b/graphics/graphite2/pkg-descr
new file mode 100644
index 000000000000..b6590031c119
--- /dev/null
+++ b/graphics/graphite2/pkg-descr
@@ -0,0 +1,12 @@
+Graphite is a package that can be used to create "smart fonts" capable of
+displaying writing systems with various complex behaviors, such as:
+
+ * contextual shaping
+ * ligatures
+ * reordering
+ * split glyphs
+ * bidirectionality
+ * stacking diacritics
+ * complex positioning
+
+WWW: http://scripts.sil.org/RenderingGraphite
diff --git a/graphics/graphite2/pkg-plist b/graphics/graphite2/pkg-plist
new file mode 100644
index 000000000000..3f81a97a3821
--- /dev/null
+++ b/graphics/graphite2/pkg-plist
@@ -0,0 +1,13 @@
+%%DATADIR%%/graphite2-release.cmake
+%%DATADIR%%/graphite2.cmake
+bin/comparerenderer
+bin/gr2fonttest
+include/graphite2/Font.h
+include/graphite2/Segment.h
+include/graphite2/Types.h
+lib/libgraphite2.so
+lib/libgraphite2.so.2.0.0
+libdata/pkgconfig/graphite2.pc
+@dirrmtry libdata/pkgconfig
+@dirrmtry include/graphite2
+@dirrmtry %%DATADIR%%