aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphite2
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2017-04-20 18:40:09 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2017-04-20 18:40:09 +0000
commit74279ba09a0d78a6e173b5d5b340d33403d3e97b (patch)
treec952e91f00b7d3a1eae93c84a564a912b759c9e1 /graphics/graphite2
parent3e6b6b7704280ad106c83ef181182ceba69f4709 (diff)
downloadports-74279ba09a0d78a6e173b5d5b340d33403d3e97b.tar.gz
ports-74279ba09a0d78a6e173b5d5b340d33403d3e97b.zip
Notes
Diffstat (limited to 'graphics/graphite2')
-rw-r--r--graphics/graphite2/Makefile1
-rw-r--r--graphics/graphite2/files/patch-src_FeatureMap.cpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/graphics/graphite2/Makefile b/graphics/graphite2/Makefile
index f04eb20a9db5..eec2f7bcf753 100644
--- a/graphics/graphite2/Makefile
+++ b/graphics/graphite2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= graphite2
PORTVERSION= 1.3.9
+PORTREVISION= 1
CATEGORIES= graphics print
MAINTAINER= office@FreeBSD.org
diff --git a/graphics/graphite2/files/patch-src_FeatureMap.cpp b/graphics/graphite2/files/patch-src_FeatureMap.cpp
new file mode 100644
index 000000000000..d6a2d28e8a3e
--- /dev/null
+++ b/graphics/graphite2/files/patch-src_FeatureMap.cpp
@@ -0,0 +1,12 @@
+--- src/FeatureMap.cpp.orig 2016-11-11 09:53:21 UTC
++++ src/FeatureMap.cpp
+@@ -275,7 +275,8 @@ bool FeatureRef::applyValToFeature(uint3
+ else
+ if (pDest.m_pMap!=&m_pFace->theSill().theFeatureMap())
+ return false; //incompatible
+- pDest.reserve(m_index);
++ if (m_index >= pDest.size())
++ pDest.resize(m_index+1);
+ pDest[m_index] &= ~m_mask;
+ pDest[m_index] |= (uint32(val) << m_bits);
+ return true;