aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphviz
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-07-06 12:02:23 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-07-06 12:02:23 +0000
commit4a404e03acd0c55933e97ae48426144f79c6f3a4 (patch)
tree23fb4ff55da8667c451f7f78dd1288a57ab20df3 /graphics/graphviz
parent0a0779177a35b71b1230d563e40615d627e33023 (diff)
downloadports-4a404e03acd0c55933e97ae48426144f79c6f3a4.tar.gz
ports-4a404e03acd0c55933e97ae48426144f79c6f3a4.zip
Notes
Diffstat (limited to 'graphics/graphviz')
-rw-r--r--graphics/graphviz/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 723f853c66ba..5a63a6468767 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -138,8 +138,7 @@ PERL_CONFIGURE_ENABLE= perl
PERL_VARS= SHEBANG_FILES+=tclpkg/gv/demo/modgraph.pl
PHP_CONFIGURE_ENABLE= php
PHP_CPPFLAGS= -I${LOCALBASE}/include/php/Zend
-PHP_VARS= SHEBANG_FILES+=tclpkg/gv/demo/modgraph.php \
- IGNORE_WITH_PHP=56
+PHP_VARS= SHEBANG_FILES+=tclpkg/gv/demo/modgraph.php
PYTHON_CONFIGURE_ENABLE= python
PYTHON_LDFLAGS= "-L${PYTHONBASE}/lib"
PYTHON_VARS= SHEBANG_FILES+=tclpkg/gv/demo/modgraph.py
@@ -207,6 +206,15 @@ CONFIGURE_ARGS+= --disable-swig
CONFIGURE_ENV+= SWIG="/nonexistent"
.endif
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MPHP}
+.if ${PHP_VER} < 70
+# force old PHP API
+MAKE_ARGS+= SWIG_PHP_OPT=-php5
+.endif
+.endif
+
post-patch:
${FIND} ${WRKSRC} -name Makefile.in | \
${XARGS} ${REINPLACE_CMD} \
@@ -288,4 +296,4 @@ post-install-EXAMPLES-on:
${WRKSRC}/tclpkg/tclpathplan/demo/pathplan_data/*.dat \
${STAGEDIR}${EXAMPLESDIR}/pathplan_data/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>