aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphviz
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-29 20:04:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-29 20:04:14 +0000
commit414bfec1bc4d8607df8b00b1251573ddfa904945 (patch)
treec7428779503dc3f26737b7ca78ec2b8ebf6cb664 /graphics/graphviz
parent37a954114552a3ac5d942e48d7521d585980bcda (diff)
downloadports-414bfec1bc4d8607df8b00b1251573ddfa904945.tar.gz
ports-414bfec1bc4d8607df8b00b1251573ddfa904945.zip
Notes
Diffstat (limited to 'graphics/graphviz')
-rw-r--r--graphics/graphviz/Makefile8
-rw-r--r--graphics/graphviz/files/patch-lib-gvc-gvconfig.c10
2 files changed, 17 insertions, 1 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index d683bced86e5..916070326ce9 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -59,6 +59,12 @@ MLINKS= dot.1 circo.1 \
MYPORTDOCS= dotguide.pdf dottyguide.pdf leftyguide.pdf \
neatoguide.pdf Dot.ref FAQ.html
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4+
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -67,4 +73,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/graphviz/files/patch-lib-gvc-gvconfig.c b/graphics/graphviz/files/patch-lib-gvc-gvconfig.c
new file mode 100644
index 000000000000..1b89d143d344
--- /dev/null
+++ b/graphics/graphviz/files/patch-lib-gvc-gvconfig.c
@@ -0,0 +1,10 @@
+--- lib/gvc/gvconfig.c.orig Thu Dec 29 12:33:58 2005
++++ lib/gvc/gvconfig.c Thu Dec 29 11:02:51 2005
+@@ -21,6 +21,7 @@
+ #include <string.h>
+
+ #ifndef DISABLE_LTDL
++#include <sys/types.h>
+ #include <regex.h>
+ #include <sys/stat.h>
+ #include <unistd.h>