aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphviz
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-02-27 16:13:13 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-02-27 16:13:13 +0000
commite714e6f72e9ab3b3349d07be6993d2bff6ba30d0 (patch)
tree73119dd4e1e0ed539b299daa138630a6b86fdf55 /graphics/graphviz
parenta1c820955ce4657be300fd2a1c91114eeb54793a (diff)
- fix package for option WITH_LUA
132089 Scot Hetzel - mark options WITH_TCL and WITH_TK as BROKEN swig does not build valid code any more. - fix option WITH_PHP
Notes
Notes: svn path=/head/; revision=229184
Diffstat (limited to 'graphics/graphviz')
-rw-r--r--graphics/graphviz/Makefile10
-rw-r--r--graphics/graphviz/files/patch-configure26
-rw-r--r--graphics/graphviz/pkg-plist1
3 files changed, 31 insertions, 6 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 3c482086a1b9..0fc4b0f06e19 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= graphviz
PORTVERSION= 2.20.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics tk
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
@@ -118,6 +118,7 @@ PLIST_SUB+= WITH_TK=""
PLIST_SUB+= WITH_TK="@comment "
.endif
.if defined(WITH_TCL) || defined(WITH_TK)
+BROKEN= Swig cant build tcl code
CPPFLAGS+= -I${TCL_INCLUDEDIR}
USE_TCL_BUILD= 84+
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
@@ -345,7 +346,8 @@ USE_LUA= yes
.include "${PORTSDIR}/Mk/bsd.lua.mk"
CFLAGS+= -I${LUA_INCDIR}
LDFLAGS+= -L${LUA_LIBDIR} -lm
-CONFIGURE_ENV+= LUA="${LUA_BINDIR}/lua"
+CONFIGURE_ENV+= LUA="${LUA_BINDIR}/lua" \
+ LUA_INSTALL_DIR=${PREFIX}/lib/lua/${LUA_VER}
MANN+= gv_lua.n
.else
CONFIGURE_ARGS+= --disable-lua
@@ -371,7 +373,7 @@ CONFIGURE_ARGS+= --disable-guile
PLIST_SUB+= WITH_GUILE="@comment "
.endif
-pre-patch:
+post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | \
${XARGS} ${REINPLACE_CMD} \
-e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
@@ -400,7 +402,7 @@ pre-patch:
${WRKSRC}/cmd/smyrna/tvnodes.h
@${REINPLACE_CMD} -e 's|#include "regex_win32.h"|#include <regex.h>|' \
${WRKSRC}/cmd/smyrna/btree.c
- @${REINPLACE_CMD} -e 's|#! /bin/sh|#! /${LOCALBASE}/bin/bash|g' \
+ @${REINPLACE_CMD} -e 's|#! /bin/sh|#! ${LOCALBASE}/bin/bash|g' \
${WRKSRC}/configure
.if defined(WITH_TK)
diff --git a/graphics/graphviz/files/patch-configure b/graphics/graphviz/files/patch-configure
index 4de1e70fdb59..a8d4adca0061 100644
--- a/graphics/graphviz/files/patch-configure
+++ b/graphics/graphviz/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2008-07-07 04:27:21.000000000 +0200
-+++ configure 2008-07-11 11:42:18.000000000 +0200
+--- configure.orig 2008-10-08 01:54:55.000000000 +0200
++++ configure 2009-02-27 11:12:03.000000000 +0100
@@ -6481,6 +6481,9 @@
*-apple-darwin* )
CFLAGS="${CFLAGS} -fno-common -Wall"
@@ -10,3 +10,25 @@
*-freebsd* )
CFLAGS="${CFLAGS} -Wstrict-prototypes -Wpointer-arith -Wall -ffast-math"
;;
+@@ -26247,7 +26250,9 @@
+
+ LUA_INCLUDES=""
+ LUA_LIBS=""
+- LUA_INSTALL_DIR=""
++ if test -z "$LUA_INSTALL_DIR" ; then
++ LUA_INSTALL_DIR=""
++ fi
+
+ if test -n "$lua_inc"; then
+ CFLAGS="$CFLAGS -I$lua_inc"
+@@ -27376,8 +27381,8 @@
+ if test "x$use_swig" != "xYes"; then
+ use_php="No (swig not available)"
+ else
+- if test `$SWIG -help 2>&1 | $GREP -c '\-php5 *- Generate'` = 0; then
+- use_php="No (swig does not support -php5 option)"
++ if test `$SWIG -help 2>&1 | $GREP -c '\-php *- Generate'` = 0; then
++ use_php="No (swig does not support -php option)"
+ else
+ # Extract the first word of "php", so it can be a program name with args.
+ set dummy php; ac_word=$2
diff --git a/graphics/graphviz/pkg-plist b/graphics/graphviz/pkg-plist
index 38e9d255118b..feeaf1bf2908 100644
--- a/graphics/graphviz/pkg-plist
+++ b/graphics/graphviz/pkg-plist
@@ -163,6 +163,7 @@ lib/graphviz/libgvplugin_neato_layout.a
%%WITH_LUA%%lib/graphviz/lua/libgv_lua.a
%%WITH_LUA%%lib/graphviz/lua/libgv_lua.la
%%WITH_LUA%%lib/graphviz/lua/libgv_lua.so
+%%WITH_LUA%%lib/lua/%%LUA_VER%%/gv.so
%%WITH_PERL%%lib/graphviz/perl/gv.so
%%WITH_PERL%%lib/graphviz/perl/gv.pm
%%WITH_PERL%%lib/graphviz/perl/libgv_perl.a