aboutsummaryrefslogtreecommitdiff
path: root/graphics/gscan2pdf/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-09-07 07:07:28 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-09-07 07:07:28 +0000
commite3eda751695ecb40bb81d3f15562a2b68a5c908a (patch)
tree3dade8544ea5e90b6b82d66c34d536154688e969 /graphics/gscan2pdf/Makefile
parent2ad3bf9db383d51b4205cb3e76d87e3037fd1c59 (diff)
Notes
Diffstat (limited to 'graphics/gscan2pdf/Makefile')
-rw-r--r--graphics/gscan2pdf/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/graphics/gscan2pdf/Makefile b/graphics/gscan2pdf/Makefile
index 2ae11d743e28..1e21c72af58c 100644
--- a/graphics/gscan2pdf/Makefile
+++ b/graphics/gscan2pdf/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= gscan2pdf
-PORTVERSION= 0.9.23
-PORTREVISION= 2
+PORTVERSION= 0.9.24
CATEGORIES= graphics
MASTER_SITES= SFE
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= chinsan@FreeBSD.org
COMMENT= Produce PDF from scanned documents
RUN_DEPENDS= p5-PDF-API2>=0.57:${PORTSDIR}/textproc/p5-PDF-API2 \
@@ -29,13 +28,23 @@ RUN_DEPENDS= p5-PDF-API2>=0.57:${PORTSDIR}/textproc/p5-PDF-API2 \
p5-gettext>=1.05:${PORTSDIR}/devel/p5-Locale-gettext
# xdg-email:${PORTSDIR}/devel/xdg-utils
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= librsvg2
PERL_CONFIGURE= yes
MAN1= ${PORTNAME}.1
PORT_VERBS= ${PORTNAME} Gscan2pdf
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/--parents/-p/g;s|$$sharedir/man|${MANPREFIX}/man|g;s|1p|1|g'\
-e '/SITEPREFIX/s|/usr|${PREFIX}|' ${WRKSRC}/Makefile.PL