aboutsummaryrefslogtreecommitdiff
path: root/graphics/gsnapshot
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-06 07:38:19 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-06 07:38:19 +0000
commitea705d39bf2fdab8b01b741c023e74533fae3812 (patch)
tree9d9ba191e349b148efcf21f1857d3bfb0e0496ca /graphics/gsnapshot
parente7e239d19aec46e8a7a220ced1fa04b8c170ba90 (diff)
downloadports-ea705d39bf2fdab8b01b741c023e74533fae3812.tar.gz
ports-ea705d39bf2fdab8b01b741c023e74533fae3812.zip
Notes
Diffstat (limited to 'graphics/gsnapshot')
-rw-r--r--graphics/gsnapshot/Makefile2
-rw-r--r--graphics/gsnapshot/files/patch-src__language.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/graphics/gsnapshot/Makefile b/graphics/gsnapshot/Makefile
index 11f4c874c2e7..d6572aac6a08 100644
--- a/graphics/gsnapshot/Makefile
+++ b/graphics/gsnapshot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gsnapshot
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
diff --git a/graphics/gsnapshot/files/patch-src__language.c b/graphics/gsnapshot/files/patch-src__language.c
new file mode 100644
index 000000000000..0d416df7b406
--- /dev/null
+++ b/graphics/gsnapshot/files/patch-src__language.c
@@ -0,0 +1,12 @@
+--- ./src/language.c.orig 2007-07-16 01:05:23.000000000 +0300
++++ ./src/language.c 2008-05-06 10:20:22.000000000 +0300
+@@ -335,6 +335,9 @@
+ {
+ if (spoken == NULL) {
+ char *lang = getenv("LANG");
++ if(!lang)
++ return TranslationEnglish[label].locale;
++
+ if (strcmp(lang, "de") == 0 || strcmp(lang, "de_DE") == 0)
+ spoken = TranslationGerman;
+ else if (strcmp(lang, "es") == 0 || strcmp(lang, "es_ES") == 0)