aboutsummaryrefslogtreecommitdiff
path: root/graphics/gstreamer1-plugins-gl
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-12-16 13:35:01 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-12-16 13:35:01 +0000
commitc6e9859c13cd4827ad2782f678ec0a3633d122ce (patch)
tree9f5703f594896a48eae53e004be52fd12fcce700 /graphics/gstreamer1-plugins-gl
parent0d5a1fd6c437b0c40b926ff0920b2c65f4f6250b (diff)
downloadports-c6e9859c13cd4827ad2782f678ec0a3633d122ce.tar.gz
ports-c6e9859c13cd4827ad2782f678ec0a3633d122ce.zip
Notes
Diffstat (limited to 'graphics/gstreamer1-plugins-gl')
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile27
-rw-r--r--graphics/gstreamer1-plugins-gl/pkg-plist37
2 files changed, 64 insertions, 0 deletions
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
new file mode 100644
index 000000000000..c948ab0d2b01
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer GL graphics plugin
+
+GST_PLUGIN= gl
+DIST= bad
+
+#USE_CSTD= gnu89
+#USE_CSTD= c11
+#USE_CXXSTD= c++11
+MAKE_ARGS+= V=1
+#USE_GCC= yes
+PLIST= ${.CURDIR}/pkg-plist
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+pre-build:
+ @cd ${WRKSRC}/gst-libs/gst/gl && ${GMAKE}
+
+post-install:
+ @cd ${WRKSRC}/gst-libs/gst/gl && ${SETENV} DESTDIR=${STAGEDIR} \
+ INSTALL_TARGET=${INSTALL_TARGET} ${GMAKE} install
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-gl/pkg-plist b/graphics/gstreamer1-plugins-gl/pkg-plist
new file mode 100644
index 000000000000..9a56ab88fed4
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gl/pkg-plist
@@ -0,0 +1,37 @@
+include/gstreamer-%%VERSION%%/gst/gl/egl/gsteglimagememory.h
+include/gstreamer-%%VERSION%%/gst/gl/egl/gstgldisplay_egl.h
+include/gstreamer-%%VERSION%%/gst/gl/gl.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/all_functions.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/base.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/blending.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/eglimage.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/fbo.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/fixedfunction.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/gles.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/gstgl_compat.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/gstgl_gles2compat.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/opengl.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/shaders.h
+include/gstreamer-%%VERSION%%/gst/gl/gstgl_fwd.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglapi.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglbufferpool.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglcolorconvert.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglconfig.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglcontext.h
+include/gstreamer-%%VERSION%%/gst/gl/gstgldisplay.h
+include/gstreamer-%%VERSION%%/gst/gl/gstgldownload.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglfeature.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglfilter.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglframebuffer.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglmemory.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglshader.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglshadervariables.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglupload.h
+include/gstreamer-%%VERSION%%/gst/gl/gstgluploadmeta.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglutils.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglwindow.h
+include/gstreamer-%%VERSION%%/gst/gl/x11/gstgldisplay_x11.h
+lib/gstreamer-%%VERSION%%/libgstopengl.so
+lib/libgstgl-%%VERSION%%.so
+lib/libgstgl-%%VERSION%%.so.0
+lib/libgstgl-%%VERSION%%.so.%%SOVERSION%%