aboutsummaryrefslogtreecommitdiff
path: root/graphics/gstreamer1-plugins-gl
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
commitd566d54fa6c982cb4bed8330d51cb11bfe3674ed (patch)
treedb8ae1482499741d4dbb123637dac45579f28eb5 /graphics/gstreamer1-plugins-gl
parent190ced69a285efe9780eea205067282568a3063f (diff)
downloadports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.tar.gz
ports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.zip
Notes
Diffstat (limited to 'graphics/gstreamer1-plugins-gl')
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile7
-rw-r--r--graphics/gstreamer1-plugins-gl/pkg-plist6
2 files changed, 7 insertions, 6 deletions
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
index 1cef84e08113..f27732739fff 100644
--- a/graphics/gstreamer1-plugins-gl/Makefile
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -8,16 +8,17 @@ COMMENT= GStreamer GL graphics plugin
GST_PLUGIN= gl
DIST= bad
+GL_GST_DIRS= gst-libs/gst/allocators
PLIST= ${.CURDIR}/pkg-plist
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
pre-build:
- @cd ${WRKSRC}/gst-libs/gst/gl && ${GMAKE}
+.for dir in ${GL_GST_DIRS}
+ @(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
post-install:
- @cd ${WRKSRC}/gst-libs/gst/gl && ${SETENV} DESTDIR=${STAGEDIR} \
- INSTALL_TARGET=${INSTALL_TARGET} ${GMAKE} install
${INSTALL_DATA} ${WRKSRC}/pkgconfig/gstreamer-gl.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig/gstreamer-gl-1.0.pc
diff --git a/graphics/gstreamer1-plugins-gl/pkg-plist b/graphics/gstreamer1-plugins-gl/pkg-plist
index 7be88efbd1ed..444074499793 100644
--- a/graphics/gstreamer1-plugins-gl/pkg-plist
+++ b/graphics/gstreamer1-plugins-gl/pkg-plist
@@ -1,7 +1,7 @@
include/gstreamer-%%VERSION%%/gst/gl/egl/gstegl.h
-include/gstreamer-%%VERSION%%/gst/gl/egl/gsteglimagememory.h
-include/gstreamer-%%VERSION%%/gst/gl/egl/gstglcontext_egl.h
+include/gstreamer-%%VERSION%%/gst/gl/egl/gsteglimage.h
include/gstreamer-%%VERSION%%/gst/gl/egl/gstgldisplay_egl.h
+include/gstreamer-%%VERSION%%/gst/gl/egl/gstglmemoryegl.h
include/gstreamer-%%VERSION%%/gst/gl/gl.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/all_functions.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/base.h
@@ -28,7 +28,6 @@ include/gstreamer-%%VERSION%%/gst/gl/gstglbuffer.h
include/gstreamer-%%VERSION%%/gst/gl/gstglbufferpool.h
include/gstreamer-%%VERSION%%/gst/gl/gstglcolorconvert.h
include/gstreamer-%%VERSION%%/gst/gl/gstglcontext.h
-include/gstreamer-%%VERSION%%/gst/gl/gstglcontrolbindingproxy.h
include/gstreamer-%%VERSION%%/gst/gl/gstgldebug.h
include/gstreamer-%%VERSION%%/gst/gl/gstgldisplay.h
include/gstreamer-%%VERSION%%/gst/gl/gstglfeature.h
@@ -39,6 +38,7 @@ include/gstreamer-%%VERSION%%/gst/gl/gstglmemory.h
include/gstreamer-%%VERSION%%/gst/gl/gstglmemorypbo.h
include/gstreamer-%%VERSION%%/gst/gl/gstgloverlaycompositor.h
include/gstreamer-%%VERSION%%/gst/gl/gstglquery.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglrenderbuffer.h
include/gstreamer-%%VERSION%%/gst/gl/gstglshader.h
include/gstreamer-%%VERSION%%/gst/gl/gstglshaderstrings.h
include/gstreamer-%%VERSION%%/gst/gl/gstglsl.h