aboutsummaryrefslogtreecommitdiff
path: root/graphics/gthumb2/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-17 22:22:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-17 22:22:42 +0000
commit3e5f9c80034fe60deefdecbf84c7940a69cf8e6a (patch)
tree409b675ee0d51ab5d9bb759c108f888258bc4361 /graphics/gthumb2/Makefile
parent37345177bab095b1e8db27ef2e3e7805b28ea93f (diff)
downloadports-3e5f9c80034fe60deefdecbf84c7940a69cf8e6a.tar.gz
ports-3e5f9c80034fe60deefdecbf84c7940a69cf8e6a.zip
Notes
Diffstat (limited to 'graphics/gthumb2/Makefile')
-rw-r--r--graphics/gthumb2/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/gthumb2/Makefile b/graphics/gthumb2/Makefile
index cd03c6480d3f..95bbe5e5fd1c 100644
--- a/graphics/gthumb2/Makefile
+++ b/graphics/gthumb2/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gthumb2
-PORTVERSION= 2.2.0
+PORTVERSION= 2.3.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.3
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,7 +19,7 @@ COMMENT= An image viewer and browser for the GNOME 2 environment
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui
+USE_GNOME= gnomeprefix gnomehack lthack libgnomeui libgnomeprintui
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -33,4 +33,8 @@ MAN1= gthumb.1
LIB_DEPENDS+= exif.10:${PORTSDIR}/graphics/libexif
.endif
+.if defined(WITH_GPHOTO2) || exists(${LOCALBASE}/lib/libgphoto2.so.2)
+LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+.endif
+
.include <bsd.port.post.mk>