aboutsummaryrefslogtreecommitdiff
path: root/graphics/gthumb
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-03 18:55:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-03 18:55:35 +0000
commita862292ee0c0c7732ecb9b02a352324280d387ee (patch)
treef394b34731ff8bb40551a5c003935fa0bab03a8d /graphics/gthumb
parent19751b04d539d68fc9604adf529c74615556e438 (diff)
downloadports-a862292ee0c0c7732ecb9b02a352324280d387ee.tar.gz
ports-a862292ee0c0c7732ecb9b02a352324280d387ee.zip
Notes
Diffstat (limited to 'graphics/gthumb')
-rw-r--r--graphics/gthumb/Makefile25
-rw-r--r--graphics/gthumb/distinfo6
-rw-r--r--graphics/gthumb/files/patch-libgthumb_image-loader.c14
-rw-r--r--graphics/gthumb/files/patch-libgthumb_image-viewer.c10
-rw-r--r--graphics/gthumb/files/patch-rotation-utils.h10
-rw-r--r--graphics/gthumb/pkg-plist84
6 files changed, 59 insertions, 90 deletions
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 1d52d4a6c199..a364955a89da 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gthumb
-PORTVERSION= 2.6.9
-PORTREVISION= 1
+PORTVERSION= 2.8.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.8
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,22 +19,36 @@ COMMENT= An image viewer and browser for the GNOME 2 environment
LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libgnomeprintui
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= gthumb.schemas
MAN1= gthumb.1
+OPTIONS= GPHOTO2 "Support loading photos from digital cameras" On \
+ IPTCDATA "Support for IPTC metadata" Off
+
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GPHOTO2) || exists(${LOCALBASE}/lib/libgphoto2.so.2)
+.if !defined(WITHOUT_GPHOTO2)
LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+CONFIGURE_ARGS+=--enable-gphoto2
+.else
+CONFIGURE_ARGS+=--disable-gphoto2
+.endif
+
+.if defined(WITH_IPTCDATA)
+LIB_DEPENDS+= iptcdata.3:${PORTSDIR}/graphics/libiptcdata
+CONFIGURE_ARGS+=--enable-iptcdata
+.else
+CONFIGURE_ARGS+=--disable-iptcdata
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/gthumb/distinfo b/graphics/gthumb/distinfo
index e0d576358418..d7b3fca9a5db 100644
--- a/graphics/gthumb/distinfo
+++ b/graphics/gthumb/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gthumb-2.6.9.tar.bz2) = 56b35aa24d4461d7e0ee3c4dea3c6141
-SHA256 (gnome2/gthumb-2.6.9.tar.bz2) = da2a7e2c92d7ead726cb742a05230c311daed2fd3e8e11f069154eb746aef2e2
-SIZE (gnome2/gthumb-2.6.9.tar.bz2) = 1785398
+MD5 (gnome2/gthumb-2.8.0.tar.bz2) = 414093862b94d623f1270069c383af13
+SHA256 (gnome2/gthumb-2.8.0.tar.bz2) = 38b401c41454a0835857ea0b97ad63c296183f155b099b27036bebbc0824b144
+SIZE (gnome2/gthumb-2.8.0.tar.bz2) = 1833264
diff --git a/graphics/gthumb/files/patch-libgthumb_image-loader.c b/graphics/gthumb/files/patch-libgthumb_image-loader.c
deleted file mode 100644
index 461a0048fa61..000000000000
--- a/graphics/gthumb/files/patch-libgthumb_image-loader.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- libgthumb/image-loader.c.orig Mon Mar 3 15:45:30 2003
-+++ libgthumb/image-loader.c Mon Mar 3 15:45:32 2003
-@@ -534,8 +534,10 @@
- image_loader_sync_pixbuf (il);
-
- priv->done_func = NULL;
-- if (done_func != NULL)
-+ if (done_func != NULL) {
- (*done_func) (priv->done_func_data);
-+ return;
-+ }
-
- if (! priv->emit_signal)
- return;
diff --git a/graphics/gthumb/files/patch-libgthumb_image-viewer.c b/graphics/gthumb/files/patch-libgthumb_image-viewer.c
deleted file mode 100644
index d01b73b9e054..000000000000
--- a/graphics/gthumb/files/patch-libgthumb_image-viewer.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libgthumb/image-viewer.c.orig Sun Aug 18 00:36:59 2002
-+++ libgthumb/image-viewer.c Sun Aug 18 00:37:08 2002
-@@ -21,6 +21,7 @@
- */
-
- #include <math.h>
-+#include <sys/types.h>
- #include <gdk/gdkkeysyms.h>
- #include <gtk/gtkadjustment.h>
- #include <gtk/gtkhscrollbar.h>
diff --git a/graphics/gthumb/files/patch-rotation-utils.h b/graphics/gthumb/files/patch-rotation-utils.h
new file mode 100644
index 000000000000..a5ebab846e53
--- /dev/null
+++ b/graphics/gthumb/files/patch-rotation-utils.h
@@ -0,0 +1,10 @@
+--- src/rotation-utils.h.orig Sat Dec 24 14:08:28 2005
++++ src/rotation-utils.h Sun Dec 3 16:39:14 2006
+@@ -54,6 +54,7 @@
+
+ void update_orientation_field (const char *filename,
+ RotationData *rot_data);
++void reset_orientation_field (const char *path);
+ gboolean swap_fields (ExifContent *content,
+ ExifTag tag1,
+ ExifTag tag2);
diff --git a/graphics/gthumb/pkg-plist b/graphics/gthumb/pkg-plist
index d2ad985d6dd0..94c419d4d240 100644
--- a/graphics/gthumb/pkg-plist
+++ b/graphics/gthumb/pkg-plist
@@ -1,4 +1,7 @@
bin/gthumb
+lib/gthumb/libgthumb.a
+lib/gthumb/libgthumb.la
+lib/gthumb/libgthumb.so
lib/gthumb/modules/libduplicates.a
lib/gthumb/modules/libduplicates.la
lib/gthumb/modules/libduplicates.so
@@ -17,10 +20,7 @@ lib/gthumb/modules/libsearch.so
lib/gthumb/modules/libwebexporter.a
lib/gthumb/modules/libwebexporter.la
lib/gthumb/modules/libwebexporter.so
-lib/libgthumb.a
-lib/libgthumb.la
-lib/libgthumb.so
-lib/libgthumb-2.6.9.so
+libdata/bonobo/servers/GNOME_GThumb.server
libdata/bonobo/servers/GNOME_GThumb_CatalogView.server
libdata/bonobo/servers/GNOME_GThumb_Viewer.server
libexec/gthumb-catalog-view
@@ -29,22 +29,6 @@ share/gnome/application-registry/gthumb.applications
share/gnome/applications/gthumb.desktop
share/gnome/gnome-2.0/ui/GNOME_GThumb_CatalogView.xml
share/gnome/gnome-2.0/ui/GNOME_GThumb_Viewer.xml
-share/gnome/gthumb/albumthemes/BlueStripes/back.png
-share/gnome/gthumb/albumthemes/BlueStripes/background.png
-share/gnome/gthumb/albumthemes/BlueStripes/bottom.png
-share/gnome/gthumb/albumthemes/BlueStripes/image.gthtml
-share/gnome/gthumb/albumthemes/BlueStripes/index.gthtml
-share/gnome/gthumb/albumthemes/BlueStripes/layout.css
-share/gnome/gthumb/albumthemes/BlueStripes/left.png
-share/gnome/gthumb/albumthemes/BlueStripes/next.png
-share/gnome/gthumb/albumthemes/BlueStripes/prev.png
-share/gnome/gthumb/albumthemes/BlueStripes/preview.png
-share/gnome/gthumb/albumthemes/BlueStripes/right.png
-share/gnome/gthumb/albumthemes/BlueStripes/style.css
-share/gnome/gthumb/albumthemes/BlueStripes/thumbnail.gthtml
-share/gnome/gthumb/albumthemes/BlueStripes/top.png
-share/gnome/gthumb/albumthemes/BlueStripes/transparent.png
-share/gnome/gthumb/albumthemes/BlueStripes/white-dot.png
share/gnome/gthumb/albumthemes/Classic/1.gif
share/gnome/gthumb/albumthemes/Classic/back.png
share/gnome/gthumb/albumthemes/Classic/background.gif
@@ -75,22 +59,12 @@ share/gnome/gthumb/albumthemes/ClassicClips/right.png
share/gnome/gthumb/albumthemes/ClassicClips/style.css
share/gnome/gthumb/albumthemes/ClassicClips/thumbnail.gthtml
share/gnome/gthumb/albumthemes/ClassicClips/top.png
-share/gnome/gthumb/albumthemes/Clean/1.gif
-share/gnome/gthumb/albumthemes/Clean/back.png
-share/gnome/gthumb/albumthemes/Clean/background.gif
-share/gnome/gthumb/albumthemes/Clean/bot.png
-share/gnome/gthumb/albumthemes/Clean/image.gthtml
-share/gnome/gthumb/albumthemes/Clean/index.gthtml
-share/gnome/gthumb/albumthemes/Clean/layout.css
-share/gnome/gthumb/albumthemes/Clean/left.png
-share/gnome/gthumb/albumthemes/Clean/left_arrow.png
-share/gnome/gthumb/albumthemes/Clean/preview.png
-share/gnome/gthumb/albumthemes/Clean/right.png
-share/gnome/gthumb/albumthemes/Clean/right_arrow.png
-share/gnome/gthumb/albumthemes/Clean/style.css
-share/gnome/gthumb/albumthemes/Clean/thumbnail.gthtml
-share/gnome/gthumb/albumthemes/Clean/top.png
-share/gnome/gthumb/albumthemes/Clean/up_arrow.png
+share/gnome/gthumb/albumthemes/Flicker/image.gthtml
+share/gnome/gthumb/albumthemes/Flicker/index.gthtml
+share/gnome/gthumb/albumthemes/Flicker/layout.css
+share/gnome/gthumb/albumthemes/Flicker/preview.png
+share/gnome/gthumb/albumthemes/Flicker/style.css
+share/gnome/gthumb/albumthemes/Flicker/thumbnail.gthtml
share/gnome/gthumb/albumthemes/NeatRound/1.gif
share/gnome/gthumb/albumthemes/NeatRound/back.png
share/gnome/gthumb/albumthemes/NeatRound/background.gif
@@ -106,21 +80,12 @@ share/gnome/gthumb/albumthemes/NeatRound/right.png
share/gnome/gthumb/albumthemes/NeatRound/style.css
share/gnome/gthumb/albumthemes/NeatRound/thumbnail.gthtml
share/gnome/gthumb/albumthemes/NeatRound/top.png
-share/gnome/gthumb/albumthemes/NeatSquare/1.gif
-share/gnome/gthumb/albumthemes/NeatSquare/back.png
-share/gnome/gthumb/albumthemes/NeatSquare/background.gif
-share/gnome/gthumb/albumthemes/NeatSquare/bot.png
-share/gnome/gthumb/albumthemes/NeatSquare/image.gthtml
-share/gnome/gthumb/albumthemes/NeatSquare/index.gthtml
-share/gnome/gthumb/albumthemes/NeatSquare/layout.css
-share/gnome/gthumb/albumthemes/NeatSquare/left.png
-share/gnome/gthumb/albumthemes/NeatSquare/next.png
-share/gnome/gthumb/albumthemes/NeatSquare/prev.png
-share/gnome/gthumb/albumthemes/NeatSquare/preview.png
-share/gnome/gthumb/albumthemes/NeatSquare/right.png
-share/gnome/gthumb/albumthemes/NeatSquare/style.css
-share/gnome/gthumb/albumthemes/NeatSquare/thumbnail.gthtml
-share/gnome/gthumb/albumthemes/NeatSquare/top.png
+share/gnome/gthumb/albumthemes/Wiki/image.gthtml
+share/gnome/gthumb/albumthemes/Wiki/index.gthtml
+share/gnome/gthumb/albumthemes/Wiki/layout.css
+share/gnome/gthumb/albumthemes/Wiki/preview.png
+share/gnome/gthumb/albumthemes/Wiki/style.css
+share/gnome/gthumb/albumthemes/Wiki/thumbnail.gthtml
share/gnome/gthumb/glade/ftp-client-48.png
share/gnome/gthumb/glade/gphoto-48.png
share/gnome/gthumb/glade/gthumb.glade
@@ -150,9 +115,9 @@ share/gnome/help/gthumb/C/figures/preferences.png
share/gnome/help/gthumb/C/gthumb.xml
share/gnome/help/gthumb/C/legal.xml
share/gnome/omf/gthumb/gthumb-C.omf
-share/gnome/pixmaps/gthumb.png
-share/gnome/pixmaps/gthumb-logo.png
+share/icons/hicolor/48x48/apps/gthumb.png
share/locale/am/LC_MESSAGES/gthumb.mo
+share/locale/ar/LC_MESSAGES/gthumb.mo
share/locale/az/LC_MESSAGES/gthumb.mo
share/locale/be/LC_MESSAGES/gthumb.mo
share/locale/bg/LC_MESSAGES/gthumb.mo
@@ -160,14 +125,17 @@ share/locale/ca/LC_MESSAGES/gthumb.mo
share/locale/cs/LC_MESSAGES/gthumb.mo
share/locale/da/LC_MESSAGES/gthumb.mo
share/locale/de/LC_MESSAGES/gthumb.mo
+share/locale/dz/LC_MESSAGES/gthumb.mo
share/locale/el/LC_MESSAGES/gthumb.mo
share/locale/en_CA/LC_MESSAGES/gthumb.mo
share/locale/en_GB/LC_MESSAGES/gthumb.mo
share/locale/es/LC_MESSAGES/gthumb.mo
+share/locale/et/LC_MESSAGES/gthumb.mo
share/locale/eu/LC_MESSAGES/gthumb.mo
share/locale/fi/LC_MESSAGES/gthumb.mo
share/locale/fr/LC_MESSAGES/gthumb.mo
share/locale/ga/LC_MESSAGES/gthumb.mo
+share/locale/gl/LC_MESSAGES/gthumb.mo
share/locale/gu/LC_MESSAGES/gthumb.mo
share/locale/hi/LC_MESSAGES/gthumb.mo
share/locale/hr/LC_MESSAGES/gthumb.mo
@@ -182,9 +150,9 @@ share/locale/mk/LC_MESSAGES/gthumb.mo
share/locale/ml/LC_MESSAGES/gthumb.mo
share/locale/ms/LC_MESSAGES/gthumb.mo
share/locale/nb/LC_MESSAGES/gthumb.mo
+share/locale/ne/LC_MESSAGES/gthumb.mo
share/locale/nl/LC_MESSAGES/gthumb.mo
share/locale/nn/LC_MESSAGES/gthumb.mo
-share/locale/no/LC_MESSAGES/gthumb.mo
share/locale/pa/LC_MESSAGES/gthumb.mo
share/locale/pl/LC_MESSAGES/gthumb.mo
share/locale/pt/LC_MESSAGES/gthumb.mo
@@ -196,10 +164,13 @@ share/locale/sq/LC_MESSAGES/gthumb.mo
share/locale/sr/LC_MESSAGES/gthumb.mo
share/locale/sr@Latn/LC_MESSAGES/gthumb.mo
share/locale/sv/LC_MESSAGES/gthumb.mo
+share/locale/th/LC_MESSAGES/gthumb.mo
share/locale/tr/LC_MESSAGES/gthumb.mo
+share/locale/vi/LC_MESSAGES/gthumb.mo
share/locale/uk/LC_MESSAGES/gthumb.mo
share/locale/xh/LC_MESSAGES/gthumb.mo
share/locale/zh_CN/LC_MESSAGES/gthumb.mo
+share/locale/zh_HK/LC_MESSAGES/gthumb.mo
share/locale/zh_TW/LC_MESSAGES/gthumb.mo
@dirrm share/gnome/omf/gthumb
@dirrm share/gnome/help/gthumb/C/figures
@@ -207,12 +178,11 @@ share/locale/zh_TW/LC_MESSAGES/gthumb.mo
@dirrm share/gnome/help/gthumb
@dirrm share/gnome/gthumb/icons
@dirrm share/gnome/gthumb/glade
-@dirrm share/gnome/gthumb/albumthemes/NeatSquare
+@dirrm share/gnome/gthumb/albumthemes/Wiki
@dirrm share/gnome/gthumb/albumthemes/NeatRound
-@dirrm share/gnome/gthumb/albumthemes/Clean
+@dirrm share/gnome/gthumb/albumthemes/Flicker
@dirrm share/gnome/gthumb/albumthemes/ClassicClips
@dirrm share/gnome/gthumb/albumthemes/Classic
-@dirrm share/gnome/gthumb/albumthemes/BlueStripes
@dirrm share/gnome/gthumb/albumthemes
@dirrm share/gnome/gthumb
@dirrm lib/gthumb/modules