aboutsummaryrefslogtreecommitdiff
path: root/graphics/gthumb
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-08 21:38:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-08 21:38:36 +0000
commit15cda68c3556a578f56fc0ad8ff72fc0d2318693 (patch)
tree369219f2c4a55f117606ef558c5ebce96e685471 /graphics/gthumb
parent2d36cee9cd2b04d3b992ea193599556a6ad9ca17 (diff)
downloadports-15cda68c3556a578f56fc0ad8ff72fc0d2318693.tar.gz
ports-15cda68c3556a578f56fc0ad8ff72fc0d2318693.zip
graphics/gthumb: prepare for exiv2-0.27
Notes
Notes: svn path=/head/; revision=495077
Diffstat (limited to 'graphics/gthumb')
-rw-r--r--graphics/gthumb/Makefile2
-rw-r--r--graphics/gthumb/files/patch-gentoo_2bd8b934
2 files changed, 35 insertions, 1 deletions
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index cff09c9013a4..1720a1b8bb53 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gthumb
PORTVERSION= 3.6.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/graphics/gthumb/files/patch-gentoo_2bd8b9 b/graphics/gthumb/files/patch-gentoo_2bd8b9
new file mode 100644
index 000000000000..29685bd88b3c
--- /dev/null
+++ b/graphics/gthumb/files/patch-gentoo_2bd8b9
@@ -0,0 +1,34 @@
+Patch kindly borrowed from Mageia.
+
+* asturm@gentoo.org: Dropped unnecessary and backwards incompatible
+xmp_exiv2.hpp include.
+
+https://gitlab.gnome.org/GNOME/gthumb/issues/30
+
+diff -Nru a/extensions/exiv2_tools/exiv2-utils.cpp b/extensions/exiv2_tools/exiv2-utils.cpp
+--- extensions/exiv2_tools/exiv2-utils.cpp 2018-06-17 08:24:44.000000000 +0200
++++ extensions/exiv2_tools/exiv2-utils.cpp 2018-12-31 15:51:50.912329232 +0100
+@@ -32,7 +32,7 @@
+ #include <sstream>
+ #include <vector>
+ #include <iomanip>
+-#include <exiv2/xmp.hpp>
++#include <exiv2/exiv2.hpp>
+ #include <gthumb.h>
+ #include "exiv2-utils.h"
+
+@@ -1073,7 +1073,11 @@
+
+ try {
+ if (exifData.empty()) {
++#if EXIV2_TEST_VERSION(0,27,0)
++ throw Exiv2::Error(Exiv2::kerErrorMessage, " No Exif data found in the file");
++#else
+ throw Exiv2::Error(1, " No Exif data found in the file");
++#endif
+ }
+ Exiv2::ExifData::const_iterator end = exifData.end();
+ for (Exiv2::ExifData::const_iterator i = exifData.begin(); i != end; ++i) {
+
+
+