aboutsummaryrefslogtreecommitdiff
path: root/graphics/gtkam
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-11-18 03:00:04 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-11-18 03:00:04 +0000
commitd24d9d7c7bc44d969c9be15840dd6db0e8995e2d (patch)
treed0494b2994d1fe407891480b99aa7a29cf1c87ac /graphics/gtkam
parentba046b2af51730fe34f1118acc9a1943999f0c16 (diff)
downloadports-d24d9d7c7bc44d969c9be15840dd6db0e8995e2d.tar.gz
ports-d24d9d7c7bc44d969c9be15840dd6db0e8995e2d.zip
Notes
Diffstat (limited to 'graphics/gtkam')
-rw-r--r--graphics/gtkam/Makefile59
-rw-r--r--graphics/gtkam/distinfo1
-rw-r--r--graphics/gtkam/pkg-comment1
-rw-r--r--graphics/gtkam/pkg-descr8
-rw-r--r--graphics/gtkam/pkg-plist34
5 files changed, 103 insertions, 0 deletions
diff --git a/graphics/gtkam/Makefile b/graphics/gtkam/Makefile
new file mode 100644
index 000000000000..8ef56a556e62
--- /dev/null
+++ b/graphics/gtkam/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: gtkam
+# Date created: 10 June 2002
+# Whom: KATO Tsuguru <tkato@prontomail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkam
+PORTVERSION= 0.1.9
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gphoto
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= exif-gtk.4:${PORTSDIR}/graphics/libexif-gtk \
+ gphoto2.2:${PORTSDIR}/graphics/gphoto2
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 gdkpixbuf
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if defined(WITH_GIMP)
+LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp1
+PLIST_SUB+= GIMP=""
+.else
+CONFIGURE_ARGS= --without-gimp
+PLIST_SUB+= GIMP="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITH_GIMP)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with plugin for The GIMP,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_GIMP=yes\""
+ @${ECHO_MSG}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-g -Wall||g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's| install-gtkamdocDATA||g ; \
+ s|images/gtkam|gtkam/images|g'
+ @${REINPLACE_CMD} -e "s|^test_fsel_LDFLAGS =.*|test_fsel_LDFLAGS = \$$(EXIF_LIBS)|" ${WRKSRC}/test/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/MANUAL ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gtkam/distinfo b/graphics/gtkam/distinfo
new file mode 100644
index 000000000000..227779740e86
--- /dev/null
+++ b/graphics/gtkam/distinfo
@@ -0,0 +1 @@
+MD5 (gtkam-0.1.9.tar.bz2) = c39d1dae18a4a3ab5018e83bc238c7e6
diff --git a/graphics/gtkam/pkg-comment b/graphics/gtkam/pkg-comment
new file mode 100644
index 000000000000..31fb9cf93344
--- /dev/null
+++ b/graphics/gtkam/pkg-comment
@@ -0,0 +1 @@
+Download and view files from various digital cameras
diff --git a/graphics/gtkam/pkg-descr b/graphics/gtkam/pkg-descr
new file mode 100644
index 000000000000..8aa470ec40aa
--- /dev/null
+++ b/graphics/gtkam/pkg-descr
@@ -0,0 +1,8 @@
+gtkam is an universal, free GTK+ application that will allow
+downloading, saving, and manipulation of images from several
+different digital camera models, or from the local harddrive.
+
+gtkam supports a wide array of digital camera models.
+Visit http://www.gphoto.org/cameras.html for an updated list.
+
+WWW: http://www.gphoto.org/gphoto2/
diff --git a/graphics/gtkam/pkg-plist b/graphics/gtkam/pkg-plist
new file mode 100644
index 000000000000..fa04bf5dabd9
--- /dev/null
+++ b/graphics/gtkam/pkg-plist
@@ -0,0 +1,34 @@
+bin/gtkam
+%%GIMP%%libexec/gimp/1.2/plug-ins/gtkam-gimp
+%%PORTDOCS%%share/doc/gtkam/AUTHORS
+%%PORTDOCS%%share/doc/gtkam/MANUAL
+share/gtkam/images/gtkam-audio.png
+share/gtkam/images/gtkam-camera.png
+share/gtkam/images/gtkam-folder-camera.png
+share/gtkam/images/gtkam-folder.png
+share/gtkam/images/gtkam-lock.png
+share/gtkam/images/gtkam-new.png
+share/gtkam/pixmaps/camera.xpm
+share/gtkam/pixmaps/configure.xpm
+share/gtkam/pixmaps/delete_images.xpm
+share/gtkam/pixmaps/exit.xpm
+share/gtkam/pixmaps/folder.xpm
+share/gtkam/pixmaps/save_current_image.xpm
+share/locale/da/LC_MESSAGES/gtkam.mo
+share/locale/de/LC_MESSAGES/gtkam.mo
+share/locale/es/LC_MESSAGES/gtkam.mo
+share/locale/fr/LC_MESSAGES/gtkam.mo
+share/locale/hu/LC_MESSAGES/gtkam.mo
+share/locale/it/LC_MESSAGES/gtkam.mo
+share/locale/ja/LC_MESSAGES/gtkam.mo
+share/locale/no/LC_MESSAGES/gtkam.mo
+share/locale/pt_BR/LC_MESSAGES/gtkam.mo
+share/locale/pt_PT/LC_MESSAGES/gtkam.mo
+share/locale/ru/LC_MESSAGES/gtkam.mo
+share/locale/sl/LC_MESSAGES/gtkam.mo
+share/locale/sv/LC_MESSAGES/gtkam.mo
+share/locale/uk/LC_MESSAGES/gtkam.mo
+@dirrm share/gtkam/pixmaps
+@dirrm share/gtkam/images
+@dirrm share/gtkam
+%%PORTDOCS%%@dirrm share/doc/gtkam