aboutsummaryrefslogtreecommitdiff
path: root/graphics/gtkgraph/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-14 03:44:12 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-14 03:44:12 +0000
commit5354f8b966d39c172f3055531426e9a0f12d15c7 (patch)
treec71500e9c0383d2d00a7d76d7dba851b43718303 /graphics/gtkgraph/Makefile
parent2432e1ee7f6cc79fdb5ee572adb05ff83b788885 (diff)
downloadports-5354f8b966d39c172f3055531426e9a0f12d15c7.tar.gz
ports-5354f8b966d39c172f3055531426e9a0f12d15c7.zip
Notes
Diffstat (limited to 'graphics/gtkgraph/Makefile')
-rw-r--r--graphics/gtkgraph/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/gtkgraph/Makefile b/graphics/gtkgraph/Makefile
new file mode 100644
index 000000000000..ff59aa5565e5
--- /dev/null
+++ b/graphics/gtkgraph/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gtkgraph
+# Version required: 0.5.0
+# Date created: 12 October 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= gtkgraph-0.5.0
+CATEGORIES= math
+MASTER_SITES= http://gtkgraph.linuxbox.com/
+
+MAINTAINER= jedgar@fxp.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ intl.1:${PORTSDIR}/devel/gettext \
+ gdk_imlib.5:${PORTSDIR}/graphics/imlib
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-x
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>