aboutsummaryrefslogtreecommitdiff
path: root/graphics/gtksee/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:59:49 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:59:49 +0000
commit476b3f623d0f113d59ba3ae986007206477b40ef (patch)
treeec274a5cf3b6396f7bdaaee95024bbc4e99a43f2 /graphics/gtksee/Makefile
parentd6c28f5cebd223cbf925a0cd383fc4873e11fdb6 (diff)
downloadports-476b3f623d0f113d59ba3ae986007206477b40ef.tar.gz
ports-476b3f623d0f113d59ba3ae986007206477b40ef.zip
Notes
Diffstat (limited to 'graphics/gtksee/Makefile')
-rw-r--r--graphics/gtksee/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/graphics/gtksee/Makefile b/graphics/gtksee/Makefile
index 320bd0ce9cff..793287801fa7 100644
--- a/graphics/gtksee/Makefile
+++ b/graphics/gtksee/Makefile
@@ -6,17 +6,14 @@
#
PORTNAME= gtksee
-PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTVERSION= 0.5.2
CATEGORIES= graphics
-MASTER_SITES= http://www.linux.tucows.com/files/x11/graphics/ \
- http://www.physik.TU-Berlin.DE/~ibex/ports/distfiles/
+MASTER_SITES= http://download.berlios.de/gtksee/
-MAINTAINER= dirk@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Image viewer
-LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= bzip:${PORTSDIR}/archivers/bzip
@@ -24,9 +21,14 @@ RUN_DEPENDS= bzip:${PORTSDIR}/archivers/bzip
RUN_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
.endif
-USE_GNOME= gtk12
+USE_GNOME= gtk12 gnometarget
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CFLAGS=""|CFLAGS="$$CFLAGS"|g' ${WRKSRC}/configure
.include <bsd.port.mk>