aboutsummaryrefslogtreecommitdiff
path: root/graphics/gts/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-30 13:06:59 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-30 13:06:59 +0000
commitaef4c9e7c1cb324c4fe7bdc3da70e578e3c78990 (patch)
tree417b965c55ca08f6d5085461f28715592e8b927b /graphics/gts/Makefile
parentcafa20fd3c11a143e3269305eb94f1bdd1cdebc8 (diff)
Notes
Diffstat (limited to 'graphics/gts/Makefile')
-rw-r--r--graphics/gts/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index a6cd1002b1bd..fe13deba88e8 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gts
-PORTVERSION= 0.7.3
-PORTREVISION= 2
+PORTVERSION= 0.7.4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,17 +16,34 @@ MAINTAINER= erik@smluc.org
COMMENT= GNU Triangulated Surface Library
USE_GNOME= glib20 gnometarget pkgconfig
-USE_GETOPT_LONG= yes
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
+OPTIONS= NETPBM "Build with libnetpbm support" off
+
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NETPBM)
+LIB_DEPENDS+= netpbm.1:${PORTSDIR}/graphics/netpbm
+PLIST_SUB= NETPBM=""
+.else
+PLIST_SUB= NETPBM="@comment "
+.endif
+
+post-extract:
+.if !defined(WITH_NETPBM)
+ @${REINPLACE_CMD} -e 's|netpbm="true"|netpbm="false"|' \
+ ${WRKSRC}/configure
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-release \$$(LT_RELEASE)||g ; s|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>