aboutsummaryrefslogtreecommitdiff
path: root/graphics/hgl
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-09-04 18:39:09 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-09-04 18:39:09 +0000
commite8cd55cc7d4d597772395188a1bdf5f4cf00d93c (patch)
treebd0a795fe4755b1baebc7f362da20b689d535677 /graphics/hgl
parenta8b9ee2372cdb4479b7b219b505278450ea62768 (diff)
downloadports-e8cd55cc7d4d597772395188a1bdf5f4cf00d93c.tar.gz
ports-e8cd55cc7d4d597772395188a1bdf5f4cf00d93c.zip
Notes
Diffstat (limited to 'graphics/hgl')
-rw-r--r--graphics/hgl/Makefile45
-rw-r--r--graphics/hgl/distinfo1
-rw-r--r--graphics/hgl/files/patch-aa41
-rw-r--r--graphics/hgl/pkg-comment1
-rw-r--r--graphics/hgl/pkg-descr15
-rw-r--r--graphics/hgl/pkg-plist39
-rw-r--r--graphics/hgl/scripts/hugs-hgl3
7 files changed, 0 insertions, 145 deletions
diff --git a/graphics/hgl/Makefile b/graphics/hgl/Makefile
deleted file mode 100644
index 87505292ff00..000000000000
--- a/graphics/hgl/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# New ports collection makefile for: hgl
-# Date created: 22 January 2002
-# Whom: octaphial
-#
-# $FreeBSD$
-#
-
-PORTNAME= hgl
-PORTVERSION= 2.0.4
-CATEGORIES= graphics
-MASTER_SITES= http://haskell.org/graphics/downloads/
-DISTNAME= graphics-${PORTVERSION}.src
-
-MAINTAINER= octaphial@yahoo.com
-
-RUN_DEPENDS= hugs:${PORTSDIR}/lang/hugs
-
-WRKSRC= ${WRKDIR}/graphics-${PORTVERSION}
-USE_GMAKE= yes
-USE_XLIB= yes
-
-BUILD_WRKSRC= ${WRKSRC}/lib/x11
-MAKE_ENV= system=FreeBSD \
- hugs_install=${PREFIX}/share/hugs
-ALL_TARGET= all
-
-do-install:
- ${MKDIR} ${PREFIX}/share/hugs/lib/x11
- ${MKDIR} ${PREFIX}/share/hugs/demos/hgl
- ${INSTALL_SCRIPT} ${PKGDIR}/scripts/hugs-hgl ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/lib/x11/*.hs ${PREFIX}/share/hugs/lib/x11
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/x11/*.o ${PREFIX}/share/hugs/lib/x11
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/x11/*.so ${PREFIX}/share/hugs/lib/x11
- ${INSTALL_DATA} ${WRKSRC}/demos/* ${PREFIX}/share/hugs/demos/hgl
- ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/hugs/demos/hgl
-
-post-install:
- ${MKDIR} ${PREFIX}/share/doc/hgl
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/hgl
- ${INSTALL_DATA} ${WRKSRC}/License ${PREFIX}/share/doc/hgl
- ${INSTALL_DATA} ${WRKSRC}/Readme ${PREFIX}/share/doc/hgl
- ${INSTALL_DATA} ${WRKSRC}/Version ${PREFIX}/share/doc/hgl
- ${INSTALL_DATA} ${WRKSRC}/Version-2.0.4 ${PREFIX}/share/doc/hgl
-
-.include <bsd.port.mk>
diff --git a/graphics/hgl/distinfo b/graphics/hgl/distinfo
deleted file mode 100644
index 88ccc64b766d..000000000000
--- a/graphics/hgl/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (graphics-2.0.4.src.tar.gz) = 60da7bc8f3a2414778fe1e693ba54ab4
diff --git a/graphics/hgl/files/patch-aa b/graphics/hgl/files/patch-aa
deleted file mode 100644
index 15413dfb577c..000000000000
--- a/graphics/hgl/files/patch-aa
+++ /dev/null
@@ -1,41 +0,0 @@
---- lib/x11/X.c.orig Wed Sep 5 16:26:18 2001
-+++ lib/x11/X.c Tue Jan 22 11:18:50 2002
-@@ -5526,8 +5526,8 @@
- #ifdef __cplusplus
- extern "C" {
- #endif
--DLLEXPORT(void) initModule(HugsAPI3 *);
--DLLEXPORT(void) initModule(HugsAPI3 *hugsAPI) {
-+DLLEXPORT(void) _initModule(HugsAPI3 *);
-+DLLEXPORT(void) _initModule(HugsAPI3 *hugsAPI) {
- hugs = hugsAPI;
- hugs->registerPrims(&prims);
- }
-diff -Naur graphics-2.0.4.orig/lib/x11/Xlib.c graphics-2.0.4/lib/x11/Xlib.c
---- lib/x11/Xlib.c.orig Wed Sep 5 16:26:18 2001
-+++ lib/x11/Xlib.c Tue Jan 22 11:19:05 2002
-@@ -4349,8 +4349,8 @@
- #ifdef __cplusplus
- extern "C" {
- #endif
--DLLEXPORT(void) initModule(HugsAPI3 *);
--DLLEXPORT(void) initModule(HugsAPI3 *hugsAPI) {
-+DLLEXPORT(void) _initModule(HugsAPI3 *);
-+DLLEXPORT(void) _initModule(HugsAPI3 *hugsAPI) {
- hugs = hugsAPI;
- hugs->registerPrims(&prims);
- }
-diff -Naur graphics-2.0.4.orig/lib/x11/Xlib_StdDIS.c graphics-2.0.4/lib/x11/Xlib_StdDIS.c
---- lib/x11/Xlib_StdDIS.c.orig Wed Sep 5 16:26:18 2001
-+++ lib/x11/Xlib_StdDIS.c Tue Jan 22 11:17:48 2002
-@@ -65,8 +65,8 @@
- #ifdef __cplusplus
- extern "C" {
- #endif
--DLLEXPORT(void) initModule(HugsAPI3 *);
--DLLEXPORT(void) initModule(HugsAPI3 *hugsAPI) {
-+DLLEXPORT(void) _initModule(HugsAPI3 *);
-+DLLEXPORT(void) _initModule(HugsAPI3 *hugsAPI) {
- hugs = hugsAPI;
- hugs->registerPrims(&prims);
- }
diff --git a/graphics/hgl/pkg-comment b/graphics/hgl/pkg-comment
deleted file mode 100644
index 5d12a09ca598..000000000000
--- a/graphics/hgl/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Graphics library for Hugs98, an implementation of Haskell 98
diff --git a/graphics/hgl/pkg-descr b/graphics/hgl/pkg-descr
deleted file mode 100644
index 6116627eafb5..000000000000
--- a/graphics/hgl/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-From homepage of HGL:
-
-The HGL gives the programmer access to the most interesting parts of
-the Win32 and X11 library without exposing the programmer to the pain
-and anguish usually associated with using these interfaces. The library
-library is distributed as open source and is suitable for use in
-teaching and in applications.
-
-...
-
-WWW: http://haskell.org/graphics/
-
-
- - Byunghyun Oh
- octaphial@yahoo.com
diff --git a/graphics/hgl/pkg-plist b/graphics/hgl/pkg-plist
deleted file mode 100644
index bf24fc9d51c2..000000000000
--- a/graphics/hgl/pkg-plist
+++ /dev/null
@@ -1,39 +0,0 @@
-bin/hugs-hgl
-share/doc/hgl/License
-share/doc/hgl/Readme
-share/doc/hgl/Version
-share/doc/hgl/Version-2.0.4
-share/doc/hgl/Graphics.dvi
-share/doc/hgl/Graphics.tex
-share/doc/hgl/appendix.tex
-share/doc/hgl/graphics.bib
-share/doc/hgl/oldappendix.tex
-share/hugs/demos/hgl/HelloWorld.hs
-share/hugs/demos/hgl/GTest.hs
-share/hugs/demos/hgl/Tests.hs
-share/hugs/lib/x11/GraphicsCore.hs
-share/hugs/lib/x11/GraphicsDC.hs
-share/hugs/lib/x11/GraphicsEvent.hs
-share/hugs/lib/x11/GraphicsEvents.hs
-share/hugs/lib/x11/GraphicsFlag.hs
-share/hugs/lib/x11/GraphicsFont.hs
-share/hugs/lib/x11/GraphicsKey.hs
-share/hugs/lib/x11/GraphicsPicture.hs
-share/hugs/lib/x11/GraphicsRegion.hs
-share/hugs/lib/x11/GraphicsTimer.hs
-share/hugs/lib/x11/GraphicsUtils.hs
-share/hugs/lib/x11/GraphicsWindow.hs
-share/hugs/lib/x11/GraphicsWindows.hs
-share/hugs/lib/x11/Graphics_Utilities.hs
-share/hugs/lib/x11/SOEGraphics.hs
-share/hugs/lib/x11/X.hs
-share/hugs/lib/x11/X.o
-share/hugs/lib/x11/X.so
-share/hugs/lib/x11/Xlib.hs
-share/hugs/lib/x11/Xlib.o
-share/hugs/lib/x11/Xlib.so
-share/hugs/lib/x11/Xlib_StdDIS.hs
-share/hugs/lib/x11/Xlib_StdDIS.so
-@dirrm share/doc/hgl
-@dirrm share/hugs/demos/hgl
-@dirrm share/hugs/lib/x11
diff --git a/graphics/hgl/scripts/hugs-hgl b/graphics/hgl/scripts/hugs-hgl
deleted file mode 100644
index 37ca106a7798..000000000000
--- a/graphics/hgl/scripts/hugs-hgl
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-hugs -P{Hugs}/lib/x11: $@