aboutsummaryrefslogtreecommitdiff
path: root/graphics/hpoj
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-21 06:11:33 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-21 06:11:33 +0000
commitd3e4b37dfcdb63a77e4df90f699193763531addd (patch)
treec37dbbe60709ed9fe85ffdfdfb6d17392ea8a560 /graphics/hpoj
parent29ad97f6d14b82579abbe50e409e4ee3fc9980f8 (diff)
Notes
Diffstat (limited to 'graphics/hpoj')
-rw-r--r--graphics/hpoj/Makefile7
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-Makefile.in14
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp12
-rw-r--r--graphics/hpoj/files/patch-Makefile.in28
4 files changed, 38 insertions, 23 deletions
diff --git a/graphics/hpoj/Makefile b/graphics/hpoj/Makefile
index 533b5af04555..6e960c7598b1 100644
--- a/graphics/hpoj/Makefile
+++ b/graphics/hpoj/Makefile
@@ -55,14 +55,17 @@ BROKEN= "ffs() clash, see i386/41930"
.if ${ARCH} == "alpha"
EXTRA_PATCHES= ${FILESDIR}/extra-patch-mlcd-Makefile.in \
- ${FILESDIR}/extra-patch-mlcd-ParPort.cpp \
${FILESDIR}/extra-patch-mlcd-ParPort.h
.endif
GNU_CONFIGURE= yes
# Necessary hacks to find libsnmp:
+.if ${OSVERSION} < 510000
+EXTRALDFLAGS= -lcipher
+.endif
CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib ${PTHREAD_CFLAGS}"
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -lcipher -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} ${EXTRALDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --with-snmp=${LOCALBASE}/include/ucd-snmp
.ifdef(WITHOUT_X11)
CONFIGURE_ARGS+= --without-qt
diff --git a/graphics/hpoj/files/extra-patch-mlcd-Makefile.in b/graphics/hpoj/files/extra-patch-mlcd-Makefile.in
index 76a6fdaa14f2..8a8832a72373 100644
--- a/graphics/hpoj/files/extra-patch-mlcd-Makefile.in
+++ b/graphics/hpoj/files/extra-patch-mlcd-Makefile.in
@@ -1,11 +1,11 @@
---- mlcd/Makefile.in.orig Sat May 24 08:03:14 2003
-+++ mlcd/Makefile.in Sat May 24 08:03:37 2003
-@@ -35,7 +35,7 @@
- for link in $(LINKS) ; do ln -s . $$link ; done
+--- mlcd/Makefile.in.orig Sat Dec 20 19:36:00 2003
++++ mlcd/Makefile.in Sat Dec 20 19:36:10 2003
+@@ -31,7 +31,7 @@
+ all: $(GOAL)
$(GOAL): $(OBJS)
-- $(CXX) -o $(GOAL) $(OBJS)
-+ $(CXX) -o $(GOAL) -lio $(OBJS)
+- $(CXX) $(LFLAGS) -o $(GOAL) $(OBJS)
++ $(CXX) $(LFLAGS) -lio -o $(GOAL) $(OBJS)
clean:
- rm -f $(OBJS) $(GOAL) $(LINKS)
+ rm -f $(OBJS) $(GOAL)
diff --git a/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp b/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
deleted file mode 100644
index 4d62bc3f52a9..000000000000
--- a/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- mlcd/ParPort.cpp.orig Sat May 24 08:03:20 2003
-+++ mlcd/ParPort.cpp Sat May 24 08:03:48 2003
-@@ -926,9 +926,6 @@
- #elif defined(PAR_PLATFORM_FREEBSD)
- #include <unistd.h>
- #include <fcntl.h>
-- extern "C" {
-- #include <machine/cpufunc.h>
-- }
- #else
- /* TODO: Handle these more gracefully! */
- #error Undefined platform
diff --git a/graphics/hpoj/files/patch-Makefile.in b/graphics/hpoj/files/patch-Makefile.in
index ebfb810275f0..6ce82feff40d 100644
--- a/graphics/hpoj/files/patch-Makefile.in
+++ b/graphics/hpoj/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Fri Jul 26 14:05:04 2002
-+++ Makefile.in Mon May 19 12:12:29 2003
+--- Makefile.in.orig Tue Sep 23 03:16:41 2003
++++ Makefile.in Sat Dec 20 21:21:36 2003
@@ -5,6 +5,9 @@
SUBDIRS=@SUBDIRS@
DISTCLEANS=Makefile config.cache config.log config.status scripts/ptal-init
@@ -31,3 +31,27 @@
fi ; \
done ; \
cd .. ; \
+@@ -164,11 +167,6 @@
+ fi ; \
+ fi ; \
+ echo ; \
+- if ! grep $(libdir) /etc/ld.so.conf >/dev/null 2>/dev/null ; then \
+- echo "Adding $(libdir) to /etc/ld.so.conf." ; \
+- echo $(libdir) >>/etc/ld.so.conf ; \
+- fi ; \
+- ldconfig ; \
+ else \
+ if ! test -d /etc/profile.d || ! test -f /etc/profile.d/hpoj.sh || ! test -f /etc/profile.d/hpoj.csh ; then \
+ echo "You may need to add $(bindir) and $(sbindir) to your PATH." ; \
+@@ -193,11 +191,6 @@
+ fi ; \
+ fi
+ @ echo
+- @ for file in /bin/bash /usr/bin/perl ; do \
+- if ! test -x $$file ; then \
+- echo "As root, please install and/or create a symlink to \"$$file\"." ; \
+- fi ; \
+- done
+ @ echo
+ @ for file in bin/hpo bin/ieee12844_print bin/ptal-printd bin/addpjl lib/ieee12844.o lib/ieee12844pp.o etc/ptal-start.conf etc/ptal-start.conf.new etc/ptal-stop.conf etc/ptal-stop.conf.new share/pixmaps/hpoj doc/hpoj ; do \
+ if test -f $(prefix)/$$file ; then \