aboutsummaryrefslogtreecommitdiff
path: root/graphics/hs-HGL
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
committerGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
commit39b8e49140afdb1d1d001c477befb4b05efa7fc3 (patch)
tree607a5ca77efd301a2b4dc49b05d108829fcffa77 /graphics/hs-HGL
parent75b64b1cb42c127b71646f039269eb7bd560d8ef (diff)
downloadports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.tar.gz
ports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.zip
Notes
Diffstat (limited to 'graphics/hs-HGL')
-rw-r--r--graphics/hs-HGL/Makefile2
-rw-r--r--graphics/hs-HGL/files/patch-Graphics_HGL_Internals_Draw.hs22
2 files changed, 23 insertions, 1 deletions
diff --git a/graphics/hs-HGL/Makefile b/graphics/hs-HGL/Makefile
index 12ab90afed63..f1132bdbbcbb 100644
--- a/graphics/hs-HGL/Makefile
+++ b/graphics/hs-HGL/Makefile
@@ -3,7 +3,7 @@
PORTNAME= HGL
PORTVERSION= 3.2.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/graphics/hs-HGL/files/patch-Graphics_HGL_Internals_Draw.hs b/graphics/hs-HGL/files/patch-Graphics_HGL_Internals_Draw.hs
new file mode 100644
index 000000000000..c4910277f2bc
--- /dev/null
+++ b/graphics/hs-HGL/files/patch-Graphics_HGL_Internals_Draw.hs
@@ -0,0 +1,22 @@
+--- Graphics/HGL/Internals/Draw.hs.orig 1991-05-09 14:40:52 UTC
++++ Graphics/HGL/Internals/Draw.hs
+@@ -31,7 +31,7 @@ import Graphics.HGL.X11.Types(DC)
+ import Graphics.HGL.Win32.Types(DC)
+ #endif
+ import qualified Graphics.HGL.Internals.Utilities as Utils (bracket, bracket_)
+-import Control.Monad (liftM)
++import Control.Monad (liftM, ap)
+
+ ----------------------------------------------------------------
+ -- Graphics
+@@ -61,6 +61,10 @@ instance Monad Draw where
+
+ instance Functor Draw where fmap = liftM
+
++instance Applicative Draw where
++ pure = return
++ (<*>) = ap
++
+ -- | Wrap a drawing action in initialization and finalization actions.
+ bracket
+ :: Draw a -- ^ a pre-operation, whose value is passed to the