aboutsummaryrefslogtreecommitdiff
path: root/graphics/hs-HGL
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
commit7d5781e5ab3aa2c4d9f46985acec697caae1c173 (patch)
treefb0e55efa60858746649977ee5813f549bfbad04 /graphics/hs-HGL
parent9acc5ac910695e85c7d24401bfecd5d6e6da0d7f (diff)
downloadports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.tar.gz
ports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.zip
Notes
Diffstat (limited to 'graphics/hs-HGL')
-rw-r--r--graphics/hs-HGL/Makefile18
-rw-r--r--graphics/hs-HGL/files/patch-HGL.cabal11
-rw-r--r--graphics/hs-HGL/pkg-descr29
-rw-r--r--graphics/hs-HGL/pkg-plist1
4 files changed, 32 insertions, 27 deletions
diff --git a/graphics/hs-HGL/Makefile b/graphics/hs-HGL/Makefile
index 53a17ded8688..5d216cb1987a 100644
--- a/graphics/hs-HGL/Makefile
+++ b/graphics/hs-HGL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= HGL
PORTVERSION= 3.2.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -16,10 +16,12 @@ PKGNAMESUFFIX= -ghc
MAINTAINER= jacula@gmail.com
COMMENT= A simple graphics library based on X11 or Win32
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-x11-ghc>=1.2.1:${PORTSDIR}/x11/hs-x11-ghc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-x11-ghc>=1.2.1:${PORTSDIR}/x11/hs-x11-ghc
-GHC_VERSION= 6.8.3
+GHC_VERSION= 6.10.4
HGL_VERSION= ${PORTVERSION}
CABAL_CMD= ${LOCALBASE}/bin/runghc Setup.hs
@@ -38,10 +40,14 @@ PLIST_SUB+= NOPORTDOCS="@comment "
.endif
.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock \
- HsColour:${PORTSDIR}/print/hs-hscolour
-HSCOLOUR_VERSION= 1.12
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.13
HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
PORTDOCS= *
diff --git a/graphics/hs-HGL/files/patch-HGL.cabal b/graphics/hs-HGL/files/patch-HGL.cabal
new file mode 100644
index 000000000000..d4f30644bcc1
--- /dev/null
+++ b/graphics/hs-HGL/files/patch-HGL.cabal
@@ -0,0 +1,11 @@
+--- HGL.cabal.orig 2009-07-14 16:55:20.000000000 +0000
++++ HGL.cabal 2009-07-14 16:56:13.000000000 +0000
+@@ -22,7 +22,7 @@
+
+ library
+ if flag(split-base)
+- build-depends: base >= 3, array
++ build-depends: base < 4, array
+ else
+ build-depends: base < 2
+ exposed-modules:
diff --git a/graphics/hs-HGL/pkg-descr b/graphics/hs-HGL/pkg-descr
index 0364f499e3db..893d95650fd7 100644
--- a/graphics/hs-HGL/pkg-descr
+++ b/graphics/hs-HGL/pkg-descr
@@ -1,23 +1,10 @@
-A simple graphics library, designed to give the programmer access
-to most interesting parts of the Win32 Graphics Device Interface
-and X11 library without exposing the programmer to the pain and
-anguish usually associated with using these interfaces.
-The library also includes a module Graphics.SOE providing the
-interface used in "The Haskell School of Expression", by Paul
-Hudak, cf <http://www.haskell.org/soe/>.
+A simple graphics library, designed to give the programmer access to most
+interesting parts of the Win32 Graphics Device Interface and X11 library
+without exposing the programmer to the pain and anguish usually associated with
+using these interfaces.
-author: Alastair Reid
-maintainer: <libraries@haskell.org>
-license: BSD3
-WWW: http://www.haskell.org/graphics/index.html
-package-url: http://hackage.haskell.org/packages/archive/HGL
+The library also includes a module Graphics.SOE providing the interface used
+in "The Haskell School of Expression", by Paul Hudak,
+cf <http://www.haskell.org/soe/>.
-exposed-modules:
- Graphics.HGL.Core, Graphics.HGL.Draw,
- Graphics.HGL.Units, Graphics.HGL.Key,
- Graphics.HGL.Run, Graphics.HGL.Draw.Brush,
- Graphics.HGL.Draw.Font, Graphics.HGL.Draw.Monad,
- Graphics.HGL.Draw.Pen, Graphics.HGL.Draw.Picture,
- Graphics.HGL.Draw.Region, Graphics.HGL.Draw.Text,
- Graphics.HGL.Utils, Graphics.HGL.Window,
- Graphics.HGL, Graphics.SOE
+WWW: http://www.haskell.org/graphics/index.html
diff --git a/graphics/hs-HGL/pkg-plist b/graphics/hs-HGL/pkg-plist
index 8f82c647e39b..d5a6c8c4c9a3 100644
--- a/graphics/hs-HGL/pkg-plist
+++ b/graphics/hs-HGL/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
%%HGL_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL.hi
%%HGL_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Core.hi
%%HGL_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw.hi