aboutsummaryrefslogtreecommitdiff
path: root/graphics/hs-HOpenGL
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-06-10 19:56:27 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-06-10 19:56:27 +0000
commit64f0cabd72e7bf10d1ddce186956ea241c8d8d1e (patch)
tree86bb555145309f134e4cb6872918fda876aec051 /graphics/hs-HOpenGL
parentbe25956743cc06d6f7a00db8aacebcad634a8d5a (diff)
Notes
Diffstat (limited to 'graphics/hs-HOpenGL')
-rw-r--r--graphics/hs-HOpenGL/Makefile3
-rw-r--r--graphics/hs-HOpenGL/pkg-plist2
2 files changed, 5 insertions, 0 deletions
diff --git a/graphics/hs-HOpenGL/Makefile b/graphics/hs-HOpenGL/Makefile
index fd23562ed6e4..88ce88a268c1 100644
--- a/graphics/hs-HOpenGL/Makefile
+++ b/graphics/hs-HOpenGL/Makefile
@@ -40,6 +40,7 @@ pre-configure:
CONFIGURE_ARGS+=--with-library-dir=${LIB_DIR} --with-import-dir=${IMPORT_DIR} --enable-Mesa
PLIST_SUB= LIB_DIR=${LIB_DIR_REL} IMPORT_DIR=${IMPORT_DIR_REL}
+PLIST_SUB+= GHC_VERSION="${GHC_VERSION}"
ALL_TARGET= depend all
@@ -93,4 +94,6 @@ post-install:
${INSTALL_DATA} ${GFXSRC}/UI/GLUT/*.hi ${GFXDIR}/UI/GLUT
${INSTALL_DATA} ${GFXSRC}/UI/GLUT/Callbacks/*.hi ${GFXDIR}/UI/GLUT/Callbacks
+ @${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
.include <bsd.port.mk>
diff --git a/graphics/hs-HOpenGL/pkg-plist b/graphics/hs-HOpenGL/pkg-plist
index 54354561a60d..12b1ae1935b9 100644
--- a/graphics/hs-HOpenGL/pkg-plist
+++ b/graphics/hs-HOpenGL/pkg-plist
@@ -374,4 +374,6 @@ share/examples/HOpenGL/redbook_HS/Wrap.hs
share/examples/HOpenGL/00Contents
@dirrm share/examples/HOpenGL
@exec %D/bin/ghc-pkg -ai %D/share/HOpenGL/HOpenGL.conf
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
@unexec %D/bin/ghc-pkg -r HOpenGL
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old