aboutsummaryrefslogtreecommitdiff
path: root/graphics/hs-hgl/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
commitd4f0d0048a8755106a4b0445221a19761e746984 (patch)
treec87184c5bfeaf942c827c5f706186ce9786a2588 /graphics/hs-hgl/Makefile
parente82affd309fc2d8e5ea19b2e003f1296920bd825 (diff)
downloadports-d4f0d0048a8755106a4b0445221a19761e746984.tar.gz
ports-d4f0d0048a8755106a4b0445221a19761e746984.zip
Notes
Diffstat (limited to 'graphics/hs-hgl/Makefile')
-rw-r--r--graphics/hs-hgl/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/graphics/hs-hgl/Makefile b/graphics/hs-hgl/Makefile
index 183713180e13..edc645678a69 100644
--- a/graphics/hs-hgl/Makefile
+++ b/graphics/hs-hgl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hgl
PORTVERSION= 2.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics haskell
MASTER_SITES= http://haskell.org/graphics/downloads/
PKGNAMEPREFIX= hs-
@@ -26,13 +26,14 @@ HGL_LIBS= ${PREFIX}/lib/hugs/x11
HGL_DOCS= ${PREFIX}/share/doc/hs-hgl
BUILD_WRKSRC= ${WRKSRC}/lib/x11
-MAKE_ENV= system=FreeBSD \
- hugs_install=${HGL_LIBS}
+MAKE_ARGS= system=FreeBSD \
+ hugs_install=${HGL_LIBS} \
+ X_dir=${X11BASE} \
+ CC=${CC}
ALL_TARGET= all
-.if ${MACHINE_ARCH:L} == "amd64"
-CFLAGS+= -fPIC
-.endif
+do-build:
+ @cd ${BUILD_WRKSRC}; ${GMAKE} ${MAKE_ARGS}
do-install:
${MKDIR} ${HGL_LIBS}
@@ -54,4 +55,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO} ''
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH:L} == "amd64"
+MAKE_ARGS+= CFLAGS=-fPIC
+.endif
+
+.include <bsd.port.post.mk>