aboutsummaryrefslogtreecommitdiff
path: root/graphics/hsetroot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-05 08:52:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-05 08:52:56 +0000
commitb3b50f7af32139c53992ac46fa0b438f91e01482 (patch)
tree384bd01d0c8b8acecdac35720fdbfe071290fc2b /graphics/hsetroot
parente81d45a13f3a82aee6d2ac5b359dab0413a3c673 (diff)
downloadports-b3b50f7af32139c53992ac46fa0b438f91e01482.tar.gz
ports-b3b50f7af32139c53992ac46fa0b438f91e01482.zip
Notes
Diffstat (limited to 'graphics/hsetroot')
-rw-r--r--graphics/hsetroot/Makefile23
-rw-r--r--graphics/hsetroot/distinfo1
-rw-r--r--graphics/hsetroot/files/patch-src-hsetroot.c18
-rw-r--r--graphics/hsetroot/pkg-descr7
-rw-r--r--graphics/hsetroot/pkg-plist1
5 files changed, 50 insertions, 0 deletions
diff --git a/graphics/hsetroot/Makefile b/graphics/hsetroot/Makefile
new file mode 100644
index 000000000000..113713b3df61
--- /dev/null
+++ b/graphics/hsetroot/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hsetroot
+# Date created: 30 November 2003
+# Whom: Vincent Tantardini <vinc@freebsd-fr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hsetroot
+PORTVERSION= 1.0.2
+CATEGORIES= graphics
+MASTER_SITES= http://thegraveyard.org/files/
+
+MAINTAINER= vinc@freebsd-fr.org
+COMMENT= Root window parameter setting background for X
+
+LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2
+
+USE_X_PREFIX= YES
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+.include <bsd.port.mk>
diff --git a/graphics/hsetroot/distinfo b/graphics/hsetroot/distinfo
new file mode 100644
index 000000000000..67a5a1ac8d7a
--- /dev/null
+++ b/graphics/hsetroot/distinfo
@@ -0,0 +1 @@
+MD5 (hsetroot-1.0.2.tar.gz) = f599770a6411dcfe216c37b280fad9bc
diff --git a/graphics/hsetroot/files/patch-src-hsetroot.c b/graphics/hsetroot/files/patch-src-hsetroot.c
new file mode 100644
index 000000000000..3057899de698
--- /dev/null
+++ b/graphics/hsetroot/files/patch-src-hsetroot.c
@@ -0,0 +1,18 @@
+--- src/hsetroot.c.bak Sun Nov 30 19:39:51 2003
++++ src/hsetroot.c Sun Nov 30 19:37:08 2003
+@@ -179,11 +179,13 @@
+ if (alpha < 255)
+ {
+ // Create alpha-override mask
+- imlib_image_set_has_alpha (1);
+ Imlib_Color_Modifier modifier = imlib_create_color_modifier ();
++ DATA8 red[256], green[256], blue[256], alph[256];
++
++
++ imlib_image_set_has_alpha (1);
+ imlib_context_set_color_modifier (modifier);
+
+- DATA8 red[256], green[256], blue[256], alph[256];
+ imlib_get_color_modifier_tables (red, green, blue, alph);
+ for (o = 0; o < 256; o++)
+ alph[o] = (DATA8) alpha;
diff --git a/graphics/hsetroot/pkg-descr b/graphics/hsetroot/pkg-descr
new file mode 100644
index 000000000000..a7492a3ae34b
--- /dev/null
+++ b/graphics/hsetroot/pkg-descr
@@ -0,0 +1,7 @@
+Hsetroot is a tool which allows you to compose wallpapers
+("root pixmaps") for X.
+
+WWW: http://thegraveyard.org/hsetroot.php
+
+- Vincent Tantardini
+vinc@freebsd-fr.org
diff --git a/graphics/hsetroot/pkg-plist b/graphics/hsetroot/pkg-plist
new file mode 100644
index 000000000000..64be1c6a9961
--- /dev/null
+++ b/graphics/hsetroot/pkg-plist
@@ -0,0 +1 @@
+bin/hsetroot