aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-01-30 14:40:59 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-01-30 14:40:59 +0000
commit993f7fb87cc25c11e858292471c558e1ef217397 (patch)
tree3ddd03e7ad9932da350905b144fcba8560789e35 /graphics/hugin/Makefile
parent453f2cf3a9102710f1ae5d17e423c560134b8f6e (diff)
- Update to 0.5
- Use DATADIR - Respect WITHOUT_NLS - Require wxgtk26 instead wxgtk24 and patch to use wxrc-gtk2-2.6 - Unbreak PR: ports/90619 Submitted by: Marco Molteni <molter@tin.it> Reworked by: garga Approved by: maintainer
Notes
Notes: svn path=/head/; revision=154820
Diffstat (limited to 'graphics/hugin/Makefile')
-rw-r--r--graphics/hugin/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index e7c368f827ff..5319cb662263 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= hugin
-PORTVERSION= 0.5.b2
-PORTREVISION= 5
+PORTVERSION= 0.5
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-0.5-beta2
MAINTAINER= cartola@openit.com.br
COMMENT= A GUI for Panorama Tools, to stitch panoramic images
@@ -22,25 +20,32 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
fftw:${PORTSDIR}/math/fftw \
- wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24 \
- wx_gtk2_xrc-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24-contrib \
+ wx_gtk2_xrc-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26 \
boost_date_time:${PORTSDIR}/devel/boost
RUN_DEPENDS= PTOptimizer:${PORTSDIR}/graphics/libpano12 \
PTStitcher:${PORTSDIR}/graphics/linux-panorama-tools
-BROKEN= Does not compile
-
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -ftemplate-depth-32" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -ftemplate-depth-64" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
-USE_BZIP2= yes
USE_ICONV= yes
-USE_GETTEXT= yes
DOCSDIR= ${PREFIX}/share/hugin/xrc/data
-WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.4-config
+WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.6-config
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-wxrc|-${X11BASE}/bin/wxrc-gtk2-2.6|' \
+ ${WRKSRC}/src/hugin/xrc/Makefile.in
.include <bsd.port.mk>