aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin
diff options
context:
space:
mode:
authorGreg Lehey <grog@FreeBSD.org>2016-03-21 22:06:56 +0000
committerGreg Lehey <grog@FreeBSD.org>2016-03-21 22:06:56 +0000
commit5cbf1f1c8bc1a3675de2cd09ca46b2857178a7f7 (patch)
treee3ff053f438ad6fe9440e07888959a7a2130ed7d /graphics/hugin
parente5d688c99e1a5dfd1611ce3dda46e4020642fadc (diff)
downloadports-5cbf1f1c8bc1a3675de2cd09ca46b2857178a7f7.tar.gz
ports-5cbf1f1c8bc1a3675de2cd09ca46b2857178a7f7.zip
Notes
Diffstat (limited to 'graphics/hugin')
-rw-r--r--graphics/hugin/Makefile4
-rw-r--r--graphics/hugin/distinfo4
-rw-r--r--graphics/hugin/files/patch-CMakeLists.txt14
-rw-r--r--graphics/hugin/files/patch-src__hugin1__icpfind__AutoCtrlPointCreator.cpp13
-rw-r--r--graphics/hugin/files/patch-src__tools__tca_correct.cpp20
5 files changed, 18 insertions, 37 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 39b70964effb..e6760e8699f0 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= hugin
-PORTVERSION= 2015.0.0
-PORTREVISION= 6
+PORTVERSION= 2016.0.0
+PORTREVISION= 0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
diff --git a/graphics/hugin/distinfo b/graphics/hugin/distinfo
index 712e7f18bdd4..db2e1478fbc2 100644
--- a/graphics/hugin/distinfo
+++ b/graphics/hugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hugin-2015.0.0.tar.bz2) = 2cd93c110be95d439f9e68653f3738d059a26f5c28973f75475ef59cbaa2cbbd
-SIZE (hugin-2015.0.0.tar.bz2) = 10611519
+SHA256 (hugin-2016.0.0.tar.bz2) = b030b05b248b583cf9a26817f5b350303e3ce2c8bc4b43d45f697fbdf55b65e6
+SIZE (hugin-2016.0.0.tar.bz2) = 10508576
diff --git a/graphics/hugin/files/patch-CMakeLists.txt b/graphics/hugin/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7fe935118c9d
--- /dev/null
+++ b/graphics/hugin/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+--- CMakeLists.txt~ 2016-01-24 20:16:54.000000000 +1100
++++ CMakeLists.txt 2016-02-29 14:04:08.376365000 +1100
+@@ -2,11 +2,6 @@
+ # require at least cmake 2.8
+ cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR )
+
+-# prevent in-tree building
+-if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
+- message(FATAL_ERROR "In-source builds are not allowed.")
+-endif()
+-
+ if(COMMAND cmake_policy)
+ cmake_policy(SET CMP0003 NEW)
+ endif(COMMAND cmake_policy)
diff --git a/graphics/hugin/files/patch-src__hugin1__icpfind__AutoCtrlPointCreator.cpp b/graphics/hugin/files/patch-src__hugin1__icpfind__AutoCtrlPointCreator.cpp
deleted file mode 100644
index f1ea0af648f3..000000000000
--- a/graphics/hugin/files/patch-src__hugin1__icpfind__AutoCtrlPointCreator.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/hugin1/icpfind/AutoCtrlPointCreator.cpp.orig 2015-07-18 02:44:00.000000000 +1000
-+++ src/hugin1/icpfind/AutoCtrlPointCreator.cpp 2015-10-31 15:49:42.000000000 +1100
-@@ -29,8 +29,10 @@
-
- #include <fstream>
- #ifdef __GNUC__
-+#ifndef __FreeBSD__
- #include <ext/stdio_filebuf.h>
- #endif
-+#endif
-
- #include "algorithms/optimizer/ImageGraph.h"
-
diff --git a/graphics/hugin/files/patch-src__tools__tca_correct.cpp b/graphics/hugin/files/patch-src__tools__tca_correct.cpp
deleted file mode 100644
index e327a0fab142..000000000000
--- a/graphics/hugin/files/patch-src__tools__tca_correct.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/tools/tca_correct.cpp~ 2015-10-31 11:10:44.000000000 +1100
-+++ src/tools/tca_correct.cpp 2015-10-29 13:14:14.000000000 +1100
-@@ -465,7 +465,7 @@
- << " commandline arguments for fulla" << endl;
- }
-
--static hugin_omp::Lock lock;
-+static hugin_omp::Lock slock;
- typedef std::multimap<double, vigra::Diff2D> MapPoints;
-
- template <class ImageType>
-@@ -584,7 +584,7 @@
- }
- if (!cps.empty())
- {
-- hugin_omp::ScopedLock sl(lock);
-+ hugin_omp::ScopedLock sl(slock);
- for (CPVector::const_iterator it = cps.begin(); it != cps.end(); ++it)
- {
- pano.addCtrlPoint(*it);