aboutsummaryrefslogtreecommitdiff
path: root/graphics/icc-profiles-adobe-cs4/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2018-01-18 22:13:05 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2018-01-18 22:13:05 +0000
commit041cc9b1a308796f047a597413de196f0fc10a66 (patch)
tree5cc89a95fc3fcb8a96d5352bf07c8e5c84cdc23a /graphics/icc-profiles-adobe-cs4/Makefile
parentaf42482292bf8d9dddc6a299604f04123e2bfc91 (diff)
downloadports-041cc9b1a308796f047a597413de196f0fc10a66.tar.gz
ports-041cc9b1a308796f047a597413de196f0fc10a66.zip
Notes
Diffstat (limited to 'graphics/icc-profiles-adobe-cs4/Makefile')
-rw-r--r--graphics/icc-profiles-adobe-cs4/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/icc-profiles-adobe-cs4/Makefile b/graphics/icc-profiles-adobe-cs4/Makefile
new file mode 100644
index 000000000000..2554d291c6f9
--- /dev/null
+++ b/graphics/icc-profiles-adobe-cs4/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= icc-profiles-adobe-cs4
+PORTVERSION= 1
+CATEGORIES= graphics
+MASTER_SITES= http://download.adobe.com/pub/adobe/iccprofiles/win/
+DISTNAME= AdobeICCProfilesCS4Win_end-user
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= Adobe ICC CMYK and RGB profiles for graphics professionals
+
+LICENSE= ADOBEEULA.pdf
+LICENSE_NAME= Adobe End-User License Agreement
+LICENSE_FILE= ${WRKDIR}/Adobe\ ICC\ Profiles\ \(end-user\)/Color\ Profile\ EULA.pdf
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+USES= zip
+NO_BUILD= yes
+NO_ARCH= yes
+
+SYSCOLORDIR= share/color
+PLIST_SUB= SYSCOLORDIR=${SYSCOLORDIR}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKDIR}/Adobe\ ICC\ Profiles\ \(end-user\) && ${COPYTREE_SHARE} \*.pdf ${STAGEDIR}${DOCSDIR})
+.for d in CMYK RGB
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SYSCOLORDIR}/Adobe/${d}
+ (cd ${WRKDIR}/Adobe\ ICC\ Profiles\ \(end-user\)/${d} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${SYSCOLORDIR}/Adobe/${d})
+.endfor
+
+.include <bsd.port.mk>