aboutsummaryrefslogtreecommitdiff
path: root/graphics/icoutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-09-23 06:47:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-09-23 06:47:31 +0000
commit5d235cbb502f7598feb12c430211a836157f8b2a (patch)
tree3f6fd944a98b8d47b4beef4c4e0fb0e90126e620 /graphics/icoutils
parentdd8257ed5850096ddba40bda635bac5b8f3c8ef5 (diff)
downloadports-5d235cbb502f7598feb12c430211a836157f8b2a.tar.gz
ports-5d235cbb502f7598feb12c430211a836157f8b2a.zip
Notes
Diffstat (limited to 'graphics/icoutils')
-rw-r--r--graphics/icoutils/Makefile31
-rw-r--r--graphics/icoutils/pkg-descr28
2 files changed, 29 insertions, 30 deletions
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index 0d85ad6da9e8..40632ac8e700 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -13,11 +13,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
-OPTIONS_DEFINE= RESSCRIPTS
-RESSCRIPTS_DESC= PERL resource scripts
-
-USE_BZIP2= yes
-USES= shebangfix
+USES= shebangfix tar:bzip2
SHEBANG_FILES= extresso/*.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls
@@ -25,10 +21,11 @@ CONFIGURE_ARGS= --disable-nls
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/icotool \
- bin/wrestool \
- man/man1/icotool.1.gz \
- man/man1/wrestool.1.gz
+PLIST_FILES= bin/icotool bin/wrestool \
+ man/man1/icotool.1.gz man/man1/wrestool.1.gz
+
+OPTIONS_DEFINE= RESSCRIPTS
+RESSCRIPTS_DESC= Additional resource scripts written in Perl
.include <bsd.port.options.mk>
@@ -36,20 +33,12 @@ PLIST_FILES= bin/icotool \
RUN_DEPENDS+= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
USES+= perl5
USE_PERL5= run
-MAN1+= extresso.1 genresscript.1
-PLIST_FILES+= bin/extresso \
- bin/genresscript
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not link on sparc64
+PLIST_FILES+= bin/extresso bin/genresscript \
+ man/man1/extresso.1.gz man/man1/genresscript.1.gz
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- '/^SUBDIRS/s|extresso||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|extresso||' ${WRKSRC}/Makefile.in
post-install:
.if ${PORT_OPTIONS:MRESSCRIPTS}
@@ -57,4 +46,4 @@ post-install:
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/icoutils/pkg-descr b/graphics/icoutils/pkg-descr
index 21edbbdd3f39..0d57593bd168 100644
--- a/graphics/icoutils/pkg-descr
+++ b/graphics/icoutils/pkg-descr
@@ -1,13 +1,23 @@
-[ excerpt with modifications from developer's site ]
+The icoutils are a set of program for extracting and converting images in
+Microsoft Windows(R) icon and cursor files. These files usually have the
+extension .ico or .cur, but they can also be embedded in executables and
+libraries (.dll-files).
-The icoutils are a set of program for extracting and converting
-images in Microsoft Windows(R) icon and cursor files. These files
-usually have the extension .ico or .cur, but they can also be
-embedded in executables and libraries (.dll-files).
+The icotool program converts icon and cursor files into a set of PNG images.
+(Each icon/cursor file may contain multiple images, usually of different
+sizes and with different number of colors.) Icotool can also create
+icon/cursor files from PNG images.
-The icotool program converts icon and cursor files into a set of
-PNG images. (Each icon/cursor file may contain multiple images,
-usually of different sizes and with different number of colors.)
-Icotool can also create icon/cursor files from PNG images.
+The wrestool program can extract both icons and cursors from 32-bit ("PE")
+and 16-bit ("NE") executables and libraries. It writes .ico and .cur files
+that can be used on Windows(R) operating systems as well. Other types of
+embedded resourced can be extracted, however only in raw form -- icons and
+cursors require additional conversion before they can be saved as icon and
+cursor files.
+
+The extresso script automates the tasks of extracting and converting icons.
+This is done with the help of of special resource scripts. The purpose of
+these scripts are to give names to the icons in the executables and
+libraries.
WWW: http://www.nongnu.org/icoutils/