aboutsummaryrefslogtreecommitdiff
path: root/graphics/icoutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-09 09:05:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-09 09:05:36 +0000
commit1572cf66ad0f9dd1a337229612373874b5d57dc5 (patch)
treec0991b0dfcc5777b4aab7771a0385ff0a71e4e5f /graphics/icoutils
parent86e3a4f76e501dd593412682264942296920db8d (diff)
downloadports-1572cf66ad0f9dd1a337229612373874b5d57dc5.tar.gz
ports-1572cf66ad0f9dd1a337229612373874b5d57dc5.zip
Notes
Diffstat (limited to 'graphics/icoutils')
-rw-r--r--graphics/icoutils/Makefile18
-rw-r--r--graphics/icoutils/distinfo6
-rw-r--r--graphics/icoutils/files/patch-icotool__Makefile.in15
-rw-r--r--graphics/icoutils/files/patch-wrestool__Makefile.in12
4 files changed, 34 insertions, 17 deletions
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index 1f52f6d3f634..41d0ab08f397 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -6,37 +6,27 @@
#
PORTNAME= icoutils
-PORTVERSION= 0.26.0
-PORTREVISION= 3
+PORTVERSION= 0.27.0
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SAVANNAH
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert/extract images in Microsoft Windows(R) icon/cursor files
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
USE_GETTEXT= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="-lintl"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= extresso.1 genresscript.1 icotool.1 wrestool.1
-
PLIST_FILES= \
bin/extresso \
bin/genresscript \
bin/icotool \
bin/wrestool
-post-patch:
- @${FIND} ${WRKSRC} -type f -print0 | \
- ${XARGS} -0 -x -n 10 \
- ${REINPLACE_CMD} -E \
- -e 's|stdint\.h|inttypes\.h|g' \
- -e 's|/usr/bin/perl|${PERL5}|'
-
.include <bsd.port.mk>
diff --git a/graphics/icoutils/distinfo b/graphics/icoutils/distinfo
index 18e787a48461..89bb6fb1e094 100644
--- a/graphics/icoutils/distinfo
+++ b/graphics/icoutils/distinfo
@@ -1,3 +1,3 @@
-MD5 (icoutils-0.26.0.tar.gz) = 5494ee42a9dad562b49c6b8721f973e8
-SHA256 (icoutils-0.26.0.tar.gz) = ffb6fdd3eaf0f24c53759a4eda6090dde60a4efd3342ee6c3a2a0305507b5871
-SIZE (icoutils-0.26.0.tar.gz) = 603257
+MD5 (icoutils-0.27.0.tar.gz) = e0ec22c83290317a04110a3d05d1c7ac
+SHA256 (icoutils-0.27.0.tar.gz) = 848456fdfddfdefde30946ff60658b3af544623dcde2118c75aa583a0bdf46a9
+SIZE (icoutils-0.27.0.tar.gz) = 489729
diff --git a/graphics/icoutils/files/patch-icotool__Makefile.in b/graphics/icoutils/files/patch-icotool__Makefile.in
new file mode 100644
index 000000000000..072d2caa2c91
--- /dev/null
+++ b/graphics/icoutils/files/patch-icotool__Makefile.in
@@ -0,0 +1,15 @@
+--- icotool/Makefile.in.orig 2009-06-30 03:14:01.000000000 +0900
++++ icotool/Makefile.in 2009-07-07 01:32:50.000000000 +0900
+@@ -559,9 +559,10 @@
+ win32.h
+
+ icotool_LDADD = \
+- @PNG_LIBS@ \
+ ../common/libcommon.a \
+- ../lib/libgnu.a
++ ../lib/libgnu.a \
++ @PNG_LIBS@ \
++ @LIBINTL@
+
+ man_MANS = \
+ icotool.1
diff --git a/graphics/icoutils/files/patch-wrestool__Makefile.in b/graphics/icoutils/files/patch-wrestool__Makefile.in
new file mode 100644
index 000000000000..889a0392e1b2
--- /dev/null
+++ b/graphics/icoutils/files/patch-wrestool__Makefile.in
@@ -0,0 +1,12 @@
+--- wrestool/Makefile.in.orig 2009-06-30 03:14:01.000000000 +0900
++++ wrestool/Makefile.in 2009-07-07 01:33:24.000000000 +0900
+@@ -558,7 +558,8 @@
+
+ wrestool_LDADD = \
+ ../common/libcommon.a \
+- ../lib/libgnu.a
++ ../lib/libgnu.a \
++ @LIBINTL@
+
+ man_MANS = \
+ wrestool.1