aboutsummaryrefslogtreecommitdiff
path: root/graphics/iec16022/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-10-23 20:57:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-10-23 20:57:32 +0000
commit353df5ce242d7541f91144f745eed25c814352cf (patch)
tree01191e7d43da6d5a6ecc5e29db8791cb44c771d2 /graphics/iec16022/Makefile
parent2ce50df6c14f49441fb70b7f3cbfc6791c1b6cd5 (diff)
downloadports-353df5ce242d7541f91144f745eed25c814352cf.tar.gz
ports-353df5ce242d7541f91144f745eed25c814352cf.zip
Notes
Diffstat (limited to 'graphics/iec16022/Makefile')
-rw-r--r--graphics/iec16022/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/iec16022/Makefile b/graphics/iec16022/Makefile
index 03b5eafef428..54a11f9bdf13 100644
--- a/graphics/iec16022/Makefile
+++ b/graphics/iec16022/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= iec16022
-PORTVERSION= 0.2.3
+PORTVERSION= 0.2.4
CATEGORIES= graphics
MASTER_SITES= http://datenfreihafen.org/~stefan/iec16022/ \
CRITICAL
@@ -17,19 +17,20 @@ COMMENT= Create 2D barcodes, also known as DataMatrix
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig
+
MAKE_JOBS_SAFE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
MAN1= iec16022.1
-PLIST_FILES= bin/iec16022
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/iec16022.c \
${WRKSRC}/iec16022ecc200.c ${WRKSRC}/reedsol.c ${WRKSRC}/image.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${REINPLACE_CMD} -e \
+ "s|^\(pkgconfigdir\).*|\1 = ${PREFIX}/libdata/pkgconfig|" \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.mk>