aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2007-10-06 18:36:51 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2007-10-06 18:36:51 +0000
commit689f9b8b18f33d5c77896f1315cf1db3115572cd (patch)
treee9dcd46a4c8887a80b6f3d518192f9b27c5645fe /graphics/ilmbase
parent9f6fd8785aa574aa820c8ed83f8ebc9cac995536 (diff)
downloadports-689f9b8b18f33d5c77896f1315cf1db3115572cd.tar.gz
ports-689f9b8b18f33d5c77896f1315cf1db3115572cd.zip
Notes
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile25
-rw-r--r--graphics/ilmbase/distinfo3
-rw-r--r--graphics/ilmbase/files/patch-Makefile11
-rw-r--r--graphics/ilmbase/pkg-descr13
-rw-r--r--graphics/ilmbase/pkg-plist61
5 files changed, 113 insertions, 0 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
new file mode 100644
index 000000000000..7d38858a00a9
--- /dev/null
+++ b/graphics/ilmbase/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ilmbase
+# Date created: 2007-10-07
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ilmbase
+PORTVERSION= 1.0.0
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= openexr
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath and Iex
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.mk>
diff --git a/graphics/ilmbase/distinfo b/graphics/ilmbase/distinfo
new file mode 100644
index 000000000000..314645cea6e5
--- /dev/null
+++ b/graphics/ilmbase/distinfo
@@ -0,0 +1,3 @@
+MD5 (ilmbase-1.0.0.tar.gz) = 9e0fd3357ea36995382978a2b7d22401
+SHA256 (ilmbase-1.0.0.tar.gz) = dfde8800b449709310ec2dc98a5e81ab3cadcdaa5ae4921e753639b7e088efb6
+SIZE (ilmbase-1.0.0.tar.gz) = 470217
diff --git a/graphics/ilmbase/files/patch-Makefile b/graphics/ilmbase/files/patch-Makefile
new file mode 100644
index 000000000000..f6ee12fa1649
--- /dev/null
+++ b/graphics/ilmbase/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2007-08-04 02:28:25.000000000 +0900
++++ Makefile.in 2007-10-07 03:17:50.000000000 +0900
+@@ -205,7 +205,7 @@
+ README README.CVS README.OSX README.win32 bootstrap \
+ config.windows/IlmBaseConfig.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = IlmBase.pc
+ all: all-recursive
+
diff --git a/graphics/ilmbase/pkg-descr b/graphics/ilmbase/pkg-descr
new file mode 100644
index 000000000000..f8a295a71519
--- /dev/null
+++ b/graphics/ilmbase/pkg-descr
@@ -0,0 +1,13 @@
+ILM Base libraries have following four libraries.
+
+*Half is a class that encapsulates ILM's 16-bit floating-point format.
+
+*IlmThread is a thread abstraction library for use with OpenEXR
+ and other software packages.
+
+*Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
+ and other useful 2D and 3D math functions.
+
+*Iex is an exception-handling library.
+
+WWW: http://www.openexr.com/
diff --git a/graphics/ilmbase/pkg-plist b/graphics/ilmbase/pkg-plist
new file mode 100644
index 000000000000..41c67d5145e4
--- /dev/null
+++ b/graphics/ilmbase/pkg-plist
@@ -0,0 +1,61 @@
+lib/libHalf.a
+lib/libHalf.la
+lib/libHalf.so
+lib/libHalf.so.6
+lib/libIex.a
+lib/libIex.la
+lib/libIex.so
+lib/libIex.so.6
+lib/libIlmThread.a
+lib/libIlmThread.la
+lib/libIlmThread.so
+lib/libIlmThread.so.6
+lib/libImath.a
+lib/libImath.la
+lib/libImath.so
+lib/libImath.so.6
+libdata/pkgconfig/IlmBase.pc
+include/OpenEXR/Iex.h
+include/OpenEXR/IexBaseExc.h
+include/OpenEXR/IexErrnoExc.h
+include/OpenEXR/IexMacros.h
+include/OpenEXR/IexMathExc.h
+include/OpenEXR/IexThrowErrnoExc.h
+include/OpenEXR/IlmBaseConfig.h
+include/OpenEXR/IlmThread.h
+include/OpenEXR/IlmThreadMutex.h
+include/OpenEXR/IlmThreadPool.h
+include/OpenEXR/IlmThreadSemaphore.h
+include/OpenEXR/ImathBox.h
+include/OpenEXR/ImathBoxAlgo.h
+include/OpenEXR/ImathColor.h
+include/OpenEXR/ImathColorAlgo.h
+include/OpenEXR/ImathEuler.h
+include/OpenEXR/ImathExc.h
+include/OpenEXR/ImathFrame.h
+include/OpenEXR/ImathFrustum.h
+include/OpenEXR/ImathFun.h
+include/OpenEXR/ImathGL.h
+include/OpenEXR/ImathGLU.h
+include/OpenEXR/ImathHalfLimits.h
+include/OpenEXR/ImathInt64.h
+include/OpenEXR/ImathInterval.h
+include/OpenEXR/ImathLimits.h
+include/OpenEXR/ImathLine.h
+include/OpenEXR/ImathLineAlgo.h
+include/OpenEXR/ImathMath.h
+include/OpenEXR/ImathMatrix.h
+include/OpenEXR/ImathMatrixAlgo.h
+include/OpenEXR/ImathPlane.h
+include/OpenEXR/ImathPlatform.h
+include/OpenEXR/ImathQuat.h
+include/OpenEXR/ImathRandom.h
+include/OpenEXR/ImathRoots.h
+include/OpenEXR/ImathShear.h
+include/OpenEXR/ImathSphere.h
+include/OpenEXR/ImathVec.h
+include/OpenEXR/ImathVecAlgo.h
+include/OpenEXR/half.h
+include/OpenEXR/halfFunction.h
+include/OpenEXR/halfLimits.h
+@dirrm include/OpenEXR