aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-01-17 03:19:42 +0000
committerSteve Wills <swills@FreeBSD.org>2013-01-17 03:19:42 +0000
commita16cda4c60f042b4cab5b80c18e30fa56d0f4a2f (patch)
tree74492fef2b71c5fe771ddbd99a1c03ae65c47ae1 /graphics/ilmbase
parent476a8c17672fe56514f59f0e24642a7cb99be7a2 (diff)
downloadports-a16cda4c60f042b4cab5b80c18e30fa56d0f4a2f.tar.gz
ports-a16cda4c60f042b4cab5b80c18e30fa56d0f4a2f.zip
- Update to 1.0.3
- Give maintainership to submitter PR: ports/172337 Submitted by: nemysis <nemysis@gmx.ch>
Notes
Notes: svn path=/head/; revision=310532
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile36
-rw-r--r--graphics/ilmbase/distinfo4
-rw-r--r--graphics/ilmbase/files/patch-IexMath-IexMathFpu.cpp11
-rw-r--r--graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp8
-rw-r--r--graphics/ilmbase/files/patch-ImathTest-testLineAlgo.cpp10
-rw-r--r--graphics/ilmbase/files/patch-Makefile.in (renamed from graphics/ilmbase/files/patch-Makefile)6
-rw-r--r--graphics/ilmbase/files/patch-configure6
-rw-r--r--graphics/ilmbase/pkg-descr19
-rw-r--r--graphics/ilmbase/pkg-plist44
9 files changed, 84 insertions, 60 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index 094ef0f2e96e..c4f7a04ef10b 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -6,35 +6,45 @@
#
PORTNAME= ilmbase
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
CATEGORIES= graphics devel
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= openexr
+MASTER_SITES= http://cloud.github.com/downloads/openexr/openexr/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
-CONFLICTS= OpenEXR-1.[0-4].*
+LICENSE= BSD
-OPTIONS_DEFINE= THREAD
-OPTIONS_DEFAULT= THREAD
-THREAD_DESC= Enable multithreaded file I/O support
+CONFLICTS= OpenEXR-1.[0-4].*
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-regression-test regression test check: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+PORTDOCS= AUTHORS ChangeLog README
+
+OPTIONS_DEFINE= THREAD
+OPTIONS_DEFAULT= THREAD
+THREAD_DESC= Enable multithreaded file I/O support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTHREAD}
+CONFIGURE_ARGS+=--enable-threading
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.else
CONFIGURE_ARGS+=--disable-threading
.endif
-.include <bsd.port.post.mk>
+regression-test regression test check: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/ilmbase/distinfo b/graphics/ilmbase/distinfo
index 2ba9b81aac6b..458e534f7c6b 100644
--- a/graphics/ilmbase/distinfo
+++ b/graphics/ilmbase/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ilmbase-1.0.2.tar.gz) = 2e5cda799ffdfca9b1a16bb120d49c74a39af1457ef22f968918c6200ba62e44
-SIZE (ilmbase-1.0.2.tar.gz) = 496540
+SHA256 (ilmbase-1.0.3.tar.gz) = a998e064d6960ba258731fa5c8e7a3870b0eaa7ba9c1a5e5078263e9d9f76502
+SIZE (ilmbase-1.0.3.tar.gz) = 534980
diff --git a/graphics/ilmbase/files/patch-IexMath-IexMathFpu.cpp b/graphics/ilmbase/files/patch-IexMath-IexMathFpu.cpp
new file mode 100644
index 000000000000..61307aca6ef6
--- /dev/null
+++ b/graphics/ilmbase/files/patch-IexMath-IexMathFpu.cpp
@@ -0,0 +1,11 @@
+--- IexMath/IexMathFpu.cpp.orig 2012-07-26 20:51:55.000000000 +0200
++++ IexMath/IexMathFpu.cpp 2012-11-01 12:00:36.000000000 +0100
+@@ -27,7 +27,7 @@
+ #endif
+
+
+-#ifdef HAVE_UCONTEXT_H
++#if defined(HAVE_UCONTEXT_H) && (defined(x86_64) || defined(i386_))
+
+
+ #include <ucontext.h>
diff --git a/graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp b/graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp
index 5eca503d4d1d..53ff18d06458 100644
--- a/graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp
+++ b/graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp
@@ -1,11 +1,11 @@
---- ImathTest/testBoxAlgo.cpp.orig 2007-07-13 13:48:45.000000000 +0900
-+++ ImathTest/testBoxAlgo.cpp 2007-10-07 23:26:22.000000000 +0900
-@@ -336,7 +336,7 @@
+--- ImathTest/testBoxAlgo.cpp.orig 2012-07-18 01:27:26.000000000 +0200
++++ ImathTest/testBoxAlgo.cpp 2012-10-04 15:45:00.000000000 +0200
+@@ -356,7 +356,7 @@
Box3f ()
};
- for (int i = 0; i < sizeof (boxes) / sizeof (boxes[0]); ++i)
+ for (unsigned int i = 0; i < sizeof (boxes) / sizeof (boxes[0]); ++i)
- testRayBoxIntersection (boxes[i]);
+ testEntryAndExitPoints (boxes[i]);
}
diff --git a/graphics/ilmbase/files/patch-ImathTest-testLineAlgo.cpp b/graphics/ilmbase/files/patch-ImathTest-testLineAlgo.cpp
deleted file mode 100644
index bb7452049a65..000000000000
--- a/graphics/ilmbase/files/patch-ImathTest-testLineAlgo.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ImathTest/testLineAlgo.cpp.orig 2006-12-09 06:59:38.000000000 +0900
-+++ ImathTest/testLineAlgo.cpp 2007-10-07 23:24:58.000000000 +0900
-@@ -399,7 +399,6 @@
- V3f p1 = v0 * b.x + v1 * b.y + v2 * b.z;
-
- V3f p0;
-- int j = 0;
-
- do
- {
diff --git a/graphics/ilmbase/files/patch-Makefile b/graphics/ilmbase/files/patch-Makefile.in
index f6ee12fa1649..ae1777219e44 100644
--- a/graphics/ilmbase/files/patch-Makefile
+++ b/graphics/ilmbase/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2007-08-04 02:28:25.000000000 +0900
-+++ Makefile.in 2007-10-07 03:17:50.000000000 +0900
-@@ -205,7 +205,7 @@
+--- Makefile.in.orig 2012-07-31 22:09:25.000000000 +0200
++++ Makefile.in 2012-10-04 14:25:06.000000000 +0200
+@@ -224,7 +224,7 @@
README README.CVS README.OSX README.win32 bootstrap \
config.windows/IlmBaseConfig.h
diff --git a/graphics/ilmbase/files/patch-configure b/graphics/ilmbase/files/patch-configure
index ecb43fbaafa3..bcf9d2b9ef13 100644
--- a/graphics/ilmbase/files/patch-configure
+++ b/graphics/ilmbase/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-09-19 00:48:14.000000000 +0000
-+++ configure 2012-09-19 00:51:54.000000000 +0000
-@@ -20384,25 +20384,25 @@
+--- configure.orig 2012-07-31 00:11:22.000000000 +0200
++++ configure 2012-10-04 14:20:16.000000000 +0200
+@@ -15978,25 +15978,25 @@
osx_arch=default
fi;
diff --git a/graphics/ilmbase/pkg-descr b/graphics/ilmbase/pkg-descr
index f8a295a71519..aa59684d8e5f 100644
--- a/graphics/ilmbase/pkg-descr
+++ b/graphics/ilmbase/pkg-descr
@@ -1,13 +1,18 @@
-ILM Base libraries have following four libraries.
+ABOUT THE ILMBASE LIBRARIES
+----------------------------
-*Half is a class that encapsulates ILM's 16-bit floating-point format.
+Half is a class that encapsulates our 16-bit floating-point format.
-*IlmThread is a thread abstraction library for use with OpenEXR
- and other software packages.
+IlmThread is a thread abstraction library for use with OpenEXR
+and other software packages. It currently supports pthreads and
+Windows threads.
-*Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
- and other useful 2D and 3D math functions.
+Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
+and other useful 2D and 3D math functions.
-*Iex is an exception-handling library.
+Iex is an exception-handling library.
+
+If you have questions about using the IlmBase libraries, you may want
+to join our developer mailing list.
WWW: http://www.openexr.com/
diff --git a/graphics/ilmbase/pkg-plist b/graphics/ilmbase/pkg-plist
index 41c67d5145e4..e1a842c7c590 100644
--- a/graphics/ilmbase/pkg-plist
+++ b/graphics/ilmbase/pkg-plist
@@ -1,25 +1,11 @@
-lib/libHalf.a
-lib/libHalf.la
-lib/libHalf.so
-lib/libHalf.so.6
-lib/libIex.a
-lib/libIex.la
-lib/libIex.so
-lib/libIex.so.6
-lib/libIlmThread.a
-lib/libIlmThread.la
-lib/libIlmThread.so
-lib/libIlmThread.so.6
-lib/libImath.a
-lib/libImath.la
-lib/libImath.so
-lib/libImath.so.6
-libdata/pkgconfig/IlmBase.pc
include/OpenEXR/Iex.h
include/OpenEXR/IexBaseExc.h
include/OpenEXR/IexErrnoExc.h
include/OpenEXR/IexMacros.h
include/OpenEXR/IexMathExc.h
+include/OpenEXR/IexMathFloatExc.h
+include/OpenEXR/IexMathFpu.h
+include/OpenEXR/IexMathIeeeExc.h
include/OpenEXR/IexThrowErrnoExc.h
include/OpenEXR/IlmBaseConfig.h
include/OpenEXR/IlmThread.h
@@ -58,4 +44,26 @@ include/OpenEXR/ImathVecAlgo.h
include/OpenEXR/half.h
include/OpenEXR/halfFunction.h
include/OpenEXR/halfLimits.h
-@dirrm include/OpenEXR
+lib/libHalf.a
+lib/libHalf.la
+lib/libHalf.so
+lib/libHalf.so.7
+lib/libIex.a
+lib/libIex.la
+lib/libIex.so
+lib/libIex.so.7
+lib/libIexMath.a
+lib/libIexMath.la
+lib/libIexMath.so
+lib/libIexMath.so.7
+lib/libIlmThread.a
+lib/libIlmThread.la
+lib/libIlmThread.so
+lib/libIlmThread.so.7
+lib/libImath.a
+lib/libImath.la
+lib/libImath.so
+lib/libImath.so.7
+libdata/pkgconfig/IlmBase.pc
+@dirrmtry share/applications
+@dirrmtry include/OpenEXR