aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2018-12-04 22:36:34 +0000
committerMatthias Andree <mandree@FreeBSD.org>2018-12-04 22:36:34 +0000
commitb017a6d66f64adefb7c828b578f319011d5f5551 (patch)
treec1539521c20fa2604b3a46ccf53100824d27c923 /graphics/ilmbase
parentc2a840e0af1acbae81cf020b9df1437abd6510e7 (diff)
downloadports-b017a6d66f64adefb7c828b578f319011d5f5551.tar.gz
ports-b017a6d66f64adefb7c828b578f319011d5f5551.zip
Align *_DEPENDS and use paths for bash in my ports; fix var name.
On systems where bash is in $PATH but not in ${LOCALBASE}/bin/bash, ilmbase would fail to build, and e2fsprogs might fail if the BASHTESTS option was enabled. Make sure that the _DEPENDS and the actual path handed to the configure or test rig match to the letter, to avoid a time-of-check vs. time-of-use discrepancy. In e2fsprogs, the helper variable was also mistyped and would never amend to BUILD_DEPENDS. Fix typo. Check my other ports, but wiggle and xmlto [textproc/] seem unaffected. Reported by: J R Matthews (direct email) MFH: 2018Q4
Notes
Notes: svn path=/head/; revision=486634
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index 9952bda5a073..5e7df6eee91d 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -11,14 +11,17 @@ COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= bash:shells/bash
+# there are some systems that have a static /bin/bash, so
+# in order to make BUILD_DEPENDS effective, use the same absolute
+# path we will pass down through CONFIGURE_SHELL below.
+BUILD_DEPENDS= ${BASH_CMD}:shells/bash
USES= compiler:c++14-lang pkgconfig libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
# The configure script uses bash arrays
-CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
+CONFIGURE_SHELL=${BASH_CMD}
CONFIGURE_ARGS= --disable-static
TEST_TARGET= check
@@ -27,6 +30,8 @@ OPTIONS_DEFINE= DOCS LARGE_STACK
LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
LARGE_STACK_CONFIGURE_ENABLE= large-stack
+BASH_CMD= ${LOCALBASE}/bin/bash
+
OPTIONS_SUB= yes
MAJORVER= 2_3