aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2018-09-22 10:15:22 +0000
committerMatthias Andree <mandree@FreeBSD.org>2018-09-22 10:15:22 +0000
commitd1cfeab07edadd10dd4f099e9dd0c9103b3596be (patch)
tree3378240ab0ba279cc8a007880049ac1be723082d /graphics/ilmbase
parentaf8a39ccb6a2b032b3db242b42f46734d62da830 (diff)
downloadports-d1cfeab07edadd10dd4f099e9dd0c9103b3596be.tar.gz
ports-d1cfeab07edadd10dd4f099e9dd0c9103b3596be.zip
Update ilmbase and openexr to 2.3.0, rename OpenEXR to openexr.
Release notes: <https://github.com/openexr/openexr/releases/tag/v2.3.0> Adjust LIB_DEPENDS of all ports that require ilmbase or openexr to chase the new lower-case spelling of the name, and to omit the version from the library name to ease future maintenance. Bump PORTREVISION of all ports that depend on ilmbase or openexr directly, so that they all get rebuilt on upgrades. Add patches to graphics/ampasCTL to keep it alive, with (a) ilmbase now that its Iex::BaseExc class is no longer derived from std::string, details were given upstream through https://github.com/ampas/CTL/issues/71 and (b) to unwind semicolon/;-lists in cmake that stem from openexr/ ilmbase pkg-config variables. (Note ampasCTL is unmaintained as FreeBSD port, and upstream, and I cannot run-time test it.) Poudriere build tests on 11.2-RELEASE-p1 amd64 of ALL ports depending directly or indirectly on ilmbase and/or openexr have passed without regressions. Thus invoking due diligence, I believe I have done the equivalent of an -exp run, and do not require approval for the dependency chases to third-party ports.
Notes
Notes: svn path=/head/; revision=480374
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile36
-rw-r--r--graphics/ilmbase/distinfo6
-rw-r--r--graphics/ilmbase/files/patch-CMakeLists.txt9
-rw-r--r--graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt19
-rw-r--r--graphics/ilmbase/files/patch-git_8eed701259
5 files changed, 26 insertions, 103 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index 8142508cc31e..9952bda5a073 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -2,43 +2,53 @@
# $FreeBSD$
PORTNAME= ilmbase
-PORTVERSION= 2.2.1
+PORTVERSION= 2.3.0
CATEGORIES= graphics devel
-MASTER_SITES= SAVANNAH/openexr/
-DISTNAME= ilmbase-${PORTVERSION}
+MASTER_SITES= https://github.com/openexr/openexr/releases/download/v${PORTVERSION}/
MAINTAINER= mandree@FreeBSD.org
COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
LICENSE= BSD3CLAUSE
-USES= cmake pkgconfig
+BUILD_DEPENDS= bash:shells/bash
+
+USES= compiler:c++14-lang pkgconfig libtool
USE_LDCONFIG= yes
-PORTDOCS= AUTHORS ChangeLog README
-OPTIONS_DEFINE= DOCS
+GNU_CONFIGURE= yes
+# The configure script uses bash arrays
+CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
+CONFIGURE_ARGS= --disable-static
+TEST_TARGET= check
-OPTIONS_SUB= yes
+PORTDOCS= AUTHORS ChangeLog README.md
+OPTIONS_DEFINE= DOCS LARGE_STACK
+LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
+LARGE_STACK_CONFIGURE_ENABLE= large-stack
-THREAD_CONFIGURE_ENABLE= threading
+OPTIONS_SUB= yes
-MAJORVER= 2_2
-VER= 23
+MAJORVER= 2_3
+VER= 24
PLIST_SUB= MAJORVER=${MAJORVER}
PLIST_SUB+= VER=${VER}
HALF_BIN= eLut toFloat
-regression-test regression test check: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
+regression-test regression check:: test
+
+post-configure:
+ ${REINPLACE_CMD} -e 's/#define HAVE_UCONTEXT_H 1/#undef HAVE_UCONTEXT_H/' ${WRKSRC}/config/IlmBaseConfig.h
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libHalf.so.${VER}
${RM} ${STAGEDIR}${PREFIX}/lib/*.la
.for l in libIex libIexMath libImath libIlmThread
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${l}-${MAJORVER}.so.${VER}
- ${LN} -s ${l}-${MAJORVER}.so.${VER} ${STAGEDIR}${PREFIX}/lib/${l}.so || :
+ @#${LN} -s ${l}-${MAJORVER}.so.${VER} ${STAGEDIR}${PREFIX}/lib/${l}.so || :
+ ${LN} -s ${l}.so ${STAGEDIR}${PREFIX}/lib/${l}-${MAJORVER}.so
.endfor
.for e in ${HALF_BIN}
diff --git a/graphics/ilmbase/distinfo b/graphics/ilmbase/distinfo
index 941a8ec90527..85149b2aebfe 100644
--- a/graphics/ilmbase/distinfo
+++ b/graphics/ilmbase/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1512081439
-SHA256 (ilmbase-2.2.1.tar.gz) = cac206e63be68136ef556c2b555df659f45098c159ce24804e9d5e9e0286609e
-SIZE (ilmbase-2.2.1.tar.gz) = 573073
+TIMESTAMP = 1536500142
+SHA256 (ilmbase-2.3.0.tar.gz) = 456978d1a978a5f823c7c675f3f36b0ae14dba36638aeaa3c4b0e784f12a3862
+SIZE (ilmbase-2.3.0.tar.gz) = 595490
diff --git a/graphics/ilmbase/files/patch-CMakeLists.txt b/graphics/ilmbase/files/patch-CMakeLists.txt
deleted file mode 100644
index a46a83f2b356..000000000000
--- a/graphics/ilmbase/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
---- CMakeLists.txt.orig 2017-11-17 23:00:23 UTC
-+++ CMakeLists.txt
-@@ -227,5 +227,5 @@ Cflags: -pthread -I\${OpenEXR_includedir
- INSTALL ( FILES
- ${CMAKE_BINARY_DIR}/IlmBase.pc
- DESTINATION
-- lib/pkgconfig
-+ libdata/pkgconfig
- )
diff --git a/graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt b/graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt
deleted file mode 100644
index 1f2b51d628f0..000000000000
--- a/graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
---- IlmThread/CMakeLists.txt.orig 2017-11-17 23:00:23 UTC
-+++ IlmThread/CMakeLists.txt
-@@ -18,6 +18,7 @@ IF (WIN32)
- )
- ENDIF()
-
-+FIND_PACKAGE(Threads)
-
- IF(BUILD_SHARED_LIBS)
- ADD_DEFINITIONS(-DILMTHREAD_EXPORTS)
-@@ -26,7 +27,7 @@ ENDIF()
- ADD_LIBRARY ( IlmThread ${LIB_TYPE}
- ${ILMTHREAD_LIBRARY_SOURCES}
- )
--TARGET_LINK_LIBRARIES(IlmThread Iex)
-+TARGET_LINK_LIBRARIES(IlmThread Iex ${CMAKE_THREAD_LIBS_INIT})
-
- INSTALL ( TARGETS
- IlmThread
diff --git a/graphics/ilmbase/files/patch-git_8eed7012 b/graphics/ilmbase/files/patch-git_8eed7012
deleted file mode 100644
index dbbcd85ec4a0..000000000000
--- a/graphics/ilmbase/files/patch-git_8eed7012
+++ /dev/null
@@ -1,59 +0,0 @@
-From 8eed7012c10f1a835385d750fd55f228d1d35df9 Mon Sep 17 00:00:00 2001
-From: Ralph Potter <r.potter@bath.ac.uk>
-Date: Wed, 5 Nov 2014 16:16:55 +0000
-Subject: [PATCH] Resolve dependency issue building eLut.h/toFloat.h with
- CMake/Ninja.
-
----
- IlmBase/Half/CMakeLists.txt | 23 +++++++++++------------
- 1 file changed, 11 insertions(+), 12 deletions(-)
-
-diff --git a/IlmBase/Half/CMakeLists.txt b/IlmBase/Half/CMakeLists.txt
-index 6f9714d..958d1b0 100644
---- Half/CMakeLists.txt
-+++ Half/CMakeLists.txt
-@@ -1,23 +1,24 @@
- # yue.nicholas@gmail.com
-
- ADD_EXECUTABLE ( eLut eLut.cpp )
--
--ADD_CUSTOM_COMMAND (
-- TARGET eLut POST_BUILD
-- COMMAND eLut > ${CMAKE_CURRENT_BINARY_DIR}/eLut.h
-+ADD_CUSTOM_COMMAND(
-+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/eLut.h
-+ COMMAND eLut ARGS > ${CMAKE_CURRENT_BINARY_DIR}/eLut.h
-+ DEPENDS eLut
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
--)
-+ )
- SET_SOURCE_FILES_PROPERTIES(
- ${CMAKE_CURRENT_BINARY_DIR}/eLut.h
- PROPERTIES HEADER_FILE_ONLY TRUE
- )
-
- ADD_EXECUTABLE ( toFloat toFloat.cpp )
--ADD_CUSTOM_COMMAND (
-- TARGET toFloat POST_BUILD
-- COMMAND toFloat > ${CMAKE_CURRENT_BINARY_DIR}/toFloat.h
-+ADD_CUSTOM_COMMAND(
-+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/toFloat.h
-+ COMMAND toFloat ARGS > ${CMAKE_CURRENT_BINARY_DIR}/toFloat.h
-+ DEPENDS toFloat
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
--)
-+ )
- SET_SOURCE_FILES_PROPERTIES(
- ${CMAKE_CURRENT_BINARY_DIR}/toFloat.h
- PROPERTIES HEADER_FILE_ONLY TRUE
-@@ -27,9 +28,7 @@ SET_SOURCE_FILES_PROPERTIES(
- half.cpp
- PROPERTIES
- OBJECT_DEPENDS
-- ${CMAKE_CURRENT_BINARY_DIR}/eLut.h
-- OBJECT_DEPENDS
-- ${CMAKE_CURRENT_BINARY_DIR}/toFloat.h
-+ "${CMAKE_CURRENT_BINARY_DIR}/eLut.h;${CMAKE_CURRENT_BINARY_DIR}/toFloat.h"
- )
-
- IF(BUILD_SHARED_LIBS)